X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

How to get multi-row bookmarks bar?

Geplaatst

For years I've used a userchrome script to show multiple rows of bookmarks, but it no longer works in Firefox 66!

Does anyone know what's gone wrong, or a way this can be fixed?

I cannot function without multi-row bookmarks! I have over 25,000 bookmarks, all neatly organized into folders across five rows of bookmarks. there's no way I could cram all those categories into one single, solitary row.

It's a shame that Firefox has never seriously supported the bookmark bar. It's always been buggy, ugly, cumbersome to use, and never felt very "solid". The menu also has a tendency to disappear, making it hard to organize and drag bookmarks and folders around.

For years I've used a userchrome script to show multiple rows of bookmarks, but it no longer works in Firefox 66! Does anyone know what's gone wrong, or a way this can be fixed? I cannot function without multi-row bookmarks! I have over 25,000 bookmarks, all neatly organized into folders across five rows of bookmarks. there's no way I could cram all those categories into one single, solitary row. It's a shame that Firefox has never seriously supported the bookmark bar. It's always been buggy, ugly, cumbersome to use, and never felt very "solid". The menu also has a tendency to disappear, making it hard to organize and drag bookmarks and folders around.

Gekozen oplossing

https://www.reddit.com/r/FirefoxCSS/

Grab the latest version of that CSS code. Some changes made for Firefox 65 'broke' the older CSS code for certain elements of the UI, a simple edit is needed. I am not aware of any changes made for Firefox 66 though.

Dit antwoord in context lezen 1

Aanvullende systeemdetails

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Meer informatie

the-edmeister
  • Top 25 Contributor
  • Moderator
5420 oplossingen 40435 antwoorden

Gekozen oplossing

https://www.reddit.com/r/FirefoxCSS/

Grab the latest version of that CSS code. Some changes made for Firefox 65 'broke' the older CSS code for certain elements of the UI, a simple edit is needed. I am not aware of any changes made for Firefox 66 though.

https://www.reddit.com/r/FirefoxCSS/ Grab the latest version of that CSS code. Some changes made for Firefox 65 'broke' the older CSS code for certain elements of the UI, a simple edit is needed. I am not aware of any changes made for Firefox 66 though.

Nuttig antwoord

Thanks, the link you gave has the solution - a new code for Firefox 66!

The code I had been using before was very long, but the new code is really small and simple. You just put this in your Userchrome file:

#PersonalToolbar {
  min-height: unset !important;
  max-height: unset !important;
/* text-align: center !important; */
}

#PersonalToolbar #PlacesToolbarItems {
  overflow-x: visible !important;
  overflow-y: visible !important;
  display: inline-block !important;
}
Thanks, the link you gave has the solution - a new code for Firefox 66! The code I had been using before was very long, but the new code is really small and simple. You just put this in your Userchrome file: <pre>#PersonalToolbar { min-height: unset !important; max-height: unset !important; /* text-align: center !important; */ } #PersonalToolbar #PlacesToolbarItems { overflow-x: visible !important; overflow-y: visible !important; display: inline-block !important; }</pre>

Bewerkt door MartyJames op

jscher2000
  • Top 10 Contributor
8838 oplossingen 72245 antwoorden

Nuttig antwoord

Hi MartyJames, if you put <pre> before and </pre> after your CSS, the forum won't mangle it as badly.

Hi MartyJames, if you put &lt;pre> before and &lt;/pre> after your CSS, the forum won't mangle it as badly.

Vraageigenaar

Thanks again, as always, jscher! (I've edited my post.)

Thanks again, as always, jscher! (I've edited my post.)
webref.pl 0 oplossingen 3 antwoorden

MartyJames said

Thanks again, as always, jscher! (I've edited my post.)

@MartyJames Hi, can you share your script for multirow bookmarks? In my case any CSS solution has this problem: https://github.com/Aris-t2/CustomCSSforFx/issues/99#issuecomment-475870631

''MartyJames [[#answer-1206696|said]]'' <blockquote> Thanks again, as always, jscher! (I've edited my post.) </blockquote> @MartyJames Hi, can you share your script for multirow bookmarks? In my case any CSS solution has this problem: https://github.com/Aris-t2/CustomCSSforFx/issues/99#issuecomment-475870631

Bewerkt door webref.pl op

jscher2000
  • Top 10 Contributor
8838 oplossingen 72245 antwoorden

Hi webref.pl, MartyJames posted the new code here:

https://support.mozilla.org/questions/1253700#answer-1206689

Hi webref''.''pl, MartyJames posted the new code here: https://support.mozilla.org/questions/1253700#answer-1206689
webref.pl 0 oplossingen 3 antwoorden

Thx, but I ask for JS code, not CSS.

Thx, but I ask for JS code, not CSS.
jscher2000
  • Top 10 Contributor
8838 oplossingen 72245 antwoorden

webref.pl said

Thx, but I ask for JS code, not CSS.

Why would there be JavaScript involved? JavaScript is not supported in userChrome.css files.

''webref.pl [[#answer-1207524|said]]'' <blockquote> Thx, but I ask for JS code, not CSS. </blockquote> Why would there be JavaScript involved? JavaScript is not supported in userChrome.css files.
webref.pl 0 oplossingen 3 antwoorden

With CSS I have some bug: https://github.com/Aris-t2/CustomCSSforFx/issues/99#issuecomment-475870631

So once again, I need JS code to run in chrome, if anyone see that code for CustomButton or userChrome.js then please share.

With CSS I have some bug: https://github.com/Aris-t2/CustomCSSforFx/issues/99#issuecomment-475870631 So once again, I need JS code to run in chrome, if anyone see that code for CustomButton or userChrome.js then please share.
fabalip 0 oplossingen 1 antwoorden

MartyJames said

Thanks, the link you gave has the solution - a new code for Firefox 66! The code I had been using before was very long, but the new code is really small and simple. You just put this in your Userchrome file:
#PersonalToolbar {
  min-height: unset !important;
  max-height: unset !important;
/* text-align: center !important; */
}

#PersonalToolbar #PlacesToolbarItems {
  overflow-x: visible !important;
  overflow-y: visible !important;
  display: inline-block !important;
}

thank you very much!

''MartyJames [[#answer-1206689|said]]'' <blockquote> Thanks, the link you gave has the solution - a new code for Firefox 66! The code I had been using before was very long, but the new code is really small and simple. You just put this in your Userchrome file: <pre>#PersonalToolbar { min-height: unset !important; max-height: unset !important; /* text-align: center !important; */ } #PersonalToolbar #PlacesToolbarItems { overflow-x: visible !important; overflow-y: visible !important; display: inline-block !important; }</pre> </blockquote> thank you very much!
Harakiri 0 oplossingen 2 antwoorden

I encounter the same issue again after updating to Firefox 69.0.

Anyone can help me? The old css-code does not work :(

I encounter the same issue again after updating to Firefox 69.0. Anyone can help me? The old css-code does not work :(
jscher2000
  • Top 10 Contributor
8838 oplossingen 72245 antwoorden

Hi Harakiri, the items that do not fit on the first row have

style="visibility: hidden"

To counter that, add this to your existing set of rules (March 24th post):

#PersonalToolbar #PlacesToolbarItems toolbarbutton {
  visibility: visible !important;
}
Hi Harakiri, the items that do not fit on the first row have style="visibility: hidden" To counter that, add this to your existing set of rules (March 24th post): <pre>#PersonalToolbar #PlacesToolbarItems toolbarbutton { visibility: visible !important; } </pre>
Harakiri 0 oplossingen 2 antwoorden

Many thanks jscher2000, this solved it.

Besides, I noticed Firefox 69 will no longer look for the userChromse.css file automatically and users need to "activate it" in
about:config 
and search for "userprof" and then change the value from false to true for
toolkit.legacyUserProfileCustomizations.stylesheets 
as described here.
Many thanks jscher2000, this solved it. Besides, I noticed Firefox 69 will no longer look for the userChromse.css file automatically and users need to "activate it" in <pre>about:config </pre> and search for "userprof" and then change the value from false to true for <pre>toolkit.legacyUserProfileCustomizations.stylesheets </pre> as described [https://www.userchrome.org/how-create-userchrome-css.html here].
jscher2000
  • Top 10 Contributor
8838 oplossingen 72245 antwoorden

Harakiri said

Besides, I noticed Firefox 69 will no longer look for the userChromse.css file automatically and users need to "activate it" in
about:config 
and search for "userprof" and then change the value from false to true for
toolkit.legacyUserProfileCustomizations.stylesheets 
as described here.

If you are carrying over your existing settings from Firefox 68 to Firefox 69, the preference should already be true, but if it's a new profile or you didn't have userChrome.css set up before, you will indeed need to flip that preference yourself.

''Harakiri [[#answer-1250562|said]]'' <blockquote> Besides, I noticed Firefox 69 will no longer look for the userChromse.css file automatically and users need to "activate it" in <pre>about:config </pre> and search for "userprof" and then change the value from false to true for <pre>toolkit.legacyUserProfileCustomizations.stylesheets </pre> as described [https://www.userchrome.org/how-create-userchrome-css.html here]. </blockquote> If you are carrying over your existing settings from Firefox 68 to Firefox 69, the preference should already be true, but if it's a new profile or you didn't have userChrome.css set up before, you will indeed need to flip that preference yourself.

Vraageigenaar

Hi Jscher and thanks for all your amazingly helpful advice, as always! You're such a great guy!

I had the same problem when I upgraded to Firefox 69 so I started a new thread and Cor-el helped me (https://support.mozilla.org/en-US/questions/1268036)

The solution that worked for me concerns this line of code:

@-moz-document url(chrome://browser/content/browser.xul)

I just changed ".xul" to ".xhtml" and it worked!

Hi Jscher and thanks for all your amazingly helpful advice, as always! You're such a great guy! I had the same problem when I upgraded to Firefox 69 so I started a new thread and Cor-el helped me (https://support.mozilla.org/en-US/questions/1268036) The solution that worked for me concerns this line of code: <code>@-moz-document url(chrome://browser/content/browser.xul)</code> I just changed ".xul" to ".xhtml" and it worked!

Bewerkt door MartyJames op