Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Why is Firefox making a connection to cloudfront.net after startup (which is kept established the whole time)?

  • 3 antwoorden
  • 10 hebben dit probleem
  • 134 weergaven
  • Laatste antwoord van philipp

more options

When I start Firefox and only a blank page is shown, it still makes an https connection to cloudfront.net . It even does that after following all advice on https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections . When testing, I disabled all addons, plugins and language packs, too.

Why does make Firefox make this connection? What is transmitted? How can I disable it?

When I start Firefox and only a blank page is shown, it still makes an https connection to cloudfront.net . It even does that after following all advice on https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections . When testing, I disabled all addons, plugins and language packs, too. Why does make Firefox make this connection? What is transmitted? How can I disable it?

Gekozen oplossing

thank you for bringing this up - looks like we have to update that page in the knowledge base. in order to disable heartbeat, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.selfsupport.url. double-click it and change its value to a blank string. https://wiki.mozilla.org/Advocacy/heartbeat

Dit antwoord in context lezen 👍 2

Alle antwoorden (3)

more options

hi, can you launch firefox with the -jsconsole argument and look in the network tab of the browser console if you find more information about that connection there (like the exact url - this might give more information about what is happening)... https://developer.mozilla.org/docs/Tools/Browser_Console

more options

The exact server being contacted is server-54-230-219-14.mrs50.r.cloudfront.net Thank you for your hint about the browser console! After looking there, I found that the connection corresponds to a connection to https://self-repair.mozilla.org/de/repair/ . Now, I see that this corresponds to "Firefox Heartbeat". I didn't know it existed and it isn't listed on the help page that lists automatic connections. I never received a prompt for a rating from Firefox. I don't understand why this makes a connection at every Firefox startup.

more options

Gekozen oplossing

thank you for bringing this up - looks like we have to update that page in the knowledge base. in order to disable heartbeat, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.selfsupport.url. double-click it and change its value to a blank string. https://wiki.mozilla.org/Advocacy/heartbeat