browser.download.lastDir.savePerSite does not work

When downloading files, Firefox no longer remembers the directory path the file was previously saved to on a per-URL basis. Previous Firefox behavior: #1. download file … (read more)

When downloading files, Firefox no longer remembers the directory path the file was previously saved to on a per-URL basis.

Previous Firefox behavior: #1. download file from website "aaaa.com" to a folder on your computer, "user/frank/companies/aaaa/". #2. download file from website "bbbb.com" to a folder on your computer, "user/frank/companies/bbbb/". #3. Now, go back to the website "aaaa.com" and attempt to download another file. Firefox used to present the previously used directory for this particular URL, in this case, "user/frank/companies/aaaa/" - but instead, now it presents the most recently used directory path, which was "user/frank/companies/bbbb/".

This issue has appeared before and the advice to fix it was to go about:config, search for browser.download.lastDir.savePerSite and make sure it is set at TRUE. I have done this, but the issue remains: Firefox no longer remembers saved file directory paths on a per-URL basis.

MacOS 11.6.6 (Big Sur); Latest Firefox (103.0.2) Attempts to fix: Safe Mode - issue still present; Refresh Firefox - issue still present

Is there any advice on how to fix this problem? - Thxs.

Asked by water.hog 32 seconds ago

bookmark subfolders just disappear. If I do a search for a link, find it, and select "open folder", lost folders re-appear.

My problem is: Many times my bookmark subfolders just disappear. If I do a search for a link in any of the lost folders at the top, find the link and select "open folder… (read more)

My problem is: Many times my bookmark subfolders just disappear.

If I do a search for a link in any of the lost folders at the top, find the link and select "open folder", the lost folders re-appear.

I imagine the folders are linked lists.

I wonder if the brower refresh or not refreshing is the issue. A display problem. Since they reappear, they are still there in memory. I doubt if they been written to the harddrive.

It is very frustrating. As I've read many others having similar issues, I think it merits attention.

Let them know to search for the link and open it in it's folder to reestablish the display. This IS NOT THE ANSWER ... but it is a work around.

I've systematically tried to troubleshoot it, but have found no clue for predicting when it will happen.

I was a programmer/analyst for decades. I imagine trying to keep firefox working is a real challenge.

Thanks Greg

Asked by JGDolezal 1 minute ago

History has partially disappeared

I got a new laptop recently and yesterday I installed Firefox and started up Sync. Today, on my previous laptop, I notice that a couple years worth of history are now mis… (read more)

I got a new laptop recently and yesterday I installed Firefox and started up Sync. Today, on my previous laptop, I notice that a couple years worth of history are now missing from the beginning of the time when I used it! What can I do? I have turned off Sync now because someone told me last year to do that when I had a problem with Sync, to keep it from spreading (https://support.mozilla.org/en-US/questions/1345759).

Asked by Eric_Kvaalen 1 day ago

Last reply by Eric_Kvaalen 7 minutes ago

Bing as default search engine - ONLY search engine

I recently installed Firefox 103.0.2 (64-bit) on my brand-new Windows 11 HP ENVY desktop. Now matter how I decobnfigure Bing as a search engine, the browser always defaul… (read more)

I recently installed Firefox 103.0.2 (64-bit) on my brand-new Windows 11 HP ENVY desktop. Now matter how I decobnfigure Bing as a search engine, the browser always defaults to Bing when I search in the search field at the top. i even made google.com my home page, and even when I search on the page itself, it changes to Bing.

I don't think it was misbehaving like this on my previous computer that died. It was running Windows 10 and was up-to-date Firefox-wise in early July.

There is a screen shot of my configuration attached. The dropdown under the Google logo has no other items in the dropdown.

Asked by steinsteve 16 minutes ago

Error message

I have already sent you the exact information that depicts what is happening! What I got back from you is question after question trying to figure out what the problem is… (read more)

I have already sent you the exact information that depicts what is happening! What I got back from you is question after question trying to figure out what the problem is! Pages of absolute junk that have nothing to do with my problem! What does it take to get through to you people?! You sent me a reply that asks me a question: "Does it work if you allow to go to the HTTP version of the website as in some cases a redirect only works via HTTP and you will eventually end up on a secure HTTPS site?"...but your email is unable to be replied to and you offer no way to tell you my answer! If I am reading your question right, the answer is "YES".

I was able to figure out how to get your system to upload the error image and it is here within. The snip says it pertains to a website called "Western Journal", but I have gotten the error message on other sites as well. I repeat, from my original missive, although it claims to only be able to go to a non-HTTPS site, when I choose to go to that site, it shows in the address box, "HTTPS". Have I been hacked? In 25 years of using a computer, I have never seen this error message that seems to contradict itself. Please help and let me reply to you emails. Wayne Ollick, Overviewer1@outlook.com

Asked by Overviewer 2 hours ago

Last reply by Overviewer 16 minutes ago

Firefox not starting windows 10

Win 10laptop had Firefox installed and working. Suddenly stopped after some windows updates. I have Uninstalled several times, both vanilla and using IOBIT program. Delet… (read more)

Win 10laptop had Firefox installed and working. Suddenly stopped after some windows updates. I have Uninstalled several times, both vanilla and using IOBIT program. Deleted the program file folder, and the local apps profile. Won't start in safe mode either. I don't even see anything in task manager when clicking. No error messages.

However.....tried installing developer version and it works fine!

Any thoughts?

Thanks!

Asked by firefox1941 1 hour ago

Last reply by jscher2000 - Support Volunteer 21 minutes ago

Developer Edition Crashing

As of 16 August Firefox Development Edition continually crashes. Firefox standard is fine. Tried the following 1. Shutdown and restart 2. Refresh 3. Uninstall, download a… (read more)

As of 16 August Firefox Development Edition continually crashes.

Firefox standard is fine.

Tried the following 1. Shutdown and restart 2. Refresh 3. Uninstall, download and reinstall (4 times) 4. Chkdsk /r with restart then uninstall and reinstall 5. Open in troubleshoot mode 6. Tried incognito window 7. Tried disabling AV (Eset)

No change other than when the crash happens. Initially it would require opening a few tabs and browsing - now it crashes on startup.

Given that no other applications are behaving adversely, that Firefox standard works, that this was working find until 12 hours ago - my suspicion is it is something to do with the Developer edition.

Any other suggestions welcome.

Asked by julian11 7 hours ago

Last reply by Paul 40 minutes ago

Firefox consitently crashes on exit. Takes several minutes to open next time.

Running Firefox 103.0.2 (64 bit) over windows 10 on a Dell Latitude E5440. At the end of the day, I close Firefox. It takes several minutes for the 8 or so processes tha… (read more)

Running Firefox 103.0.2 (64 bit) over windows 10 on a Dell Latitude E5440.

At the end of the day, I close Firefox. It takes several minutes for the 8 or so processes that linger in the system to exit. 2 minutes after that, I get the Firefox Crashed pop-up. I always send the crash report.

On restart, Firefox takes 3-5 minutes to load data from contile-images.services.mozilla.com before I can actually use the browser.

This happens daily, whether Firefox is the first or last application closed, or whether I wait several minutes after everything else is closed before I close Firefox.

Are there settings I can change to prevent this?

Thanks,

--j

Asked by jade8 2 hours ago

Last reply by Paul 40 minutes ago

HTTPS not available error message

Error message says: "HTTPS not available on this site" Choices: : "Go back" or "Continue to HTTP only site". If I choose "Continue to HTTP site", the address bar shows th… (read more)

Error message says: "HTTPS not available on this site" Choices: : "Go back" or "Continue to HTTP only site". If I choose "Continue to HTTP site", the address bar shows that the address is indeed HTTPS! Have I been hacked? Do I have a virus? I can find no help elsewhere. I have saved the error message but, using your "Browse" below will not show it in my documents.

Asked by Overviewer 6 days ago

Last reply by jscher2000 - Support Volunteer 41 minutes ago

Developer Edition Crashing

As of 16 August Firefox Development Edition continually crashes. Firefox standard is fine. Tried the following 1. Shutdown and restart 2. Refresh 3. Uninstall, download a… (read more)

As of 16 August Firefox Development Edition continually crashes.

Firefox standard is fine.

Tried the following 1. Shutdown and restart 2. Refresh 3. Uninstall, download and reinstall (4 times) 4. Chkdsk /r with restart then uninstall and reinstall 5. Open in troubleshoot mode 6. Tried incognito window 7. Tried disabling AV (Eset)

No change other than when the crash happens. Initially it would require opening a few tabs and browsing - now it crashes on startup.

Given that no other applications are behaving adversely, that Firefox standard works, that this was working find until 12 hours ago - my suspicion is it is something to do with the Developer edition.

Any other suggestions welcome.

Asked by julian11 6 hours ago

Last reply by Paul 41 minutes ago

Firefox Developer Edition crashes on startup, even in troubleshooting mode

I tried a clean Firefox Dev install On MBP M1 2020 Monterey 12.5 MacOS is up to date. Crash ID bp-63427f0f-a1fc-45b0-84da-46f710220816 Crash report AdapterVendorID: … (read more)

I tried a clean Firefox Dev install On MBP M1 2020 Monterey 12.5 MacOS is up to date. Crash ID bp-63427f0f-a1fc-45b0-84da-46f710220816

Crash report AdapterVendorID: 0x106b AvailablePhysicalMemory: 4841553920 AvailableSwapMemory: 0 BackgroundTaskMode: 0 BuildID: 20220811191329 ContentSandboxCapable: 1 ContentSandboxLevel: 3 CrashTime: 1660673653 DOMFissionEnabled: 1 DOMIPCEnabled: 1 EventLoopNestingLevel: 1 ExperimentalFeatures: devtools.inspector.compatibility.enabled GraphicsNumActiveRenderers: 1 GraphicsNumRenderers: 1 HeadlessMode: 0 InstallTime: 1660616909 MacAvailableMemorySysctl: 87 MacMemoryPressure: Normal MacMemoryPressureCriticalTime: Unset MacMemoryPressureNormalTime: 1660673624 MacMemoryPressureSysctl: 1 MacMemoryPressureWarningTime: Unset Notes: FP(D00-L1000-W00000000-T000) WR? WR+ GL Context? GL Context+ ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox PurgeablePhysicalMemory: 538312704 ReleaseChannel: aurora SafeMode: 1 SecondsSinceLastCrash: 152 StartupCrash: 0 StartupTime: 1660673624 SubmittedFrom: Client TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"aarch64","buildId":"20220811191329","version":"104.0","vendor":"Mozilla","displayVersion":"104.0b9","platformVersion":"104.0","xpcomAbi":"aarch64-gcc3","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":16384,"virtualMaxMB":null,"cpu":{"extensions":["hasNEON"]},"os":{"name":"Darwin","version":"21.6.0","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null,"type":null},"binary":{"model":null,"revision":null,"type":null},"system":{"model":null,"revision":null,"type":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","Headless":false,"EmbeddedInFirefoxReality":null,"adapters":[{"description":null,"vendorID":"0x106b","deviceID":null,"subsysID":null,"RAM":0,"driver":null,"driverVendor":null,"driverVersion":null,"driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":2880,"screenHeight":1800,"scale":2},{"screenWidth":1920,"screenHeight":1080,"scale":1}],"features":{"compositor":"webrender_software","hwCompositing":{"status":"blocked:FEATURE_FAILURE_COMP_SAFEMODE"},"gpuProcess":{"status":"unused"},"wrQualified":{"status":"available"},"webrender":{"status":"unavailable-in-safe-mode"},"wrCompositor":{"status":"available"},"wrSoftware":{"status":"available"},"openglCompositing":{"status":"unavailable:FEATURE_FAILURE_OPENGL_NEED_HWCOMP"},"omtp":{"status":"unused"}}},"appleModelId":"MacBookPro17,1","hasWinPackageId":null},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":8,"fissionEnabled":true,"telemetryEnabled":true,"locale":"en-US","intl":{"requestedLocales":["en-US"],"availableLocales":["en-US"],"appLocales":["en-US"],"systemLocales":["en-US"],"regionalPrefsLocales":["en-US"],"acceptLanguages":["en-US","en"]},"update":{"channel":"aurora","enabled":true,"autoDownload":true,"background":true},"userPrefs":{"browser.fixup.alternate.enabled":false,"browser.newtabpage.enabled":false,"browser.search.region":"US","browser.search.widget.inNavBar":false,"browser.startup.homepage":"<user-set>","browser.urlbar.autoFill":true,"browser.urlbar.autoFill.adaptiveHistory.enabled":false,"browser.urlbar.dnsResolveSingleWordsAfterSearch":0,"browser.urlbar.quicksuggest.dataCollection.enabled":false,"browser.urlbar.suggest.quicksuggest.nonsponsored":true,"browser.urlbar.suggest.quicksuggest.sponsored":true,"browser.urlbar.suggest.bestmatch":true,"media.gmp-gmpopenh264.lastInstallStart":1659887702,"media.gmp-gmpopenh264.lastDownload":1659887702,"media.gmp-gmpopenh264.lastUpdate":1659887702,"media.gmp-manager.lastCheck":1660617143,"media.gmp-manager.lastEmptyCheck":1660617143,"network.trr.strict_native_fallback":false,"privacy.donottrackheader.enabled":true,"widget.content.allow-gtk-dark-theme":false,"widget.content.gtk-high-contrast.enabled":true},"sandbox":{"effectiveContentProcessLevel":3,"contentWin32kLockdownState":3},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":true,"defaultSearchEngine":"ddg","defaultSearchEngineData":{"loadPath":"[other]addEngineWithDetails:ddg@search.mozilla.org","name":"DuckDuckGo","origin":"default","submissionURL":"https://duckduckgo.com/?t=ffsb&q="}},"profile":{"creationDate":19198,"firstUseDate":19198},"addons":{"activeAddons":{"doh-rollout@mozilla.org":{"version":"2.0.0","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"This used to be a Mozilla add-on that supported the roll-out of DoH, but now only exists as a stub t","name":"DoH Roll-Out","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188},"formautofill@mozilla.org":{"version":"1.0.1","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":null,"name":"Form Autofill","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188},"pictureinpicture@mozilla.org":{"version":"1.0.0","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Fixes for web compatibility with Picture-in-Picture","name":"Picture-In-Picture","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188},"screenshots@mozilla.org":{"version":"39.0.1","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Take clips and screenshots from the Web and save them temporarily or permanently.","name":"Firefox Screenshots","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188},"webcompat-reporter@mozilla.org":{"version":"1.5.0","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Report site compatibility issues on webcompat.com","name":"WebCompat Reporter","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188},"webcompat@mozilla.org":{"version":"104.0.0","scope":1,"type":"extension","updateDay":19215,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Urgent post-release fixes for web compatibility.","name":"Web Compatibility Interventions","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19188}},"theme":{"id":"firefox-compact-dark@mozilla.org","blocklisted":false,"description":"A theme with a dark color scheme.","name":"Dark","userDisabled":false,"appDisabled":false,"version":"1.2","scope":4,"foreignInstall":false,"hasBinaryComponents":false,"installDay":19198,"updateDay":19198},"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.8.1.2","userDisabled":false,"applyBackgroundUpdates":1},"gmp-widevinecdm":{"version":"4.10.2449.0","userDisabled":false,"applyBackgroundUpdates":1}}},"experiments":{"tcp-rollout-aurora-phase-iii-tcp-on-by-default-for-100-aurora-profiles":{"branch":"control","type":"nimbus-nimbus","enrollmentId":"6999ed06-b4b8-43ff-9815-7527485c4476"}},"services":{"accountEnabled":true,"syncEnabled":true}} Throttleable: 1 TotalPhysicalMemory: 17179869184 UptimeTS: 29.833333333333332 Vendor: Mozilla Version: 104.0 useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

Asked by cfairhurst1 2 hours ago

Last reply by Paul 41 minutes ago

I can't get my FF Dev Edition to open without crashing

Please help, I rely heavily on FF Dev Edition for my job. I'm a web dev. I've tried starting in Troubleshoot mode, still crashes... I've tried the Refresh FF option, st… (read more)

Please help,

I rely heavily on FF Dev Edition for my job. I'm a web dev.

I've tried starting in Troubleshoot mode, still crashes... I've tried the Refresh FF option, still crashes... I've tried manually installing all over again, still crashes...

Please help. I looked at the crashes tab but don't know what to make of it. The crash ID from my last crash is:

BDEC3386-ECDF-4B5B-824B-6AC9CD19C6F7

Let me know if you need anything else - thanks in advance! John

Asked by John Schulz 1 hour ago

Last reply by Paul 42 minutes ago

A different O/S than Windows

I was wondering if you were aware of any projects in the computer industry to come up with a new PC O/S since windows has become so unfriendly and autocratic with win 10… (read more)

I was wondering if you were aware of any projects in the computer industry to come up with a new PC O/S since windows has become so unfriendly and autocratic with win 10 & I imagine 11 as well? As you are one of the more important players in the home and business computer world, I figure you folks would know much more than I, and know it way before I do. I do not want to get another windows machine. I had to fight it to get your superior web browser to be and stay the default browser over something called "edge", as an example. Us Boomers have been buying PC's for 40+ years and the software too. Then we choose what we want installed and ignore the rest. And we never heard of buying a program then also paying rent to some overlord. Talking to friends of similar age, this is a huge reason PC sales are falling. Win 10 &11 were such a traumatic shock to us. My wife (age 72) was so angry she went out and purchased Apple notebook, ipad and iphone and gave her windoze junk to the trash man after a thorough scrubbing. At age 72 she undertook learning a new O/S to get away from MSFT. (I try hard not to get her real angry!)

Thank you in advance for any help you may provide. I think quantum computers are a few years out yet, so there is a need.

Asked by rhsbdld 56 minutes ago

Last reply by jscher2000 - Support Volunteer 43 minutes ago

Won't correctly load amazon's website.

I've tried "refreshing Firefox", CTR+ALT+DEL to end program, but it still doesn't load Amazon's page. I have attached a screenshot of how it loads. Nothing is able to … (read more)

I've tried "refreshing Firefox", CTR+ALT+DEL to end program, but it still doesn't load Amazon's page. I have attached a screenshot of how it loads. Nothing is able to be clicked on, and on other Amazon pages its just words with almost no images.

Asked by cyclist5000 1 hour ago

  • Solved

hide bookmark text in Firefox (reveal text on mouse hover)

Hey :) https://support.mozilla.org/en-US/questions/1265175 This no longer seems to work on my new mac (M1, FF 103.0.2) Or maybe I did something wrong but I cannot figure … (read more)

Hey :)

https://support.mozilla.org/en-US/questions/1265175 This no longer seems to work on my new mac (M1, FF 103.0.2)

Or maybe I did something wrong but I cannot figure it out.

Basically, I get no change whatsoever after creating the userChrome.css file and placing it in the appropriate "chrome" folder in my profile folder...

Please help me figure this out.

Best, Julien

Asked by juliendalcol 1 hour ago

Answered by juliendalcol 1 hour ago

  • Solved

Stop auto-download for Version 98.0.1 (64-bit)

Hi, new updates on Version 98.0.1 quite a hassle for me. It auto-download all my files even when I just want to view. Is there any other way to disable this feature? I op… (read more)

Hi, new updates on Version 98.0.1 quite a hassle for me. It auto-download all my files even when I just want to view. Is there any other way to disable this feature? I opened Setting>Download but there is no disable button or checkbox for that. Please help me. Thank you in advance.

Asked by miszluuna 4 months ago

Answered by Terry 4 months ago

youtube doesn't play

Hi! For the past month or so, some youtube clips keeps on loading and do not play. When I switch to another video, it either plays or keeps loading again. Refreshing th… (read more)

Hi!

For the past month or so, some youtube clips keeps on loading and do not play.

When I switch to another video, it either plays or keeps loading again. Refreshing the page doesn't help. Clearing data (cookies, site data, and cache) do not help either. The only solution is to close the window which I'd rather not have to do every time. There doesn't seem to be any rule to the types of clips that plays or doesn't. Any ideas?

I'm using windows 10. Firefox is the latest 103.0.2 (64-bit). Thank you!

Asked by doritos 2 days ago

Last reply by TechHorse 2 hours ago