X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 29 is painfully slow

Posted

What happened with Firefox 29? It is PAINFULLY slow. Sometimes switching between tabs takes a matter of seconds. Have a video running and FF often times out when switching between tabs and needs to be shut down.

Not running a slow or overloaded system by any means. Something is very wrong with this update.

Any idea how to fix this or degrade to FF 28, which worked amazingly well?

What happened with Firefox 29? It is PAINFULLY slow. Sometimes switching between tabs takes a matter of seconds. Have a video running and FF often times out when switching between tabs and needs to be shut down. Not running a slow or overloaded system by any means. Something is very wrong with this update. Any idea how to fix this or degrade to FF 28, which worked amazingly well?

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • VLC media player Web Plugin 2.1.3
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • 5.1.20513.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to internet for Firefox and the plugin-container process and the updater process.

See:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/fix-problems-connecting-websites-after-updating
user1084514 0 solutions 1 answers

Had this problem too, here's what worked for me; open task manager, go to processes, right click on Firefox, choose set priority set it to high.

Had this problem too, here's what worked for me; open task manager, go to processes, right click on Firefox, choose set priority set it to high.
DeepFrz 0 solutions 3 answers

This helped a little but not much.

This helped a little but not much.
acsmith1972 0 solutions 17 answers

Helpful Reply

Mozilla's support for faulty products is it's always you, never them. Has to be an add-on or extension. If it's not that they blame your antivirus. If it's not that they blame your OS. If it's not that they'll say your specs need upgrading even when every other browser manufacturer works fine. Safari's a beast and that work faster than FF. I just started using Chrome more and more. Mozilla doesn't seem to care about users. I even stopped using Thunderbird since it's just as buggy.

Mozilla's support for faulty products is it's always you, never them. Has to be an add-on or extension. If it's not that they blame your antivirus. If it's not that they blame your OS. If it's not that they'll say your specs need upgrading even when every other browser manufacturer works fine. Safari's a beast and that work faster than FF. I just started using Chrome more and more. Mozilla doesn't seem to care about users. I even stopped using Thunderbird since it's just as buggy.
kobe 441 solutions 5048 answers

If the safe mode suggestion does not resolve your issue, please consider creating a new thread containing the specific details of your issue.

Also include troubleshooting information when asked.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.

If the safe mode suggestion does not resolve your issue, please consider creating a new thread containing the specific details of your issue. Also include troubleshooting information when asked. * [[Use the Troubleshooting Information page to help fix Firefox issues]] Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently. Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you. Thank you.
FredMcD
  • Top 10 Contributor
4267 solutions 59840 answers

acsmith1972; If you are not going to post something useful, why post anything?

acsmith1972; If you are not going to post something useful, why post anything?
FredMcD
  • Top 10 Contributor
4267 solutions 59840 answers

alcahuete; When you tried Starting Firefox in Safe Mode, what did or didn't happen?

While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.
Then check ALL of your settings. Browser and add-ons. Then restart.

alcahuete; When you tried '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Starting Firefox in Safe Mode],''''' what did or didn't happen? <BR><BR>While you are in safe mode;<BR> '''''Firefox Options > Advanced > General'''''.<BR> Look for and turn off '''Use Hardware Acceleration'''.<BR> Then check ALL of your settings. Browser and add-ons. Then restart.
rwk2095 1 solutions 4 answers

Helpful Reply

For me this problems started with version 29. In another thread it was suggested that hardware acceleration might be the problem. I turned off hardware acceleration, and that fixed the problem.

>>Tools>Options>Advanced>General Tab>Use hardware acceleration when available <<= uncheck

For me this problems started with version 29. In another thread it was suggested that hardware acceleration might be the problem. I turned off hardware acceleration, and that fixed the problem. >>Tools>Options>Advanced>General Tab>Use hardware acceleration when available <<= uncheck