X
Tap here to go to the mobile version of the site.

Support Forum

Flash plugin detected but not working (Firefox 22 on Linux)

Posted

Hi all,

I can't get the flash plugin to work. It's installed, detected in about:plugins, but when I visit adobes's test page at http://www.adobe.com/fr/shockwave/welcome/ , I just get the usual " you need a plugin to view this content" thing.

This happenned since I migrated from Mageia 1 to Mageia 2, and still doesn't work on Mageia 3, which uses Firefox 17 ESR. I then downloaded and installed Firefox 22 directly from Mozilla, still with no luck. I've reset my profile, tried to use an empty profile, tried disabling all add-ons, still no luck.

about:plugins displays this:

   File : libflashplayer.so
   Path : /opt/firefox/browser/plugins/libflashplayer.so
   Version : 11,2,202,297
   State : Enabled
   Shockwave Flash 11.2 r202

This is the most up-to-date flash version available from Adobe.

Another thing is that this machine is a 32 bits install, on an Athlon XP 3000+ with a Radeon X1650 graphics card. Surprisingly, on another machine, using the same distro but with a 64 bits install, Flash works well.

I'm out of ideas now, so any hint would be welcome. Thank you.

Hi all, I can't get the flash plugin to work. It's installed, detected in about:plugins, but when I visit adobes's test page at http://www.adobe.com/fr/shockwave/welcome/ , I just get the usual " you need a plugin to view this content" thing. This happenned since I migrated from Mageia 1 to Mageia 2, and still doesn't work on Mageia 3, which uses Firefox 17 ESR. I then downloaded and installed Firefox 22 directly from Mozilla, still with no luck. I've reset my profile, tried to use an empty profile, tried disabling all add-ons, still no luck. about:plugins displays this: File : libflashplayer.so Path : /opt/firefox/browser/plugins/libflashplayer.so Version : 11,2,202,297 State : Enabled Shockwave Flash 11.2 r202 This is the most up-to-date flash version available from Adobe. Another thing is that this machine is a 32 bits install, on an Athlon XP 3000+ with a Radeon X1650 graphics card. Surprisingly, on another machine, using the same distro but with a 64 bits install, Flash works well. I'm out of ideas now, so any hint would be welcome. Thank you.

Chosen solution

Maybe the videos you can see are served in HTML5, and thus may be plyed without Flash. Just right click on the video to check that. But this is a different problem.

I solved my problem by following the instructions there: https://wiki.mageia.org/en/Flash_Plugin_Installation

Recent versions of Adobe 11.2 for Linux are built for processors with the SSE2 instruction set. This is present since Intel Pentium IV and AMD Athlon 64, but my AMD Athlon XP is older and only handles SSE, as you may see here: http://en.wikipedia.org/wiki/List_of_AMD_Athlon_XP_microprocessors

So you need an older version of Flash built for SSE, or the 11.2 flash plugin shipped until Google Chrome 19, which is built for SSE.

Download that libgcflashplayer.so file, rename it into libflashplayer.so, and put it in your /usr/lib/mozilla/plugins directory.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/Linux/fr/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Ghostery 2.9.6 (firefox@ghostery.com)
  • Google/Yandex search link fix 1.4 (jid0-XWJxt5VvCXkKzQK99PhZqAn7Xbg@jetpack)
  • Movable Firefox Button 1.4 (movableAppButton@Merci.chao)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: X.Org R300 Project -- Gallium 0.4 on ATI RV530
  • adapterDeviceID: Gallium 0.4 on ATI RV530
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org R300 Project
  • driverDate:
  • driverVersion: 2.1 Mesa 9.1.3
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org R300 Project -- Gallium 0.4 on ATI RV530
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373453250
  • places.history.expiration.transient_current_max_pages: 39696
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugins.click_to_play: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

Helpful Reply

Shockwave also known as Shockwave for Director is not the same as the Shockwave Flash Player. *https://support.mozilla.org/kb/Using+the+Shockwave+plugin+with+Firefox *https://support.mozilla.org/kb/Managing+the+Flash+plugin You can test the Flash plugin here: *http://www.adobe.com/fr/software/flash/about/ *http://www.adobe.com/software/flash/about/

Question owner

Seems you're right about the test page, the link I pasted is wrong, as the plugin I'm told to install there is for MIME type application/x-director.

However I had used the right Flash Player test page too, but all I get is a blank windows where the Flash content should be. But the message telling me I need a plugin to display the page has disappeared, which is more consistent with the fact that the plugin is seen as installed and enabled by Firefox.

Seems you're right about the test page, the link I pasted is wrong, as the plugin I'm told to install there is for MIME type ''application/x-director''. However I had used the right [http://example.com Flash Player test page] too, but all I get is a blank windows where the Flash content should be. But the message telling me I need a plugin to display the page has disappeared, which is more consistent with the fact that the plugin is seen as installed and enabled by Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

The Shockwave for Director player is not available for Linux, so your are out of luck if you really need that player as application/x-director would indicate.

The Shockwave for Director player is not available for Linux, so your are out of luck if you really need that player as application/x-director would indicate.

Question owner

No, I need the Flash Player plugin, I don't care about Shockwave for Director.

No, I need the Flash Player plugin, I don't care about Shockwave for Director.
leon244 0 solutions 7 answers

I am having a similar problem. I am using Mandriva 2011. It uses FF 15.0 and was working with flash-plugin 11.2.202.285, but fails to work under 11.2.202.297. I then downloaded FF 22, placed it in /opt. My install is a 64 bit, so I installed the FF 22 which is 32 bit and installed a 32 bit flash-player but it fails to play. I get the message that I need flash plugin installed. I reverted Flash-player back to the .285 version so the FF15.0 would work. That is a 64 bit flash-plugin at /usr/lib64/mozilla/plugins.

For FF22, I have placed the plugins at /usr/lib/mozilla/plugins. This worked for the java plugin, but no dice with the flash plugin.

Is it flash-plugin or FF 22?

I am having a similar problem. I am using Mandriva 2011. It uses FF 15.0 and was working with flash-plugin 11.2.202.285, but fails to work under 11.2.202.297. I then downloaded FF 22, placed it in /opt. My install is a 64 bit, so I installed the FF 22 which is 32 bit and installed a 32 bit flash-player but it fails to play. I get the message that I need flash plugin installed. I reverted Flash-player back to the .285 version so the FF15.0 would work. That is a 64 bit flash-plugin at /usr/lib64/mozilla/plugins. For FF22, I have placed the plugins at /usr/lib/mozilla/plugins. This worked for the java plugin, but no dice with the flash plugin. Is it flash-plugin or FF 22?
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

You can also try to create a plugins folder in the Firefox profile folder and place the plugin (or a symlink) in that folder.

You can also try to create a plugins folder in the Firefox profile folder and place the plugin (or a symlink) in that folder.

Question owner

@cor-el: I already tried the installation in the plugins directory of the profile. I've read the path has changed since Firefox 21 to browser/plugins instead of plugins. But it didn't fix my problem.

@cor-el: I already tried the installation in the plugins directory of the profile. I've read the path has changed since Firefox 21 to browser/plugins instead of plugins. But it didn't fix my problem.
David_J 0 solutions 2 answers

There seems to be a stupid bug in the Firefox/Flash player interface. Background: Suse Linux v12.2 - Firefox v22 - Adobe Flash Player v11,2,202,297 Symptoms: Go to Youtube, ,select a download, a black rectangle appears where the video should play but nothing further happens. Cure: In Firefox click to Tools->Add Ons->Plugins. It should show that Shockwave Flash is present. Click the Disable Button, then go to Youtube and select what you will. A rectangle will appear in the big black one saying you need to enable the plug-in, then the video will play soon after.

There seems to be a stupid bug in the Firefox/Flash player interface. Background: Suse Linux v12.2 - Firefox v22 - Adobe Flash Player v11,2,202,297 Symptoms: Go to Youtube, ,select a download, a black rectangle appears where the video should play but nothing further happens. Cure: In Firefox click to Tools->Add Ons->Plugins. It should show that Shockwave Flash is present. Click the Disable Button, then go to Youtube and select what you will. A rectangle will appear in the big black one saying you need to enable the plug-in, then the video will play soon after.

Question owner

@David_J: Disabling the plugin, refreshing the youtube page, then re-enabling the plugin and refreshing again the page doesn't work for me. I get a black screen, and even right clicking I don't get the Flash context menu.

@David_J: Disabling the plugin, refreshing the youtube page, then re-enabling the plugin and refreshing again the page doesn't work for me. I get a black screen, and even right clicking I don't get the Flash context menu.
David_J 0 solutions 2 answers

You seem to miss the point. You leave the plugin disabled and then it runs for 80% of the Youtube videos. On the other 20% of Youtube videos and 90% of Daily Motion ones, I get the message "The Adobe Flash Player is required for video playback", even though it has been running OK for the other videos. Strange, but I guess there is a problem with the interface between the two packages.

You seem to miss the point. You leave the plugin disabled and then it runs for 80% of the Youtube videos. On the other 20% of Youtube videos and 90% of Daily Motion ones, I get the message "The Adobe Flash Player is required for video playback", even though it has been running OK for the other videos. Strange, but I guess there is a problem with the interface between the two packages.

Chosen Solution

Maybe the videos you can see are served in HTML5, and thus may be plyed without Flash. Just right click on the video to check that. But this is a different problem.

I solved my problem by following the instructions there: https://wiki.mageia.org/en/Flash_Plugin_Installation

Recent versions of Adobe 11.2 for Linux are built for processors with the SSE2 instruction set. This is present since Intel Pentium IV and AMD Athlon 64, but my AMD Athlon XP is older and only handles SSE, as you may see here: http://en.wikipedia.org/wiki/List_of_AMD_Athlon_XP_microprocessors

So you need an older version of Flash built for SSE, or the 11.2 flash plugin shipped until Google Chrome 19, which is built for SSE.

Download that libgcflashplayer.so file, rename it into libflashplayer.so, and put it in your /usr/lib/mozilla/plugins directory.

Maybe the videos you can see are served in HTML5, and thus may be plyed without Flash. Just right click on the video to check that. But this is a different problem. I solved my problem by following the instructions there: https://wiki.mageia.org/en/Flash_Plugin_Installation Recent versions of Adobe 11.2 for Linux are built for processors with the SSE2 instruction set. This is present since Intel Pentium IV and AMD Athlon 64, but my AMD Athlon XP is older and only handles SSE, as you may see here: http://en.wikipedia.org/wiki/List_of_AMD_Athlon_XP_microprocessors So you need an older version of Flash built for SSE, or the 11.2 flash plugin shipped until Google Chrome 19, which is built for SSE. Download that [http://www1.datafilehost.com/d/796ff3f2 libgcflashplayer.so] file, rename it into libflashplayer.so, and put it in your /usr/lib/mozilla/plugins directory.
kobe 441 solutions 5048 answers

you could also install firefox using a package manager and flash using a package manager

you could also install firefox using a package manager and flash using a package manager * [[Install Firefox on Linux]]

Question owner

You can install Firefox using a package manager, yes, as the problem comes from the flash plugin, not Firefox. But you can't install on non-SSE2 machines the flash plugin from your distro's repositories.

Here's why: on my distro at least (Mageia), the package that installs flash is just a script that downloads the latest flash version from the Adobe site, which just won't work because it's SSE2-only. I don't know how it's done on other distros, but at least openSUSE looks to be doing more or less same.

All this is because Adobe doesn't allow redistribution by third parties. This is why I'm pretty sure giving a direct link to libgcflashplayer.so is illegal, but I don't care until I haven't received a take-down notice.

You can install Firefox using a package manager, yes, as the problem comes from the flash plugin, not Firefox. But you can't install on non-SSE2 machines the flash plugin from your distro's repositories. Here's why: on my distro at least (Mageia), the package that installs flash is just a script that downloads the latest flash version from the Adobe site, which just won't work because it's SSE2-only. I don't know how it's done on other distros, but at least openSUSE looks to be doing more or less same. All this is because Adobe doesn't allow redistribution by third parties. This is why I'm pretty sure giving a direct link to libgcflashplayer.so is illegal, but I don't care until I haven't received a take-down notice.
kobe 441 solutions 5048 answers

thought you had a distro such as ubuntu or debian, adobe is trying their best to ditch all linux users.

thought you had a distro such as ubuntu or debian, adobe is trying their best to ditch all linux users.
leon244 0 solutions 7 answers

I guess they are succeeding then with the latest update which allegedly was made for Linux.  :o(

I guess they are succeeding then with the latest update which allegedly was made for Linux. :o(
kobe 441 solutions 5048 answers

you can also try their IRC network

or this guide....

you can also try their IRC network * https://wiki.mageia.org/en/IRC or this guide.... * https://wiki.mageia.org/en/Flash_Plugin_Installation

Question owner

@Wakka_Flocka_Flame: I know, I already solved my problem using the instructions on https://wiki.mageia.org/en/Flash_Plugin_Installation , and updated that page to make installation easier. And AFAIK, Debian and Ubuntu users have the same problem. Here's the upstream bug at Adobe: https://bugbase.adobe.com/index.cfm?event=bug&id=3161034

They just don't care.

@Wakka_Flocka_Flame: I know, I already solved my problem using the instructions on https://wiki.mageia.org/en/Flash_Plugin_Installation , and updated that page to make installation easier. And AFAIK, Debian and Ubuntu users have the same problem. Here's the upstream bug at Adobe: https://bugbase.adobe.com/index.cfm?event=bug&id=3161034 They just don't care.