Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Firefox display changed, zoomed in on websites

  • 98 replies
  • 149 have this problem
  • 1800 views
  • Last reply by paul8887

more options

My Firefox on a windows 7 HP laptop updated today (June 25th) and the zoom adjusted, changing the font size, as well as icons and zoomed in on websites. I noticed in the list of changes for the program it says "improved rendering on high-res displays" is this the problem and is there anyway I can disable this? I was quite happy with the resolution before, and find this tacky and annoying...

My Firefox on a windows 7 HP laptop updated today (June 25th) and the zoom adjusted, changing the font size, as well as icons and zoomed in on websites. I noticed in the list of changes for the program it says "improved rendering on high-res displays" is this the problem and is there anyway I can disable this? I was quite happy with the resolution before, and find this tacky and annoying...

Chosen solution

This post has been revised to include information about an add-on. A copy of the original post appears below the horizontal line.

Firefox now adjusts the page zoom level according to your Windows settings, to better support high DPI displays. For example, if Windows is set to 125% font size (120dpi), the content area will be zoomed by 25% compared with Firefox 21 and earlier.

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.


Original Post

Firefox now tries to adjust the zoom level according to your Windows settings, as well as better supporting high DPI displays. It's not going to be to everyone's liking.

I still have Fx21 on this computer so I can't test it myself, but could you check the following setting and try adjusting it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 to restore the appearance from earlier versions of Firefox for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings.

Does that help?

More info in this thread: How do I set the default font size to a lower value?

Read this answer in context 👍 25

All Replies (20)

more options

Hi maibockaddict, setting layout.css.devPixelsPerPx = 1.0 should restore the content area to the same size as Firefox 21.

Site-specific zoom settings, or zoom-related extensions, could be modifying the size. Pressing Ctrl+0 (that's a zero) should reset the zoom level to default (the new default of 96ppi). You can check for extensions on the following tab:

orange Firefox button (or Tools menu) > Add-ons > Extensions category


I did see a screen shot from another user where Facebook looked very strange even after making the change, but I don't think we identified the cause of it.

When you next encounter a problem with a particular site, can you try this:

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

If not, could you post a screen shot showing the distortion? This article has tips on how to do that: How do I create a screenshot of my problem?

more options

Hi ad_verbum, I agree it doesn't work for everyone, and that it could be a lot easier to adjust.

I'm sure if this had been built in to Firefox since 2004 it would seem normal, but now that we are used to small content areas, the zooming seems excessive by comparison. Up to now the people who couldn't see pages well bore the burden of zooming them. Now those who had just the right size may be overwhelmed with the enlargement.

I don't know will happen in future versions of Firefox, but I think it's fair to say that because pixel pitch on display screens and the acuity of human vision vary widely, and there are numerous ways to adjust Windows settings and tweak Firefox, we have an environment where Mozilla can't please all of the people all of the time.

more options

jscher2000, you bizarrely state "there's no single setting for layout.css.devPixelsPerPx that will make everything look like Firefox 21 if your Windows DPI is anything other than 100%."

However, my Windows DPI is 100% and yet still everything on Firefox 22 looks massively out of proportion. So your explanation is incorrect,

I have tried adjusting layout.css.devPixelsPerPx to 1.0 which at least makes chrome vaguely resemble Firefox 21, but still all my webpages are out of proportion. Text is too big, too small, and the page layouts are completely different - parts of pages are now located in different places in relation to each other.

My question to you - Is there a simple setting that will make Firefox 22 present EVERYTHING (browser, chrome, webpages) in both the same size AND proportion as Firefox 21 (and pretty much every previous Firefox for the last 5 years)?

If there is not, WHY NOT?

more options

Hi bewley, if your Windows is set to 100%, it sounds as though Firefox is reading it incorrectly. I don't know what could cause that.

The distorted layouts sound like a problem a poster illustrated with a screen shot here: https://support.mozilla.org/en-US/questions/959696?page=5#answer-451659

This seems to be caused by something in your browser settings, but since the other poster said it wasn't resolved by trying Firefox's Safe Mode, we don't yet have a good idea of what "it" is.

Could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any improvement in page layout on broken sites?

more options

I'd like to go back to 21.0 too. How do I go about doing it?

more options

thanks jscher2000, changing only the 1.0 wasnt enough, installing that plugging things improved a lot.

more options

i went back and surprise when i run firefox today version 22 was already installed =(

more options

Hi jscher2000, in Safe mode nothing looks different from before.

When I say everything's out of proportion, it's not as broken as Haterade's screenshot - it's just things are not the same proportion to each other as they were under Firefox 21. Webpages do NOT look the same as Firefox 21 if I modify layout.css.devPixelsPerPx to 1.0 or 1.1. And as everyone here has stated, your new -1.0 just makes everything huge.

I don't understand why you have introduced an update that makes everything out of scale. You've managed to update Firefox for many years without doing this. I've never had to adjust size settings before, and I'm not a programmer. If people aren't happy with a default setting, by all means let them play with it to their heart's content. But why make the default itself unusable for so many people?

more options

Seems to work thanks!

more options

Same issue on http://www.ATChimneySweeps.com its a chimney sweep site but shows weird code across the second chimney cleaning article.

more options

Hi bewley, something is wrong if the scaling is not proportional; it should be if it's working correctly. (Also, what -1.0 does is use your Windows setting, so that explains the increase.)

more options

Hi ATChimneySweeps, this is your site?

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

In case you are seeing an artifact of mismatched cached and live files, use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

If you still see strange code on the page, could you start a new thread and include a more detailed description of the problem. You also can reply to your question and post a screenshot. (There's no upload form for screenshots in the initial post.)

To start a new question, scroll to the top of this page and click the "Ask a Question" link.

more options

Dear jscher2000, I'm fully aware that something is wrong! That's why I am asking you how to fix it.

more options

Hi bewley, could you upload some screen shots of sites that are out of proportion? I've only seen the one example that you said was not like yours. Thanks. This article has tips if needed: How do I create a screenshot of my problem?

more options

Ditto re creating an account just to complain about this update. So some developer decided to fix what wasn't broke and 'tidy things up', forcing tens of millions of Firefox users to change their system settings. I use an ultralight so I must now choose between readable Windows menus or readable Firefox pages.

more options

Hi happytadpole, you don't have to choose! Keep your Windows setting as it is, and then --

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.

more options

Another long-time user unhappy with the new display size changes. I use 125% display in Windows settings and I can't get Firefox 22 to display the same sizes as version 21 consistently across web pages despite wasting hours faffing around, time which could have been spent doing something useful. I've set layout.css.devPixelsPerPx to 1.25 (after trying lots of other values), I've played with default font sizes in Options, I've installed Theme Font & Size Changer.

I've mostly got the tab headings etc back to normal (although my bookmark/history/etc. panel still looks wrong), many pages now display correctly, but others display with a much bigger or smaller font than before, enough to make them uncomfortable to read. For example the Google results page is much too small and it's now a strain to read, but if I change things to make it usable then the fonts on other pages are much too big. Theme Font & Size Changer is a waste of time as it changes everything, not just the page contents.

If we're going to be stuck with this change as default, please would you consider giving us an option to use Firefox 21 sizes in the options menu.

more options

I noticed the new zoomed in Firefox display a few days ago, I'm also a webdeveloper with a large display like most of the complainers here and I think it's a disaster. Firefox is now worse than Explorer where you can go back to 100% zoom really easy. If you zoom out with the new firefox the site's background remains the same 125%. So you can never see the site like it's made. I've been using Firefox for ages and like all the gadgets like webdeveloper but if you guys don't change things back to normal I'll move to Chrome or -I never considered this before- Explorer...

more options

I ran into the same issues everyone else is having. None of the fixes described in this thread work to resolve the issues. The about:config fixes work for some web sites but not others (i.e. GMail for some reason looks way too small, while Yahoo looks fine). This is with most of my machines set to 100% in Windows.

What is needed is a simple one-checkbox on/off setting in "Options" to disable this behavior and make it act as before. No about:config changes, no "install this plug-in and monkey with the settings". One click and it's back to the way it was.

I have around 100 machines I'm supporting right now with Firefox and I'm staying at 21 until this gets fixed. If it doesn't get fixed, it's time for Chrome.

Has anyone heard of ANYBODY who is giddy about this "new way" of doing DPI scaling in Firefox? I haven't heard a single person who thinks this is a great idea, nor does it have any perceivable benefit other than the nebulous "it works better with big displays" all of the fanboys keep shouting. Before this I wasn't hearing anyone complaining about FF *not* working well with big displays, so it truly looks like a solution seeking a problem.

more options

I use a big screen in order to see more content at once, NOT to see content in a bigger size where I end up now having to zoom out or scroll around. I hate this change.

Agree that this needs a simple fix, not a kludge involving addons or config changes that ordinary users don't want to deal with.

This is my first comment ever in a Firefox forum. Have been a loyal Firefox user for years, but this might be the change that makes me move to another browser.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5