Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Although I have set my homepage to yahoo!, I keep getting searchqu.com every time I switch on my computer. How can I stop this?

  • 1 reply
  • 1 has this problem
  • Last reply by cor-el

more options

This has happened only since last week

Chosen solution

See these threads about searchqu:

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

See these threads about searchqu: