Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Certain websites don't work in Firefox but work in other browsers.

  • 16 replies
  • 2 have this problem
  • 29 views
  • Last reply by EltonTom

more options

I'm using Firefox 85. Windows 10. Started happening 2 days ago.

I've come across some sites that are giving me errors, but they work fine in chrome.

Things I've tried:

  • Restarting computer
  • Restarting router
  • Disabling Firefox addons
  • Clearing all cookies + history
  • Clearing cache

Below is what happens when I try to sign into the Playstation Store. Also getting similar 406 error trying to access Yamazaki Home

Example: When I click "SIGN IN" on the Playstation Store page, I'm met with a 406 error.

These are the headers that are returned.

Response Headers. Cache-Control no-cache, no-store, max-age=0, must-revalidate Connection keep-alive Content-Length 38 Content-Type application/json;charset=UTF-8 Date Sat, 30 Jan 2021 20:01:40 GMT Expires 0 Server nginx Strict-Transport-Security max-age=31536000 ; includeSubDomains X-Content-Type-Options nosniff, nosniff X-CorrelationId c22fffff-05c7-4d2c-81c0-699bbba555c3 X-Frame-Options DENY X-Psn-Correlation-Id c22fffff-05c7-4d2c-81c0-699bbba555c3 X-Psn-Request-Id 8b5177d1681a03522a5a687f9de05f18 X-RequestId 8b5177d1681a03522a5a687f9de05f18 X-XSS-Protection 1; mode=block

Request Headers Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/\*;q=0.8 Accept-Encoding gzip, deflate, br Accept-Language en-US,en;q=0.5 Connection keep-alive DNT 1 Host ca.account.sony.com Referer https://store.playstation.com/en-us/latest Upgrade-Insecure-Requests 1 User-Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0

Chosen solution

was able to get it working by doing a "firefox refresh"

Read this answer in context 👍 1

All Replies (17)

more options

Also tried changing permissions to allow everything including supercookies.

Helpful?

more options

Works here for me (redirect to https://my.account.sony.com/central/signin/).

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

I tried all your suggestions, no luck.

Helpful?

more options

The site works for me also. see screenshots Something is being blocked. Can you share a similar screenshot?

Modified by jonzn4SUSE

Helpful?

more options

jonzn4SUSE said

The site works for me also. see screenshots Something is being blocked. Can you share a similar screenshot?

I'm able to get to the playstation home page, but when I click sign in, i get the 406 error. See screenshots

Helpful?

more options

Right, but when you click on sign-in it takes you here. see screenshot Check for 3rd party cookies.

Modified by jonzn4SUSE

Helpful?

more options

jonzn4SUSE said

Right, but when you click on sign-in it takes you here. see screenshot Check for 3rd party cookies.

no, that screen doesnt show up for me at all, my 2nd screenshot above is what i see once i click sign in

oh wait, is this what you wanted to see?

Modified by Hugh

Helpful?

more options

That's it right there. see screenshot You have not granted this site any special permissions?

Helpful?

more options

Here is mine. see screenshot

Helpful?

more options

What is interesting is that your browser is showing https://ca.account.sony.com while mine starts with my. Try the my link.

Modified by jonzn4SUSE

Helpful?

more options

jonzn4SUSE said

Here is mine. see screenshot

Theres no special permissions since it hasn't requested any ( just tried to add the site manually to my cookies to allow, but didn't work). I cleared my history/cache/cookies before this.

Also you see how yours directs you to my.account.sony.com

it looks like mine is redirecting me to ca.account.sony.com for some reason (for authorization maybe?)

Helpful?

more options

jonzn4SUSE said

What is interesting is that your browser is showing https://ca.account.sony.com while mine is showing https://my.account.sony.com. Try the my link.

not sure why my previous reply didn't show up but yea i just noticed that as well. I tried using the my.account instead, but getting "not found"

tried modifying the links but not working either.

Helpful?

more options

I see two redirects from the initial signin request.

Redirects to :

Redirects to:

The latter shows the actual login form.

Helpful?

more options

Chosen Solution

was able to get it working by doing a "firefox refresh"

Helpful?

more options

Glad to hear it.

Helpful?

more options

I have found that Firefox version 88.0 was set to "Use system proxy settings". I changed that to "No Proxy" and I was able to access all pages in IRS.gov. Go to Options/General and change "Network Settings".

Helpful?

more options

I found by changing the Proxy Server Setting to "No Proxy", all started working well. Options/General/Network Settings.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.