X
Tap here to go to the mobile version of the site.

Support Forum

When I start up my computer I receive a message that an error occured in the script on this page because of an error in line 157, char 17 of a index.html file

Posted

How can I view and possibly edit the index.html file. I once deleted the file but the next time I titrned on my computer the same error appeared.

How can I view and possibly edit the index.html file. I once deleted the file but the next time I titrned on my computer the same error appeared.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

FredMcD
  • Top 10 Contributor
4271 solutions 59902 answers

What is the full name of the file?

Unless you know the program in question, trying to edit it may not work out very well.

What is the full name of the file? Unless you know the program in question, trying to edit it may not work out very well.
jscher2000
  • Top 10 Contributor
8793 solutions 71936 answers

Hi DonaldSo, there are several possible ways to get unexpected pages at startup. The two most common would be:

(1) Home Page setting was changed to a different URL (2) The shortcut you use the start Firefox was modified

So now in more detail:

(1) Custom URLs for your Home Page

This article has the steps to reset your home page to your preferred page: How to set the home page

How long does that stick?

  • It works until I close Firefox, back to the problem page at the next startup
  • It works until I close Firefox and shut down Windows, back to the problem page at the first Firefox startup after that
  • It works for some random amount of time
  • My setting is ignored!

To test your home page setting, you can either click the Home button the toolbar (looks like a house) or launch a new window by pressing Ctrl+n.

(2) Heal a hijacked shortcut

Sometimes your home page setting is fine, but the icon you use to start Firefox has been modified to load an unwanted page. To investigate that:

First, open the shortcut properties as follows (this is how it works on Windows 7, hopefully it's similar on Windows 10):

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than one of the following (depending on 32-bit/64-bit):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
"C:\Program Files\Mozilla Firefox\firefox.exe"

If anything follows after that (for example, "http://example.com"), try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your desired home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

Hi DonaldSo, there are several possible ways to get unexpected pages at startup. The two most common would be: (1) Home Page setting was changed to a different URL (2) The shortcut you use the start Firefox was modified So now in more detail: '''(1) Custom URLs for your Home Page''' This article has the steps to reset your home page to your preferred page: [[How to set the home page]] How long does that stick? * It works until I close Firefox, back to the problem page at the next startup * It works until I close Firefox and shut down Windows, back to the problem page at the first Firefox startup after that * It works for some random amount of time * My setting is ignored! To test your home page setting, you can either click the Home button the toolbar (looks like a house) or launch a new window by pressing Ctrl+n. '''(2) Heal a hijacked shortcut''' Sometimes your home page setting is fine, but the icon you use to start Firefox has been modified to load an unwanted page. To investigate that: First, open the shortcut properties as follows (this is how it works on Windows 7, hopefully it's similar on Windows 10): * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. You'll see the Target highlighted. On Windows, that usually is no more and no less than one of the following (depending on 32-bit/64-bit): "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" "C:\Program Files\Mozilla Firefox\firefox.exe" If anything follows after that (for example, "http://example.com"), try clearing it out. After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your desired home page. Either: * double-click desktop shortcut * right-click pinned taskbar icon, click Mozilla Firefox Success?
jscher2000
  • Top 10 Contributor
8793 solutions 71936 answers

Oh... this appears when you start Windows 10? Is Firefox starting up automatically? That's a new behavior, to integrate with Windows 10's automatic resumption feature. Try turning that off to see whether it makes any difference:

Firefox starts automatically when I restart Windows

Oh... this appears when you start Windows 10? Is Firefox starting up automatically? That's a new behavior, to integrate with Windows 10's automatic resumption feature. Try turning that off to see whether it makes any difference: [[Firefox starts automatically when I restart Windows]]