Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn off automatic searching when text is pasted accidentally onto main browser window (not the location bar) ?

  • 7 replies
  • 1 has this problem
  • 721 views
  • Paskiausią atsakymą parašė cor-el

more options

This sometimes happens for example while filling in a form on a web page. I intend to copy/paste text into an input box of the form but I accidentally paste it outside of the box. This causes Firefox to perform an undesired search based on my text.

Can this be turned off?

Modified by Jeff_Landry

Chosen solution

That is not default Firefox behavior AFAIK.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can also try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values or check for related user set prefs on the about:config page.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (7)

more options

Hi,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

If you would like to take a listing of the add-ons, important preferences/settings etc. to quickly replicate the previous profile, please open Troubleshooting Information via Help (Alt + H), Copy all to clipboard and paste it into MS Office Excel, or OpenOffice/LibreOffice Calc, or notepad. However, it would be a good idea to check for the existence of the issue immediately after the reset.

more options

Thanks but is there a fix short of resetting Firefox? For starters, can someone confirm then that this is not default behavior of Firefox?

more options

How are you able to paste the text outside the input form?

That Paste item should not be available via the right-click context menu.

more options

An example. If I copy the text "TEST" into my clipboard and go to www.google.com, I can then use the Ctrl+V shortcut to paste the clipboard text either:

(1) inside the proper google search box, so that obviously the word TEST ends up in the box as expected; or

(2) if I Ctrl+V paste it just outside of the input box by accident (or anywhere on the web page actually), then Firefox immediately begins a search of "TEST". Specifically it takes me here:

https://www.google.com/search?q=test&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb

more options

Chosen Solution

That is not default Firefox behavior AFAIK.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can also try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values or check for related user set prefs on the about:config page.

more options

You are right, of course. Safe mode stopped the unwanted behavior. It turns out Tab Utilities it the culprit, creating a default CTRL-V shortcut to "paste & go". Thanks for the help.

more options

You're welcome.