Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo stole my newtab page and I want it back!

  • 3 replies
  • 27 have this problem
  • 18141 views
  • Paskiausią atsakymą parašė Michael Verdi

more options

OK. I really liked the new-tab page Firefox came up with, then my brother downloaded Yahoo crap and I uninstalled it. The problem I have is that whenever I open a new tab, it still opens a yahoo search page. I looked everywhere online for information to get my new-tab page back, but all I found was how to get rid of it.

I'm not a computer person, so when they say 'open Firefox and type ___________.' I have no idea what they are talking about. To top it off, there is no little box in the upper right corner to click like all the help sites say. It's just a regular yahoo search page, and it's driving me nuts. I've looked about the web all day off and on for this. At this point, I'd be happy with figuring out how to get a blank page, but I don't know how to get to where I'm suppose to type 'about:blank' to do it.

I tried uninstalling Firefox and then installing it again too, thinking that it might reset things. It didn't. I still see yahoo. I hope you can help. I really miss my new-tab page.

Chosen solution

See this article about the New Tab (about:newtab) page:

You can check the browser.newtab.url pref on the about:config page and if it is user set (bold) then reset the pref to the default via the right-click context menu.


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Skaityti atsakymą kartu su kontekstu 👍 6

All Replies (3)

more options

Chosen Solution

See this article about the New Tab (about:newtab) page:

You can check the browser.newtab.url pref on the about:config page and if it is user set (bold) then reset the pref to the default via the right-click context menu.


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Thank you Cor-el! I was confused with your advice at first, but then I finally figured out how to get to the about:config page and everything started to make sense. I sort of felt like a computer person for a minute. hehe. Anyways, the 'browser.newtab.url' was not bold and I couldn't reset it. So, I checked your other links and found out how to run Firefox in 'safe mode' and then figured out that the I had a new-tab page in 'safe mode', which meant that it was an extension problem.

I went to the add-on list and removed 'net-assistant' because it was the only thing I didn't recognize. I got my new-tab page back!! Yay!! I didn't know 'yahoo' was disguised as 'net assistant', or I would have deleted it first thing. Thank you so much for leading me to not only fixing this problem, but allowing me to discover more about my computer in the process. You Rock!

more options

Your search settings may have also been changed. You might want to use this add-on to set them all back to default - https://addons.mozilla.org/firefox/addon/searchreset/