Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disabling 'Show animations in Windows' changes the way text is shown on some websites.

  • 4 replies
  • 0 have this problem
  • 1 view
  • Paskiausią atsakymą parašė zeroknight

more options

When I turn off the windows animations in Windows 10 the font on Twitter.com changes somewhat. I believe it is altering the character spacing/scaling.

I have not had this behavior on other browsers (Brave, Edge, Chrome & OperaGX tested). I have not noticed this on other websites, but I also haven't really looked.

Windows version 22H2 (OS Build 19045.4291) Firefox version 124.0.2

Images provided are with them off, then on

Steps to recreate 1. Load a tweet (tweet in the images: https://twitter.com/FedeItaliano76/status/1779855670432408011) 2. Turn off window animations (settings->display->show animations in windows->Off) 3. Reload the Tweet

This is not a critical issue for me, but I think it's worth mentioning

When I turn off the windows animations in Windows 10 the font on Twitter.com changes somewhat. I believe it is altering the character spacing/scaling. I have not had this behavior on other browsers (Brave, Edge, Chrome & OperaGX tested). I have not noticed this on other websites, but I also haven't really looked. Windows version 22H2 (OS Build 19045.4291) Firefox version 124.0.2 Images provided are with them off, then on Steps to recreate 1. Load a tweet (tweet in the images: https://twitter.com/FedeItaliano76/status/1779855670432408011) 2. Turn off window animations (settings->display->show animations in windows->Off) 3. Reload the Tweet This is not a critical issue for me, but I think it's worth mentioning
Pridėtos ekrano nuotraukos

All Replies (4)

more options

Another way to disable animations is to create ui.prefersReducedMotion (Number) with value 1 in about:config.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the Down arrow at the right end.

Helpful?

more options

Via inspect element: when the windows animations are off it's using Times New Roman on the 'quote tweets' text and Segoe UI on the main tweet text, but with the animations on it's using 'TwitterChirp'. This persists in Troubleshoot Mode

I have the Control Panel For Twitter extension which is likely causing the Quote Tweets box to show a different font from the rest. I have disable this extension and it persists

I've also updated to Firefox 125.0.2

The animations I want disabled on Windows but enabled on Firefox for smooth scrolling

Helpful?

more options

It always uses Noto Sans for me, regardless of the animation setting.

You can enable animations by creating ui.prefersReducedMotion (Number) with value 0 in about:config.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.