Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox macOS Constant Crashes: no blob image template

  • 7 replies
  • 0 have this problem
  • 50 views
  • Paskiausią atsakymą parašė czArmageddon

more options

Hi, I'm hoping someone can help me figure out why Firefox continues to crash on my M-series Mac, when visiting certain websites. I am getting an error, no blob image template [ EXC_BAD_ACCESS / KERN_INVALID_ADDRESS ], on each crash. I've looked this error up, to little avail. Can someone please help diagnose some of these? Thank you in advance!

e0442e78-9ed4-4875-998f-6ff790240222 a2ae5006-07be-468c-b0d0-2c34c0240224 ee2b7825-9613-4ba6-af38-cfb6c0240224

Hi, I'm hoping someone can help me figure out why Firefox continues to crash on my M-series Mac, when visiting certain websites. I am getting an error, ''no blob image template'' [ EXC_BAD_ACCESS / KERN_INVALID_ADDRESS ], on each crash. I've looked this error up, to little avail. Can someone please help diagnose some of these? Thank you in advance! [https://crash-stats.mozilla.org/report/index/e0442e78-9ed4-4875-998f-6ff790240222 e0442e78-9ed4-4875-998f-6ff790240222] [https://crash-stats.mozilla.org/report/index/a2ae5006-07be-468c-b0d0-2c34c0240224 a2ae5006-07be-468c-b0d0-2c34c0240224] [https://crash-stats.mozilla.org/report/index/ee2b7825-9613-4ba6-af38-cfb6c0240224 ee2b7825-9613-4ba6-af38-cfb6c0240224]

All Replies (7)

more options

The "Available Physical Memory" value seems very low.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

I agree, it is far lower than my system suggests it should be (4.5GB free, 2.3GB wired). I don't seem to have the problem when troubleshooting mode is enabled - though I am only able to test for short bursts of time before I end up needing extensions like Bitwarden working again. I am trying to whittle away any bad extensions that could be causing this, too.

Thank you for your help.

Helpful?

more options

Helpful?

more options

Hi zeroknight, thanks for your replies. I have disabled HW acceleration, but still receive these crashes. One by one, I am disabling third-party extensions to isolate (down to two now).

Maybe this is relevant, but the last two times FF crashed, it was during a WebAuthn negotiation. It doesn't crash on every WebAuthn request, and not every crash is preceded by one - so maybe just coincidence.

These are those two crashes: 4b1c1c00-b99c-4853-b442-3511b0240227 8c4973ef-ff86-4c2c-a9c7-071ce0240227

Helpful?

more options

The crashes are about WebRender as you can see by the signature

  • Firefox 123.0 Crash Report [@ core::option::expect_failed | webrender::api_resources::ApiResources::create_blob_scene_builder_requests ]
MOZ_CRASH Reason (Sanitized) : no blob image template
Crash Reason : EXC_BAD_ACCESS / KERN_INVALID_ADDRESS

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

cor-el said

The crashes are about WebRender as you can see by the signature
  • Firefox 123.0 Crash Report [@ core::option::expect_failed | webrender::api_resources::ApiResources::create_blob_scene_builder_requests ]
MOZ_CRASH Reason (Sanitized) : no blob image template Crash Reason : EXC_BAD_ACCESS / KERN_INVALID_ADDRESS Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.
  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You know what, I think userChrome was the problem. While I didn't have a userChrome.css file, I did have some orphan assets in the chrome folder that might have been causing this.

Thank you very much! I'll be sure to continue troubleshooting if the crashes return.

Enjoy your week.

Helpful?

more options

Well, unfortunately, I'm still experiencing crashes in standard mode, despite removing the chrome folder, resetting the theme, and disabling hardware acceleration. I've also disabled any non-core extensions, and especially ones that alter appearance. Troubleshooting mode seems to work, but would that help me identify the problem?

I would really prefer not to, of course - but is it time to do a "refresh"?

0c9e9615-3493-43a9-91f7-9ec7a0240228

Modified by czArmageddon

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.