Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Preview takes FOREVER to Load and Print - WHY?

  • 6 replies
  • 1 has this problem
  • 18 views
  • Paskiausią atsakymą parašė John Gordon

more options

Ever since you last changed Preview, it takes FOREVER for the darn page to load (be seen in Preview) and then FOREVER more to print. Half the time my doc doesn't even show up the first time Preview loads and I have to repeat it. The only work-around I've found is to open my doc in Safari and then print - which is insane. What's wrong with Firefox??

Chosen solution

Bless you!!! I think that solved it. At least I'm seeing the print option page that I'm used to and printing is MUCH faster than before. I'll be eternally grateful for your assistance :)

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (6)

more options

Hi John, sorry to hear about this problem.

Does the rendering time seem related to the length or complexity of the web page you are trying to print?

While you are waiting, is the option to use the system dialog available in the right column, or is that not presented yet?

Helpful?

more options

Thanks for the reply. The things I'm printing can be a simple email or a word doc - and the rendering time doesn't appear to be tied to how long a doc it is. Even doing something as simple as selecting page 1 from a 7 page doc throws Firefox Preview into a 60-90 seconds delay. The same item printed from the same location on Safari prints in seconds - as Firefox Preview used to do as well. Yes, the system dialog option is there in the right column - are you suggesting I use that?

Helpful?

more options

John Gordon said

The things I'm printing can be a simple email or a word doc - and the rendering time doesn't appear to be tied to how long a doc it is. Even doing something as simple as selecting page 1 from a 7 page doc throws Firefox Preview into a 60-90 seconds delay.

Hmm, strange. When you say selecting page 1 from a 7 page doc, you change the Pages from All to Custom and type 1 and then there is a long delay?

Yes, the system dialog option is there in the right column - are you suggesting I use that?

Please try it when you encounter one that feels too slow.

Helpful?

more options

Yes, if I try to make ANY change to the options on the new Firefox Preview page (like switching from B&W to Color or selecting a custom # of pages to print), that starts the annoying gear icon spinning for 30-40 seconds before Preview gives me the option to print. Half the time, though, when the gear stops spinning, Preview shows a completely blank screen and I have to repeat the process before I see my chosen document in the Preview screen. Then, and only then, can I select Print. Then the delightful gear spins for another 30-40 seconds and, if gods are with me, my printer starts to print my document.

I tried the system dialog option, and that brings up a print option page that's familiar, but once I've made choice on that screen, the little gear still spins for 30-40 seconds before my printer engages.

Am I the only person having these issues with Firefox? I want the protections Firefox offers, but I can't stand having to stop and open another browser just to print a page.

Thank you for trying to help me - any further thoughts before I throw in the towel on Firefox? J.

Helpful?

more options

What if you turn off the new print experience and revert to the MacOS dialog -- does the system dialog operate with its old speed or is it still slow:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between the new experience (true) and the classic experience (false)

(4) If there is another preference named app.normandy.startupRolloutPrefs.print.tab_modal.enabled you can double-click that one to switch it to false as well. If you do not have that one, no need to create it.

Since you are setting to false, it will look roughly like this:

Helpful?

more options

Chosen Solution

Bless you!!! I think that solved it. At least I'm seeing the print option page that I'm used to and printing is MUCH faster than before. I'll be eternally grateful for your assistance :)

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.