X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Correct Gmail password with 2-Steps Verification fails in Thunderbird IMAP / Linux Mate 19.2

Paskelbta

I'm using Thunderbird v60.9.0 under Linux Mint 19.2 Mate (64bit) with IMAP Settings. I use it to access two Gmail different accounts, and I've been doing this with the same procedures for years without any problems.

Since the 1st of November it seems I can't access to my accounts, and Thunderbird says "Configuration could not be verified - is the username or password wrong?" and then start to repeat the procedure from beginning every time.

I have no problems with my Gmail account if I access them via Firefox or Chromium or phone, then the password are correct. I've tried to:

- delete manually the folders "/home/andrea/.cache/thunderbird" and "/home/andrea/.thunderbird" before to try every time, same result: after the new Gmail window appear to confirm the authentication it ask me to allow Thunderbird the access, but then it fails on the local pc

- update manually Thunderbird to the last version 68 downloading it from the official Mozilla website

- installed the new Ubuntu 19.10 in another partition and tried there with my account details

- disable the linux firewall "gufw"

- disable the 2-Steps Verification on the Gmail

- checked Gmail settings under Thunderbird, they seem correct:

 Incoming: IMAP, imap.gmail.com, SSL/TLS, port 993
                   Outgoing: SMTP, smtp.gmail.com, SSL/TLS
                   Authentication method: OAuth2 token

- generate an "App Password for Thunderbird" under Gmail on Firefox to use specifically in Thunderbird

Well, literally I've finished the ideas... If I try to set-up any other accounts (Yahoo, etc.) ther are no problems: it seem it's just Gmail fails now... Any suggestion? Many thanks

I'm using Thunderbird v60.9.0 under Linux Mint 19.2 Mate (64bit) with IMAP Settings. I use it to access two Gmail different accounts, and I've been doing this with the same procedures for years without any problems. Since the 1st of November it seems I can't access to my accounts, and Thunderbird says "Configuration could not be verified - is the username or password wrong?" and then start to repeat the procedure from beginning every time. I have no problems with my Gmail account if I access them via Firefox or Chromium or phone, then the password are correct. I've tried to: - delete manually the folders "/home/andrea/.cache/thunderbird" and "/home/andrea/.thunderbird" before to try every time, same result: after the new Gmail window appear to confirm the authentication it ask me to allow Thunderbird the access, but then it fails on the local pc - update manually Thunderbird to the last version 68 downloading it from the official Mozilla website - installed the new Ubuntu 19.10 in another partition and tried there with my account details - disable the linux firewall "gufw" - disable the 2-Steps Verification on the Gmail - checked Gmail settings under Thunderbird, they seem correct: Incoming: IMAP, imap.gmail.com, SSL/TLS, port 993 Outgoing: SMTP, smtp.gmail.com, SSL/TLS Authentication method: OAuth2 token - generate an "App Password for Thunderbird" under Gmail on Firefox to use specifically in Thunderbird Well, literally I've finished the ideas... If I try to set-up any other accounts (Yahoo, etc.) ther are no problems: it seem it's just Gmail fails now... Any suggestion? Many thanks

Chosen solution

I can confirm that now it works in this way for me.

My configuration is with Thunderbird v60.9.0 (64-bit) and Linux Mint 19.2 (64bit), and it works also with gContactSynch add-on installed.

To summarize to anyone who needs, just go on "Edit/Preferences/Advanced/Config Editor", then find "general.useragent.compatMode.firefox" and change it on "true" (right mouse --> "toggle")

Here two screenshots to be more clear too.

Many thanks to sfhowes and all the community for the help ;-)

Skaityti atsakymą kartu su kontekstu 1
Citata

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

sfhowes
  • Top 10 Contributor
Sprendimų: 1694 Atsakymų: 8238

This is fixed in 68.2.1, but if you're using an earlier version, apply the workaround in c#22:

https://bugzilla.mozilla.org/show_bug.cgi?id=1592407

Corrected bugzilla link.

Edit/Preferences/Advanced/General/Config. editor

This is fixed in 68.2.1, but if you're using an earlier version, apply the workaround in c#22: https://bugzilla.mozilla.org/show_bug.cgi?id=1592407 Corrected bugzilla link. Edit/Preferences/Advanced/General/Config. editor

Modified by sfhowes

Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Hi sfhowes, thanks for your answer first.

Actually it's not completely clear to me how they fixed it, because I've checked the in the "Edit/Preferences/Advanced/General/Config.editor" and it seems the Local Folder and the account1/2 are correct.

And I can understand if it's a bug on the version 68 fixed with the last 68.2.1, but how can affect also the old version that is still the same?

If it can helps I've also tried this morning to reinstall completely Linux Mint 19.2 in another partition and checked with a different Gmail account (with 2Steps Validation NOT activated) but there is no way that it works when until just few days ago it was perfect (and I didn't modify anything).

What I have to change exactly? Here two screenshots after I've reinstalled everything.

Many thanks

Hi sfhowes, thanks for your answer first. Actually it's not completely clear to me how they fixed it, because I've checked the in the "Edit/Preferences/Advanced/General/Config.editor" and it seems the Local Folder and the account1/2 are correct. And I can understand if it's a bug on the version 68 fixed with the last 68.2.1, but how can affect also the old version that is still the same? If it can helps I've also tried this morning to reinstall completely Linux Mint 19.2 in another partition and checked with a different Gmail account (with 2Steps Validation NOT activated) but there is no way that it works when until just few days ago it was perfect (and I didn't modify anything). What I have to change exactly? Here two screenshots after I've reinstalled everything. Many thanks
Was this helpful to you?
Citata
elilla.shadowheart Sprendimų: 0 Atsakymų: 1

sfhowes said

This is fixed in 68.2.1, but if you're using an earlier version, apply the workaround in c#22: https://bugzilla.mozilla.org/show_bug.cgi?id=1584861 Edit/Preferences/Advanced/General/Config. editor

Doesn't seem to be fixed for imap in 68.2.1, I had to change my password while ~10000km away. I could pull email from my phone, but thunderbird kept throwing configuration could not be verified errors for my laptop, and when I got home last night the same problem.

I went through the usual steps of deleting and trying to re-setup my account and it continued to throw the same errors. 2FA wasn't turned on, even with 2FA turned on and using an app password the config could not be verified threw the same error back. Eventually I had to change this to pop, and I've been able to pull the last ~400 emails off, but that's it. Doesn't seem to matter if local folders are on or off.

''sfhowes [[#answer-1263769|said]]'' <blockquote> This is fixed in 68.2.1, but if you're using an earlier version, apply the workaround in c#22: https://bugzilla.mozilla.org/show_bug.cgi?id=1584861 Edit/Preferences/Advanced/General/Config. editor </blockquote> Doesn't seem to be fixed for imap in 68.2.1, I had to change my password while ~10000km away. I could pull email from my phone, but thunderbird kept throwing configuration could not be verified errors for my laptop, and when I got home last night the same problem. I went through the usual steps of deleting and trying to re-setup my account and it continued to throw the same errors. 2FA wasn't turned on, even with 2FA turned on and using an app password the config could not be verified threw the same error back. Eventually I had to change this to pop, and I've been able to pull the last ~400 emails off, but that's it. Doesn't seem to matter if local folders are on or off.
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1694 Atsakymų: 8238

Naudingas atsakymas

walter.andrea29 said

Hi sfhowes, thanks for your answer first. Actually it's not completely clear to me how they fixed it, because I've checked the in the "Edit/Preferences/Advanced/General/Config.editor" and it seems the Local Folder and the account1/2 are correct. And I can understand if it's a bug on the version 68 fixed with the last 68.2.1, but how can affect also the old version that is still the same? If it can helps I've also tried this morning to reinstall completely Linux Mint 19.2 in another partition and checked with a different Gmail account (with 2Steps Validation NOT activated) but there is no way that it works when until just few days ago it was perfect (and I didn't modify anything). What I have to change exactly? Here two screenshots after I've reinstalled everything. Many thanks

Sorry, I pasted the wrong bug report, one that refers to a different problem.

The correct bug is: https://bugzilla.mozilla.org/show_bug.cgi?id=1592407

The useragent switch is necessary in TB 60 to access all Google services using OAuth2 authentication, and also in TB 68.2.1 for Google calendar and contact sync. - the fix in 68.2.1 only deals with IMAP mail sync.

''walter.andrea29 [[#answer-1263976|said]]'' <blockquote> Hi sfhowes, thanks for your answer first. Actually it's not completely clear to me how they fixed it, because I've checked the in the "Edit/Preferences/Advanced/General/Config.editor" and it seems the Local Folder and the account1/2 are correct. And I can understand if it's a bug on the version 68 fixed with the last 68.2.1, but how can affect also the old version that is still the same? If it can helps I've also tried this morning to reinstall completely Linux Mint 19.2 in another partition and checked with a different Gmail account (with 2Steps Validation NOT activated) but there is no way that it works when until just few days ago it was perfect (and I didn't modify anything). What I have to change exactly? Here two screenshots after I've reinstalled everything. Many thanks </blockquote> Sorry, I pasted the wrong bug report, one that refers to a different problem. The correct bug is: https://bugzilla.mozilla.org/show_bug.cgi?id=1592407 The useragent switch is necessary in TB 60 to access all Google services using OAuth2 authentication, and also in TB 68.2.1 for Google calendar and contact sync. - the fix in 68.2.1 only deals with IMAP mail sync.
Was this helpful to you? 1
Citata

Chosen Solution

I can confirm that now it works in this way for me.

My configuration is with Thunderbird v60.9.0 (64-bit) and Linux Mint 19.2 (64bit), and it works also with gContactSynch add-on installed.

To summarize to anyone who needs, just go on "Edit/Preferences/Advanced/Config Editor", then find "general.useragent.compatMode.firefox" and change it on "true" (right mouse --> "toggle")

Here two screenshots to be more clear too.

Many thanks to sfhowes and all the community for the help ;-)

I can confirm that now it works in this way for me. My configuration is with Thunderbird v60.9.0 (64-bit) and Linux Mint 19.2 (64bit), and it works also with gContactSynch add-on installed. To summarize to anyone who needs, just go on "Edit/Preferences/Advanced/Config Editor", then find "general.useragent.compatMode.firefox" and change it on "true" (right mouse --> "toggle") Here two screenshots to be more clear too. Many thanks to sfhowes and all the community for the help ;-)
Was this helpful to you? 1
Citata
Wayne Mery
  • Top 25 Contributor
  • Moderator
Sprendimų: 596 Atsakymų: 5617

The updated gdata - provider for google calendar - is available https://addons.thunderbird.net/en-US/thunderbird/addon/provider-for-google-calendar/

The updated gdata - provider for google calendar - is available https://addons.thunderbird.net/en-US/thunderbird/addon/provider-for-google-calendar/
Was this helpful to you?
Citata
dave1650 Sprendimų: 0 Atsakymų: 1

walter.andrea29 said

I can confirm that now it works in this way for me. My configuration is with Thunderbird v60.9.0 (64-bit) and Linux Mint 19.2 (64bit), and it works also with gContactSynch add-on installed. To summarize to anyone who needs, just go on "Edit/Preferences/Advanced/Config Editor", then find "general.useragent.compatMode.firefox" and change it on "true" (right mouse --> "toggle") Here two screenshots to be more clear too. Many thanks to sfhowes and all the community for the help ;-)

The screen shots were really helpful. Thanks for the info. It worked for me after attempting to figure out how to get gmail to work for hours.

''walter.andrea29 [[#answer-1264407|said]]'' <blockquote> I can confirm that now it works in this way for me. My configuration is with Thunderbird v60.9.0 (64-bit) and Linux Mint 19.2 (64bit), and it works also with gContactSynch add-on installed. To summarize to anyone who needs, just go on "Edit/Preferences/Advanced/Config Editor", then find "general.useragent.compatMode.firefox" and change it on "true" (right mouse --> "toggle") Here two screenshots to be more clear too. Many thanks to sfhowes and all the community for the help ;-) </blockquote> The screen shots were really helpful. Thanks for the info. It worked for me after attempting to figure out how to get gmail to work for hours.
Was this helpful to you?
Citata
Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.