Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot delete items when logged into my wordpress account on Firefox, but am able to on Google Chrome.

  • 5 replies
  • 1 has this problem
  • 25 views
  • Paskiausią atsakymą parašė lovelylefty

more options

It doesn't just extend to Wordpress. Even using other websites, such as Gmail, I'll click on a link and it won't open. I'll have to scroll through with the arrow keys and hit enter for the link to load. Again, the same websites work perfectly on Google Chrome, Internet Explorer, etc. Is there any way to fix this as I hate switching back from Firefox to Chrome, and may need to stick to Chrome if such a simple solution can't be resolved.

It doesn't just extend to Wordpress. Even using other websites, such as Gmail, I'll click on a link and it won't open. I'll have to scroll through with the arrow keys and hit enter for the link to load. Again, the same websites work perfectly on Google Chrome, Internet Explorer, etc. Is there any way to fix this as I hate switching back from Firefox to Chrome, and may need to stick to Chrome if such a simple solution can't be resolved.

Chosen solution

Thank you. With both of your help I was able to solve the problem.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (5)

more options

Please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please update your Flash 26.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please let us know if this solved your issue or if need further assistance.

more options

Hi lovelylefty, being able to click links is pretty fundamental, so I'm surprised you are finding that to be broken on multiple sites.

What is the issue with deleting on WordPress? Are you editing a post or comment, or removing spam, etc.?

General Suggestions

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I saw Jscher's suggestion, before the previous one. Starting it in safemode, does cause it to work correctly. However, I can't identify what is causing it to act. I tried disabling extensions, plugins, one by one. Did I miss a step? Perhaps forgot to check on something?

more options
more options

Chosen Solution

Thank you. With both of your help I was able to solve the problem.