Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot block youtube.com cookies

  • 2 replies
  • 1 has this problem
  • 92 views
  • Paskiausią atsakymą parašė molerat

more options

I am trying to prevent youtube.com from saving cookies on my computer. I also tested this with google.com.

I go into the options -> Privacy Then I set "Use custom settings for privacy", "Accept cookies from sites" is checked, Accept third party is set to always. I then open up the exceptions button, type in "youtube.com" and click block. Exit out of options, and visit youtube.com. A cookie is saved under the name/folder "youtube.com"

Did the same steps for blocking google.com, visit google and a cookie shows up with the name "google.com"

I tried blocking both sites with and without the www at the begining, but neither works.

One thing of note: whenever I click on block in the exceptions list firefox automatically adds "http://" to the link before youtube, but the cookie viewer only lists it as "youtube.com" without the http. I wouldn't think this should affect it, but sometimes the obvious is overlooked.

After some testing I did a clean reinstall of firefox. Uninstalled, deleted all folders and whatnot left behind, and then reinstalled. The problem persisted with a clean install.

I am trying to prevent youtube.com from saving cookies on my computer. I also tested this with google.com. I go into the options -> Privacy Then I set "Use custom settings for privacy", "Accept cookies from sites" is checked, Accept third party is set to always. I then open up the exceptions button, type in "youtube.com" and click block. Exit out of options, and visit youtube.com. A cookie is saved under the name/folder "youtube.com" Did the same steps for blocking google.com, visit google and a cookie shows up with the name "google.com" I tried blocking both sites with and without the www at the begining, but neither works. One thing of note: whenever I click on block in the exceptions list firefox automatically adds "http://" to the link before youtube, but the cookie viewer only lists it as "youtube.com" without the http. I wouldn't think this should affect it, but sometimes the obvious is overlooked. After some testing I did a clean reinstall of firefox. Uninstalled, deleted all folders and whatnot left behind, and then reinstalled. The problem persisted with a clean install.

Chosen solution

I do think you need the protocol when you enter sites directly into the Exceptions dialog, and with Google sites, it's probably https:// rather than http://. Here's another way:

When you're on the site, call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer.

Before closing Page info, switch over to the Security panel. There you can use the View Cookies button to clear the cookies previously set by the site.

Then you can close out of Page Info, reload the page (try Ctrl+Shift+r to bypass the cache and load it fresh), and when you View Cookies again, you shouldn't find any for that site.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (2)

more options

Chosen Solution

I do think you need the protocol when you enter sites directly into the Exceptions dialog, and with Google sites, it's probably https:// rather than http://. Here's another way:

When you're on the site, call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer.

Before closing Page info, switch over to the Security panel. There you can use the View Cookies button to clear the cookies previously set by the site.

Then you can close out of Page Info, reload the page (try Ctrl+Shift+r to bypass the cache and load it fresh), and when you View Cookies again, you shouldn't find any for that site.

more options

Changing the permissions the way you listed did the trick. Odd that it shouldn't work in the cookie exception list though.

About the http thing, it wasn't me adding it. If you type whatever address into the cookie exception list firefox adds it to the beginning automatically.