Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do some videos not load after updating to Firefox 45.0.1?

  • 8 replies
  • 18 have this problem
  • 6728 views
  • Paskiausią atsakymą parašė AlSwilling

more options

I read somewhere that the recent update from Firefox 45.0 to 45.0.1 was, in part, to fix an issue where some videos do not load in Firefox if third party cookies were blocked.

In my case, all videos loaded fine UNTIL I installed the update that Firefox said it needed, which was to update Firefox 45.0 to 45.0.1. After the update, some video files will not load at all. The video page and player will load, and the loading animation will start, but the video never loads. On sites that have an indicator as to what percentage of the file is loaded, it will go up to 99%, but will never finish loading, if it is really loading at all.

All my plugins related to video files are up to date. I am running Windows 7 SP1 64-bit operating system, have plenty of RAM. I began having the problem when I updated Firefox from v. 45.0 (32-bit version) to v. 45.0.1. Before the update, everything was working fine.

I tried playing the same videos in Internet Explorer 11, and they load and play just fine. Therefore, it is a Firefox issue, and a Firefox 45.0.1 issue specifically.

Am I just stuck with this albatross, or is there somewhere I can download Firefox 45.0 and go back to that version of Firefox?

Please reply

Chosen solution

In response to a different thread, I created a user script which hides all of your plugins on selected sites (you can add CNN, for example). I don't know whether that would be more convenient than toggling Flash on and off.

Html5 player on specific website

Skaityti atsakymą kartu su kontekstu 👍 2

All Replies (8)

more options

After playing with the settings, and reinstalling Firefox version 45.0, I found the problem.

For future reference, for those who are having the same problem, the problem is that there is a compatibility issue between two plugins: OpenH264 Video Codec by Cisco Systems Inc, v. 1.5.3 and Shockwave Flash v. 21.0.0.182.

Until these two major developers can get their act together and work out the problem, there is a workaround.

The resolution to the problem is to set Shockwave Flash to "Never Activate". This will allow videos that would not play or load to play normally.

There are some sites, still, that use Flash as their player of choice, instead of OpenH264. For those sites, Shockwave Flash must be set to "Always Activate, or to "Ask to Activate".

On most sites, Flash and OpenH264 will coexist; but on sites like CNN, their video configuration fails if both plugins are active. What happens is that the site, which is set up to detect whether you have Shockwave Flash or OpenH264 plugin, sees both plugins and tries to load both players, which results in an error, or a player loading but an inability to play the video.

So, if you have both Shockwave Flash and OpenH264, and you have problems playing videos on some pages, try going into the Add-Ons manager and setting the Shockwave Flash plugin to "Never Activate", then reload the problematic page. The video should then play correctly.

more options

There is one other add-on that sometimes interferes with Flash Player's function. If you are running the extension Ghostery, depending on your configuration, it can sometimes interfere with the loading of the Flash Player.

This issue can be demonstrated when updating the Flash Player. After going to Adobe's download page for Flash and updating Flash Player, the browser will open and take you to a follow-up page. On that page, it says "Other products you might like", or something to that effect. Below that statement, you should see a Flash animation of the product being promoted. If Ghostery is active and configured in a certain way, there will be a blank area where the Flash animation should be. By turning Ghostery OFF and reloading the page, the Flash animation will load and run. Turning Ghostery ON again and reloading the page causes the Flash animation to disappear. This happens when Ghostery is configured to prevent Flash-based ads from loading. It can also potentially prevent some videos from loading properly or even showing up on the page.

The solution is to disable Ghostery and reload the affected page.

Modified by AlSwilling

more options

That was very good work. Well Done.

more options

This is odd because the OpenH264 plugin is not used by websites for video playback. The HTML5 video player is built into Firefox itself, and uses external resources such as Windows Media Foundation for decoding non-open formats. If you aren't using Hello, I think you can safely disable OpenH264 as an alternate workaround.

more options

Fred McD, thank you.

jscher2000, with respect, I know what worked for me. I tried disabling the OpenH264 plugin and leaving the Shockwave Flash player set at "Always Activate" and then "Ask to Activate", and videos on CNN would not load at all. The player would load, but the video would not load or play.

To be sure I did not tell you wrong, I just repeated that procedure: disabled the OpenH264 plugin and left Shockwave Flash set to "Always Activate", and the videos would not play.

Out of curiosity, I also tried disabling both Shockwave Flash and the OpenH264 plugin and clicking on a couple of videos on CNN. With both the plugins disabled, the videos at CNN loaded and played normally.

To summarize, on problematic sites where the video will not play with both the OpenH264 and Shockwave Flash plugins enabled, the videos will not play with Shockwave Flash enabled, regardless of whether the OpenH264 plugin is enabled or disabled.

There are only two workarounds, and both require Shockwave Flash to be set to "Never Activate".

Solution 1: As previously stated, set Shockwave Flash to "Never Activate", and leave OpenH264 set to "Always Activate".

Solution 2: Set both the OpenH264 and Shockwave Flash to "Never Activate".

Since Solution 1 works on all sites tested, with CNN being typical, there is no need to disable the OpenH264 plugin to resolve the issue; but it is necessary to disable Shockwave Flash. Since there are still sites that require Shockwave Flash in order to play videos, the Shockwave Flash plugin is still necessary, and cannot be removed.

Thank you, jscher2000 for the information that led to that discovery.

The fact that OpenH264 can be disabled without affecting video playback changes the dynamics of the problem.

The point is, Shockwave Flash's being enabled will cause videos on CNN to fail to load or play in Firefox 45.0 and 45.0.1.

On the other hand, Internet Explorer 11 (IE11) [Version: 11.0.9600.18230 Update Version: 11.0.29 (KB3139929)] also has a Shockwave Flash plugin installed, but it plays videos on the problematic web sites with no problems, without having to disable the Shockwave Flash plugin.

Perhaps there is something about IE11 that Mozilla should implement in future Firefox versions in order to eliminate the necessity of spending time disabling plugins in order to view videos on CNN or other sites with similar configuration.

more options

Chosen Solution

In response to a different thread, I created a user script which hides all of your plugins on selected sites (you can add CNN, for example). I don't know whether that would be more convenient than toggling Flash on and off.

Html5 player on specific website

more options

jscher2000 said

In response to a different thread, I created a user script which hides all of your plugins on selected sites (you can add CNN, for example). I don't know whether that would be more convenient than toggling Flash on and off. Html5 player on specific website

Excellent script! I already had Greasemonkey installed, so it was just a matter of installing the script and configuring it. It works very well. It definitely is more convenient than opening Add-on Manager and toggling Flash on and off. It's definitely a keeper.

Thank you very much, jscher2000, for that. I'll recommend it to others I encounter who have similar problems.

As we old Hippies used to say, "Peace, brother!"

Modified by AlSwilling

more options

This problem is officially solved, thanks to jscher2000. Thank you for your help.