Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Norton Confidential tells me it is not supported by my version of Firefox (I have 44.0.2); it says it requires Firefox 1.5 or later, how can this be fixed?

  • 4 replies
  • 1 has this problem
  • 70 views
  • Paskiausią atsakymą parašė FredMcD

more options

When I start Firefox (44.0.2) on my Mac, I get a message from Norton Confidential saying that this version of Firefox is not supported by Norton Confidential. Further, it says that I will not be protected while browsing the Web. Then this: "Norton Confidential cannot protect you while you use this version of Firefox. Phishing Protection requires Firefox 1.5 or later."

I'm confused about the versions of Firefox they mention???

How can this be fixed?

Chosen solution

How long have you had Norton Confidential? Symantec discontinued it a long time ago, and it does not surprise me at all that it doesn't work now.

Actually, we had a similar question two years ago: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later.

If you are concerned about not being protected from phishing attacks, bear in mind that Firefox includes some level of phishing protection: How does built-in Phishing and Malware Protection work?

To supplement that feature, you can use an external service such as OpenDNS which updates faster than the Google SafeBrowsing data used by Firefox: https://www.opendns.com/home-internet-security/

  • This is free for home use
  • Works by blocking your browser from accessing suspicious sites (kicks in if you try to load the bad page)

Neither of those would help with evil email attachments, so of course be very cautious with unexpected files you receive in email.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (4)

more options

Chosen Solution

How long have you had Norton Confidential? Symantec discontinued it a long time ago, and it does not surprise me at all that it doesn't work now.

Actually, we had a similar question two years ago: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later.

If you are concerned about not being protected from phishing attacks, bear in mind that Firefox includes some level of phishing protection: How does built-in Phishing and Malware Protection work?

To supplement that feature, you can use an external service such as OpenDNS which updates faster than the Google SafeBrowsing data used by Firefox: https://www.opendns.com/home-internet-security/

  • This is free for home use
  • Works by blocking your browser from accessing suspicious sites (kicks in if you try to load the bad page)

Neither of those would help with evil email attachments, so of course be very cautious with unexpected files you receive in email.

more options

Oh, you can disable Norton Confidential so you are not bothered by this message. For that, go to the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find that extension on the right and click its Disable button. If a link appears above the extension to restart Firefox, you might just wait until the next time you quit out, if the message only appears at startup.

Modified by jscher2000

more options

millertb said

I'm confused about the versions of Firefox they mention??? How can this be fixed?

By not using a software that has not been supported by Norton for years now since 2007?. Firefox 1.5 came out way back on November 29, 2005 so over ten years ago.

Modified by James

more options