Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Google Adsense ads are not showing in Firefox, but do in other browsers.

  • 6 replies
  • 15 have this problem
  • 8615 views
  • Paskiausią atsakymą parašė cor-el

more options

I recently moved to another city, and after having my sons set up my computer, I have noticed that the Google Adsense ads that I have placed on my web site are not showing up in Firefox, yet they do show in other browsers. I've updated Java, cleared history and cache, etc., and Restarted my computer. And don't have any ad blockers going. Other people I know are able to see the ads; as well as Google staff, who say it is a problem with my computer. Any ideas what I can do? Thanks,

MSS

Chosen solution

Firefox 42+ has a new Tracking Protection feature that is enabled by default in Private Browsing mode. You can see a shield icon at the left end of the location/address bar when you are in private browsing mode that some content is blocked.

You can disable this feature in "Options/Preferences > Privacy".

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"
Skaityti atsakymą kartu su kontekstu 👍 4

All Replies (6)

more options

Chosen Solution

Firefox 42+ has a new Tracking Protection feature that is enabled by default in Private Browsing mode. You can see a shield icon at the left end of the location/address bar when you are in private browsing mode that some content is blocked.

You can disable this feature in "Options/Preferences > Privacy".

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"
more options

I found a slightly different solution. Changing from Never Remember History to Remember history seemed to solve the problem (see: http://www.jigsolving.com/general/facebook-page-like-counts-google-adsense-not-showing-in-firefox )

Both methods (turn off tracking or remember history) seem to work.

more options

Never Remember History means that Private Browsing mode is active. By choosing Remember History you disable PB mode.

Tracking Protection is controlled by these prefs, the latter can be accessed via "Options/Preferences > Privacy" in current releases.

  • privacy.trackingprotection.enabled = false
  • privacy.trackingprotection.pbmode.enabled = true
more options

Thanks - Makes sense. Feel free to remove the post.

Modified by Damien_MEL

more options

I have this problem. I have no ad blocker installed, am not using private mode, and have disabled tracking protection. My web site's ads do not show on Firefox, but show on Chrome.

more options

Hi matthewmontagupollock

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.

If you could post a link to a publicly accessible page (i.e. no authentication or signing on required) in that new thread then we can check what is going on.