Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Automatically clears address bar and leaves cursor in address bar every time new web page is opened

  • 4 replies
  • 3 have this problem
  • 2 views
  • Paskiausią atsakymą parašė LeafbladeN

more options

whenever i open a new tab, or open one of my bookmarks in a new or existing tab, after a second or two the address bar is cleared entirely and even if i clicked a new text box or pressed the spacebar to scroll I find that it would start typing in the address bar. This just started happening today after I restarted my computer.

whenever i open a new tab, or open one of my bookmarks in a new or existing tab, after a second or two the address bar is cleared entirely and even if i clicked a new text box or pressed the spacebar to scroll I find that it would start typing in the address bar. This just started happening today after I restarted my computer.

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (4)

more options

When you open a new tab using Ctrl+t or the "+" button on the tab bar it's normal for the address bar to be selected/focused immediately.

However, opening a link or bookmark in a new tab generally does not do that.

Do you have any tab related add-ons that might have updated recently and changed behavior? You can review your extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, consider whether any might affect tabs and look for a Options button to check their settings.

If you see any unknown or nonessential extensions, try disabling them for the time being so you can focus on the most important ones.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any difference?

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

By the way, there are three keyboard shortcuts that can select the address bar, AKA the Location bar:

  • Ctrl+L
  • Alt+D
  • F6

If you notice the problem occurring when typing L or D, it could be that Firefox is misreading the state of the Ctrl or Alt keys on your keyboard. Sometimes tapping the keys several times will resolve the issues. In extreme cases, you might need to shut down and restart Windows.

more options

LeafbladeN said

whenever i open a new tab, or open one of my bookmarks in a new or existing tab, after a second or two the address bar is cleared entirely and even if i clicked a new text box or pressed the spacebar to scroll I find that it would start typing in the address bar. This just started happening today after I restarted my computer.

It worked just fine in safe mode. must be an add on or extension then. going to weed through them until I find what changed or was updated today