Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

Disable automatic recovery

  • 3 답장
  • 1 이 문제를 만남
  • 75 보기
  • 최종 답변자: lukasmaes

more options

After a crash, or even after shutting down the computer without closing all Firefox windows, Firefox will restore all the windows and tabs from the last session on restarting Firefox.

There can be many reasons why this may not be preferred behaviour for many users: Sometimes Firefox or the computer crashes because too many windows and tabs are open (and other applications running), killing Firefox may be a measure against malicious pages trying to hijack the browser, discarded pages after shutdown do not need to be restored, ...

So is there a way to make Firefox immediately ask whether to restore the session, like it already does after the second crash? This should actually be an option in the settings.

선택된 해결법

I actually found the answer in the Firefox support pages, but it was not marked as the solution to that question. So I'll post it here again and mark it as the solution.

So from jscher2000's answer:

"To always have a choice about crash recovery, turn off automatic crash recovery as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste resume and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference to display a small edit box and change from 1 to 0 (that's a zero) then click OK"

문맥에 따라 이 답변을 읽어주세요 👍 0

모든 댓글 (3)

more options

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

도움이 되셨습니까?

more options

I don't understand why it would have to do corrupt files. From Firefox' help page I understand this is intended behaviour: "Firefox will automatically restore your previous session, the first time you launch it after a crash."

I wish to change that it automatically restores the previous session, and immediately ask me.

도움이 되셨습니까?

more options

선택된 해결법

I actually found the answer in the Firefox support pages, but it was not marked as the solution to that question. So I'll post it here again and mark it as the solution.

So from jscher2000's answer:

"To always have a choice about crash recovery, turn off automatic crash recovery as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste resume and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference to display a small edit box and change from 1 to 0 (that's a zero) then click OK"

도움이 되셨습니까?

질문하기

글에 답글을 달기 위해서는 계정으로 로그인해야만 합니다. 계정이 아직 없다면 새로운 질문을 올려주십시오.