Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blank Log-in Page

  • 7 replies
  • 1 has this problem
  • 99 views
  • Last reply by FredMcD

more options

I don't know what's going on with firefox now, but i can't log in to Covered CA with this browser using the latest updated version firefox (v 98.0 64bit). When i click on the log in page on Covered CA website, all i could see is a blank page; but, if i switch to Edge browser, i could see the log in page just fine. Anyone knows how to fix this? Thanks.

PS: i tried to restart in Troubleshoot mode to get rid of all extensions, but that still doesn't help to fix it.

Edit: the link to the website's home is: https://www.coveredca.com/ click "sign in" from there and the problem starts

I don't know what's going on with firefox now, but i can't log in to Covered CA with this browser using the latest updated version firefox (v 98.0 64bit). When i click on the log in page on Covered CA website, all i could see is a blank page; but, if i switch to Edge browser, i could see the log in page just fine. Anyone knows how to fix this? Thanks. PS: i tried to restart in Troubleshoot mode to get rid of all extensions, but that still doesn't help to fix it. Edit: the link to the website's home is: https://www.coveredca.com/ click "sign in" from there and the problem starts
Attached screenshots

Modified by spfleet

Chosen solution

I refreshed firefox browser in the troubleshoot mode and now it is working fine. Thanks for the helps

Read this answer in context 👍 0

All Replies (7)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Can you post a similar screenshot showing the issue? see screenshot

more options

jonzn4SUSE said

Can you post a similar screenshot showing the issue? see screenshot

Added pics. hmmm, seems yours is working fine. wonder what's wrong with mine.

more options

FredMcD said

Please provide a public link (no password) that we can check out. No Personal Information Please ! Make sure you are not blocking content. https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/ https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

1) edited in link to the website. 2) i didn't touch any of the enhanced securities/privacy settings so i don't think that's the problem. I just tried turning on/ off the enhanced tracking protection like you suggested, but didn't solve the problem :( 3) and no, safe mode does not fix the problem 4) clearing cache and cookies didn't fix it either

Modified by spfleet

more options

Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address box.

more options

Chosen Solution

I refreshed firefox browser in the troubleshoot mode and now it is working fine. Thanks for the helps

more options

That was very good work. Well Done.