Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

update

  • 3 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

update

Modified by cor-el

All Replies (3)

more options

Hey there!

Thanking you for reaching out! Is it possible to give some more information about your question so that I can assist you better?

Thank you!

Bithiah Koshy

Helpful?

more options

Hey there!

If your problem is solved, please mark an answer as a solution to let others know this thread is finished. Thanks!

Kind regards,

Bithiah

Helpful?

more options

Your Windows XP platform is no longer supported, so you can no longer update Firefox beyond Firefox 52. Current Firefox releases require Windows 7 and newer. Users on Windows XP and Vista have been moved to the Firefox 52 ESR version.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.