Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web notifications don't work

more options

I turned on web notifications but I don't receive them.

All Replies (3)

more options

Do you mean a site asked for permission to send you notifications, and you granted the site permission, and you haven't received any notifications from that site?

You could test with this page (silly, but, it's just for testing):

https://mdn.mozillademos.org/en-US/docs/Web/API/Notifications_API/Using_the_Notifications_API$samples/Tag_example

I don't know whether I changed it, but instead of a panel dropping down from the left end of the address bar to grant permission, an icon wiggles back and forth and then I can click it.

Helpful?

more options

Yes. I tested your site and it worked. But on my site it doesn't work

Helpful?

more options

If you click the lock, does it show that you gave the site permission to show notifications? If the site isn't triggering the wiggling notification icon, I guess that's the first problem.

Another way to give a permission to the site if the icon doesn't appear is to use the Permissions panel of the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • (menu bar) Tools > Page Info
  • click the lock icon > then the ">" button > More Information

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Send Notifications" and uncheck the "Use default" box, and then select Allow to let the site show notifications.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.