On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do i disable the fullscreen animation?

  • 5 replies
  • 2 have this problem
  • 7643 views
  • Last reply by effgo

more options

Heyo,

       I switched to firefox today and I noticed that on youtube there's an animation (fade in and out) when fullscreening. Is there any way to disable this?

Thanks

Heyo, I switched to firefox today and I noticed that on youtube there's an animation (fade in and out) when fullscreening. Is there any way to disable this? Thanks

Chosen solution

hello,

sorry to hear this problem,

follow the steps and instruction your easily to resolved:

  1. Open Firefox and type about:config in the addressbar and press Enter. ...
  2. Now type animate in the Filter box and look for following integer key:
  3. The entry "browser. ...
  4. Now whenever you go into full screen mode, you'll not see the animation.

NOTE: If you are using newer versions of Mozilla Firefox, you should check out following :

for more information visit given link:

[https://www.askvg.com/how-to-disable-animation-while-going...]

i hope to resolve your problem then reply back to me and mark the solution.

Thank you asked Question in Mozilla,

Regards,

Arman

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

hello,

sorry to hear this problem,

follow the steps and instruction your easily to resolved:

  1. Open Firefox and type about:config in the addressbar and press Enter. ...
  2. Now type animate in the Filter box and look for following integer key:
  3. The entry "browser. ...
  4. Now whenever you go into full screen mode, you'll not see the animation.

NOTE: If you are using newer versions of Mozilla Firefox, you should check out following :

for more information visit given link:

[https://www.askvg.com/how-to-disable-animation-while-going...]

i hope to resolve your problem then reply back to me and mark the solution.

Thank you asked Question in Mozilla,

Regards,

Arman

more options

You can modify these prefs on the about:config page to disable the full screen fade in and fade out.
Leave out the quotes around the value (enter two zeros separated by a space).

  • full-screen-api.transition-duration.enter = "0 0"
  • full-screen-api.transition-duration.leave = "0 0"

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

cor-el said

You can modify these prefs on the about:config page to disable the full screen fade in and fade out.
Leave out the quotes around the value (enter two zeros separated by a space).
  • full-screen-api.transition-duration.enter = "0 0"
  • full-screen-api.transition-duration.leave = "0 0"
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This doesn't seem to be working anymore. I still get the damn animation. In the old times Browser.fullscreen.animateUp 0 worked like a charm. It doesn't work either.

Modified by effgo

more options

I think that the prefs should still work if I check the source code.

more options

cor-el said

I think that the prefs should still work if I check the source code.

Well, they don't. It seems the only thing available right now is this workaround https://www.reddit.com/r/firefox/comments/j9agb3/disable_the_fullscreen_animation_in_firefox_80/

Thank god for this as whoever came up with the animation is some kind of a sociopath. Before any kneejerking reaction I suggest checking the state of the animation first.