Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disabling image loading doesn't work

  • 7 replies
  • 2 have this problem
  • 183 views
  • Last reply by jscher2000

more options

I am following the instructions found on the web: about:config set "permission.default.image" to 2 reload pages or restart FireFox but images loading is not disabled.

Chosen solution

If you want a "recommended" extension to block images, try uBlock Origin . Select 'I am an advanced user' in its Options page. The next time the toolbar button is clicked, there will be a setting to disable images globally or locally.

Read this answer in context 👍 0

All Replies (7)

more options

Removing support for permissions.default.image is an intentional change, see the Firefox 72 release notes.

Support for blocking images from individual domains has been removed from Firefox, because of low usage and poor user experience. For now you can revert this change by modifying this pref on the about:config

  • extensions.contentblocker.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

You also could try the add-on "Image Video Block":

https://addons.mozilla.org/firefox/addon/image-video-block/

Use its toolbar button to set your global default settings. When there's a site where you want site-specific settings, you can use the right-click context menu in the page or its drop-down menu. I'm attaching a screenshot of the menu showing global settings and how to make site exceptions.

more options

Thank you both for the helpful answers.

@cor-el It works. Thank you. Would you also have a link to a description of that preference ?

@jscher2000 this is not a "recommended" extension and has not been updated since 2018. I see that it is free software, but I worry about potential security issues. Would you know of a recommended extension that has similar effects ?

more options

The pref got added in this bug report.

  • Bug 1597541 - Add a pref and disable nsContentBlocker by default

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Chosen Solution

If you want a "recommended" extension to block images, try uBlock Origin . Select 'I am an advanced user' in its Options page. The next time the toolbar button is clicked, there will be a setting to disable images globally or locally.

more options

Most of the times, when i use up my internet quota i switch to text-only mode to read without images. But there's no way to get text-only version or maybe block images from loading. is there any way to get it done.

  • permissions.default.image = 2

doesn't work

  • extensions.contentblocker.enabled [= true]

doesn't work

i use ublock Origin but it doesn't help in getting text version of any site faster.

Modified by ADNAN PMI

more options

Hi ADNAN PMI, you could look at uMatrix:

https://addons.mozilla.org/firefox/addon/umatrix/