X
Tap here to go to the mobile version of the site.

Support Forum

Hello, just would like to know, if the sollution from https://support.mozilla.org/en-US/questions/1092572 works in Mozilla Firefox version 70.0.1 - thank you.

Posted

Need to block Firefox menu mouse pop-up function in fullscreeen mode, and this sollution solves exactly this problem, but not working with my version, which is 70.0.1 Is there anything else, what I could do to disable menu pop-up by moving mouse near top of screen when in full-screen mode?

Need to block Firefox menu mouse pop-up function in fullscreeen mode, and this sollution solves exactly this problem, but not working with my version, which is 70.0.1 Is there anything else, what I could do to disable menu pop-up by moving mouse near top of screen when in full-screen mode?

Chosen solution

The AppData\Local location is the wrong location for the profile folder. The main profile folder is in "AppData\Roaming".

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

TyDraniu
  • Top 25 Contributor
338 solutions 1899 answers

Helpful Reply

Yes, it should work, but now you have to enter about:config in the URL bar and set toolkit.legacyUserProfileCustomizations.stylesheets = true.

Yes, it should work, but now you have to enter about:config in the URL bar and set ''toolkit.legacyUserProfileCustomizations.stylesheets'' = '''true'''.
Was this helpful to you? 1
Quote

Question owner

Hi TyDraniu, tried your solution, but still no success :(

Checked userChome.css file path: C:\Users\<username>\AppData\Local\Mozilla\Firefox\Profiles\<profilename>.default\chrome\ -> seems OK.

CSS contains: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. fullscr-toggler { display:none!important; }

(Hope the hash (#) on the 3rd line doesn't mean it is some kind of a comment...)

checked about:config and the toolkit.legacyUserProfileCustomizations.stylesheets value is set to true

Restarted Firefox, loaded some page, switched to fullscreen and Firefox still shows menu and address bar when mouse near the top of the screen :(

Thank you, but I still have no luck..

Hi TyDraniu, tried your solution, but still no success :( Checked userChome.css file path: C:\Users\<username>\AppData\Local\Mozilla\Firefox\Profiles\<profilename>.default\chrome\ -> seems OK. CSS contains: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); #fullscr-toggler { display:none!important; } (Hope the hash (#) on the 3rd line doesn't mean it is some kind of a comment...) checked about:config and the toolkit.legacyUserProfileCustomizations.stylesheets value is set to true Restarted Firefox, loaded some page, switched to fullscreen and Firefox still shows menu and address bar when mouse near the top of the screen :( Thank you, but I still have no luck..
Was this helpful to you?
Quote

Question owner

CSS FILE: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. fullscr-toggler { display:none!important; }
CSS FILE: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); #fullscr-toggler { display:none!important; }
Was this helpful to you?
Quote

Question owner

There is not "1." but the "hash" symbol..

There is not "1." but the "hash" symbol..
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
338 solutions 1899 answers

Helpful Reply

Well, that works for me.

Try to remove the first line.

There is only

#fullscr-toggler { display:none!important; }
Well, that works for me. Try to remove the first line. There is only #fullscr-toggler { display:none!important; }
Was this helpful to you? 1
Quote

Question owner

Hi TyDraniu, unfortunately, still no success :( I removed the first line, closed other browser panels, disabled all browser addons, tried to empty browser cache just for to be sure and restarted the browser.. but nothing changed, it does not works.

Hi TyDraniu, unfortunately, still no success :( I removed the first line, closed other browser panels, disabled all browser addons, tried to empty browser cache just for to be sure and restarted the browser.. but nothing changed, it does not works.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

Chosen Solution

The AppData\Local location is the wrong location for the profile folder. The main profile folder is in "AppData\Roaming".

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

The AppData\Local location is the wrong location for the profile folder. The main profile folder is in "AppData\Roaming". You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file. See also: *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html
Was this helpful to you? 1
Quote

Question owner

Hi cor-el, I moved the whole chorme folder to the roaming profile path and it works like a charm, of course. It was my mistake, that I created the chrome folder in the AppData\Local profile..

Thank you very much - problem solved

Hi cor-el, I moved the whole chorme folder to the roaming profile path and it works like a charm, of course. It was my mistake, that I created the chrome folder in the AppData\Local profile.. Thank you very much - problem solved
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

You're welcome

You're welcome
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.