Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Your system doesn't meet the requirements to run Firefox.

  • 2 replies
  • 1 has this problem
  • 349 views
  • Last reply by vyickie

more options

I got xp 32 computer pack 3 do not know much about computers only what i read I got ff 37.0.1 , when I click on About Firefox tells me it is up to date when i check on Plugins and see if i need to update i get that msg been for long time i do not know what to do , been with ff for years

Chosen solution

Windows is identifying itself as Windows2000 when you're using Firefox. Right-click the Firefox shortcut on the desktop and open Properties. Then look at the Compatibility tab in Properties. Deselect Run this program in compatibility mode for: [Windows 2000]

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Windows is identifying itself as Windows2000 when you're using Firefox. Right-click the Firefox shortcut on the desktop and open Properties. Then look at the Compatibility tab in Properties. Deselect Run this program in compatibility mode for: [Windows 2000]

more options

Thank you worked it tried for long time trying to find a answer, So simple and now i am updated , Thanks