Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox didn't load correctly, not a problem of graphics card (IMO)

  • 4 replies
  • 3 have this problem
  • 214 views
  • Last reply by Bonar

more options

I have this problem when play "pets" on tagged.com. I am running Firefox 33.0.2 on Windows 8

http://www.uploadhouse.com/viewfile.php?id=20142918

http://www.uploadhouse.com/viewfile.php?id=20142917

Chosen solution

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Read this answer in context 👍 1

All Replies (4)

more options

Hello,

Does the site work fine in other browsers?

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Modified by CoryMH

more options

Yes, it works fine on Google Chrome.

Umm... Let me try Safe Mode first. Thank you


Updates: Sometimes I got normal page view, and sometime I didn't. Not only tagged as I mentioned before, also Facebook and your site (screenshot: http://www.uploadhouse.com/viewfile.php?id=20142917 ). It's weird. Happened after updating to FF 33.0

Looks fine when I am on Safe Mode

Modified by Bonar

more options

Chosen Solution

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

It's solved now, FireShot Webpage Screenshots is the problem.

Problem solved. Thank you very much


EDIT (11/13):

After removing Fireshot, I'm still experiencing the same problem. So now I disable Social Fixer and remove Troubleshooter.

Wish it definitely solve my problems :(

I will let you know later in a week or two

Modified by Bonar