Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Cari Bantuan

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mouse pointer jumps to top of screen when dialog box opens

  • 15 balas
  • 7 memiliki masalah ini
  • 9 kunjungan
  • Balasan terakhir oleh FredMcD

more options

Within the last few weeks my mouse pointer occasionally jumps to the extreme top (left side) of the FF browser window. Only happens in FF, not Chrome or IE or any other MS application. Reloaded fresh up-to-date mouse drivers, switched mouses, switched USB ports, switched to a non MS mouse - all to no avail.

It seems to happen more often when I have the mouse's 'snap to" feature enabled that automatically moves the pointer to the default button in the dialog box.

This along with FF's unique inability to hide the pointer when typing (when set in the mouses's Properties box) have become very annoying.

Please address and fix both of the above problems. Thanks.

Within the last few weeks my mouse pointer occasionally jumps to the extreme top (left side) of the FF browser window. Only happens in FF, not Chrome or IE or any other MS application. Reloaded fresh up-to-date mouse drivers, switched mouses, switched USB ports, switched to a non MS mouse - all to no avail. It seems to happen more often when I have the mouse's 'snap to" feature enabled that automatically moves the pointer to the default button in the dialog box. This along with FF's unique inability to hide the pointer when typing (when set in the mouses's Properties box) have become very annoying. Please address and fix both of the above problems. Thanks.

Solusi terpilih

Great News! Good going. For the time being you may want to disable KeyScrambler. You can always turn it on when you need it.

Baca jawaban ini dalam konteks 👍 0

Semua Balasan (15)

more options

Try turning off anything having to do with auto-moving the mouse. Does your system have a touch pad? Sometimes my pad acts like I touched something when I did not. So I disabled the pad.

more options

Whether I have the "Snap-to" feature enabled or not in my mouse software, any dialogue box opening in FF results in the mouse cursor immediately jumping to the extreme top of the screen directly above the word History. Happens 100% of the time and only in FF. Touch pad is disabled but it also happens if no mouse is connected and the Touch Pad is active (only active if no mouse plugged in). All this started around vers. 25 of FF.

Best example: When X'ing out of FF, dialogue box comes up asking to Save and Quit, Quit, Save and Restore at Startup, Cancel. Upon opening this dialogue box, mouse pointer jumps to top of screen as described above. See screen image attached.

Very, very annoying.

Diperbarui oleh oldgeek42 pada

more options

Clear the Cache Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If there is still a problem, Start Firefox in Safe Mode While you are in safe mode; Firefox Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

more options

@FredMcD. Thanks. Tried your suggestions but did not solve problem. Also I have FF set to clear history and cookies when it closes. I also run Ccleaner everyday y before shutting down my system. Should I submit a big report on Bugzilla? Thanks.

more options

Run several of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

You may have switched on caret browsing.

You can toggle caret browsing on/off by pressing F7 (Mac: fn + F7).

  • Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Note that this is an accessibility feature of Firefox.

more options

@FredMcD. Thanks. Have run deep scans on both MS Security Essentials, Malwarebytes, and regular scans on Spybot which I do weekly or whenever I suspect a problem. No hits, no help.

Also noticed when I am in FF Options, the response to choices is very slow. But response to clicks is fine when in normal browsing mode. Weird.

BTW, on Vers. 27 of FF, running Win 7 fully up to date.

Diperbarui oleh oldgeek42 pada

more options

@cor-el. Thanks but didn't help. Tried both ways. Problem persists even when I press F7. When dialogue box opens cursor shoots to the top of the screen no matter what setting I choose..

more options

Does it still happen in Safe Mode? Did you turn off Use Hardware Acceleration?

Okay lets try this. Firefox > Add-ons > Plugins. Go thru and disable EVERYTHING. Then restart.

more options

Hi FredMcD. Hardware Acceleration is off. When I start FF in Safe Mode the dialogue box that first appears asking to start in safe mode - the mouse pointer snaps to the correct dialogue choice. Unfortunately in Safe Mode, it is hard to generate a pop up dialogue box to test further.

Did you mean disable Plugins or Extensions?

Of interest, when I first start FF and then immediately X out, the cursor sometimes snaps to the correct dialogue choice. If I cancel then try it again, the cursor reverts back to snapping to the top of the screen.

more options

Firefox > Add-ons > Plugins. Go thru and disable EVERYTHING by selecting Never Activate using the button on the far right. Then restart.

more options

Hi FredMcD.

Firefox > Add-ons > Plugins. Go thru and disable EVERYTHING by selecting Never Activate using the button on the far right. Then restart.

Did as requested. No change.

Thanks.

more options

Okay, we have just about exhausted everything to do with Firefox. Let's try this. Windows > Start > search bar > msconfig. Select Startup. Go thru the list and, using notepad, write down anything that you don't know. If you want, uncheck those entries. Once you are done select OK if you made changes (the computer will reboot) or Cancel. Then post the list here.

Diperbarui oleh FredMcD pada

more options

Hi FredMcD. Problem found! I check my msconfig on a regular basis to make sure nothing sneaks in. Image of mine below. While I have been using KeyScrambler (KS) for a few years I do recall a problem awhile back with it in another app. So I exited KS in the task bar and the cursor function in FF was as it should be - snapping to the default choice box. Restarted KS and the problem came back.

I will notify QFX Software, who produce KS, of the problem. Thanks for your persistence and help.

more options

Solusi Terpilih

Great News! Good going. For the time being you may want to disable KeyScrambler. You can always turn it on when you need it.