Pomoc přepytać

Hladajće so wobšudstwa pomocy. Njenamołwimy was ženje, telefonowe čisło zawołać, SMS pósłać abo wosobinske informacije přeradźić. Prošu zdźělće podhladnu aktiwitu z pomocu nastajenja „Znjewužiwanje zdźělić“.

Learn More

can't import bookmarks from safari

  • 14 wotmołwy
  • 4 maja tutón problem
  • 50 napohladow
  • Poslednja wotmołwa wot jchinggis

more options

Trying to bring bookmarks from Safari to Firefox, I've carefully followed the instructions provided by folks in this forum with no success.

Using "Import data from another browser" I get "From Safari" folders but they turn up empty; see screenshot. Using "Import bookmarks from HTML" and selecting the bookmark file I exported from Safari, I get an "Export Complete" message but nothing shows up in Firefox. Not even empty folders.

I've tried repeatedly. Quit browsers, rebooted, opened browsers, nothing works.

(sorry if this is a duplicate question; I put it in the wrong place earlier)


Připowěsnjene fota wobrazowki

Wšě wotmołwy (14)

more options

Open Safari.

These instructions are for Firefox. Other browsers should also be able to do this.

Open the Bookmarks Manager; Press the Alt or F10 key to bring up the toolbar, and select Bookmarks. Hot key is <Control> (Mac=<Command>) <Shift> B.

Once the window is open, at the top of the page, press the button labeled Import and Backup. Select Export Bookmarks To HTML, and follow the prompts and save it to a HTML file. Copy the file to another computer/profile. Repeat the instructions above, BUT select Import Bookmarks From HTML.



Mozilla search: Import {web link}

more options

Sometimes importing a bookmarks HTML backup from Safari fails because the file contains FOLDED attributes on H3 tags.

You can open the HTML file in TextEdit and remove all FOLDED attributes in the H3 tags (leave the H3 tags): <H3 FOLDED> should be <H3>. Example:

<DT><H3 FOLDED>Bookmarks Bar</H3> -> <DT><H3>Bookmarks Bar</H3>

Wot cor-el změnjeny

more options


Alas. Every H3 in my html file contained FOLDED. I edited as you suggested, but still nothing comes in when I choose "Import bookmarks from html" and select the edited file. That file opens correctly in any browser; it just won't be imported.

BTW, I've tried all this with Chrome (importing from Chrome to Firefox) with the same negative results.

Tks, JS

more options


I'm confused by your instructions. Exporting bookmarks from Safari is easy, and that's what I've done. But why would I copy the exported html file to another computer?

I don't need to backup or restore my bookmarks; I'm just trying to import Safari bookmarks to Firefox.

FWIW, Chrome easily imports the html file generated by Safari.


more options

Did you make sure that the file is a plain text file and doesn't have RTF formatting code ?

Can you open the HTML file in a Firefox tab for inspection and check the page source ?

more options

Just to confirm, can you successfully add your own bookmarks in Firefox, for example, using Command+d ? If you can't add bookmarks, there may be database damage causing both problems.

more options

cor-el and jscher,

Yes, it's plain text, and yes, it opens in Firefox.

Some progress, though. I trashed everything Firefox related, and started over with a fresh install. The fresh version appeared to import the html bookmarks file. They all showed up but some work and some don't.

Also, I can't add bookmarks (Command+d), can't drag an url from the address bar to the toolbar, and can't move bookmarks from one folder to another in the bookmarks library.

Finally, I opened an old version of Firefox (46.0.1) from an external drive. It imported as expected, and everything works as expected. It even imports using the "Import data from another browser" command.

Version 46 works, but 73 doesn't. Weird?

more options

xovev45438 said

Call On Toll Free 1-888-

There is no official phone support for Firefox, so if you choose a private vendor, choose very carefully.

more options

"choose very carefully"

As in, don't call that number! Clearly, a little phish.

more options

Apologies for putting this here. I don't know were else.

With regret, I'm giving up. I wanted to use Firefox because Safari no longer supports my password manager (Dashlane) and I like many aspects of Firefox.

But every time I open FF, I have to delete the places.sqlite files and start over. It works for a while, then something fails. Mainly problems with bookmarks, but also with sites that won't load, buttons that don't respond, history that doesn't record, and other irregularities.

I've deleted FF, re-installed from fresh download, done various other things I've read about in these (very friendly) support forums, and thanks for that. But I can't keep trying to get FF to function; many wasted hours.

Chrome, I hate to say it, always works. Drat.

I suppose I should check back occasionally to see if things improve?


more options

The places.sqlite database shouldn't get corrupted that often as you experience.

Do you possibly have security software that could be causing this corruption to happen ?

You do remove possible places.sqlite-shm and places.sqlite-wal SQLite temp files as well ?

Do you have places.sqlite.corrupt files in the profile folder ?

more options

Thanks cor-el, I really would like this to work.

I'm not running security software.

I remove places.sqlite. The others aren't in the profile folder, although places.sqlite-wal does show up when FF is active. Disappears when I quit FF.

I don't have places.sqlite.corrupt files.

Today, I'm answering you through Chrome because the log-in button for Mozilla support in FF doesn't work (https://support.mozilla.org/en-US/users/auth). It seems to click but goes nowhere.

One of my go-to sites, jacksonhole.com, refused to load. The address bar showed a padlock with a red slash through it. After restarting FF a time or two, it's back to working, without the red slash.

Also, I can't bookmark several open tabs, either with the pull-down or command-D. For example: https://www.arcgis.com/apps/opsdashboard/index.html#/bda7594740fd40299423467b48e9ecf6

Another site seemed to bookmark OK, but then is invisible in the folder where I put it. However, the Bookmarks pull-down offers to Edit This Bookmark and shows it to be in the folder as expected. But if so, it's invisible; the folder shows as empty.

Finally, I succeed in adding a different bookmark to that folder. It shows up. It works. But if I quit FF and reopen it, the folder again shows empty, and the pull-down again offers to edit it.

Sorry to throw all this at you, but this is the too-common experience of using FF for me.


more options

Could be that your current profile is broken somehow.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks again, but the problem is too deep for me to solve.

I made a new, clean profile and used it over the weekend. Didn't transfer anything from the old profiles. Didn't try importing bookmarks. Instead, I added some of my important bookmarks by visiting sites and using Command-D in FF.

Things seemed to be working fine, so I decided there must be something corrupt in the imported bookmarks in my old profiles, and I should just continue without trying to transfer them.

Then this morning, I noticed FF was taking a huge energy load, fan running nonstop and so forth although I had only 5 or 6 tabs open, so I restarted FF, and BINGO, all my bookmarks are gone.

Warning banner is back.