Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Comments do not load

more options

On a couple of sites (e.g. Petapixel) when I click "Load Comments", nothing happens. I suspect this may be because Firefox security is preventing comments from loading because of site tracking or other security issues. Is this the cause?

On a couple of sites (e.g. Petapixel) when I click "Load Comments", nothing happens. I suspect this may be because Firefox security is preventing comments from loading because of site tracking or other security issues. Is this the cause?

All Replies (4)

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

Helpful?

more options

I had to disable Enhanced Tracking Protection on the page to load the Disqus comment frame. (Click the shield icon at the left end of the address bar, then click the slider switch to disable/reload.)

Later, I checked the Web Console (Ctrl+Shift+K) and when I click the Load Comments button, there is indeed a confirmation that the Disqus script couldn't load/run because of tracking protection (see attached).

So in this case, you need to allow tracking on the site: Enhanced Tracking Protection in Firefox for desktop.

Helpful?

more options

It turns out there is a more surgical but somewhat complicated way to make an exception for Disqus content without allowing other trackers. This was described in the solution to https://support.mozilla.org/questions/1434798. Here's how to apply it to Petapixel.

Initial Step

Look up the specific Disqus host name you want to unblock. This should appear on the very long list of blocked tracking servers. On Petapixel, the key host name is petapixel.disqus.com as you can see here:

Create or Edit the exception list

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste urlclassifier.trackingSkipURLs and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a + button:

(3) If you get that bar, select String and click the + button. Firefox should place the cursor in an editing box.

(4) Edit the preference value to include disqus.com and the specific host name(s), separated by commas. In the case of Petapixel, that is:

disqus.com,petapixel.disqus.com

Then press Enter or click the blue check mark button to save the change. Here's a screen shot of the process:

After that, reload the page which is having problems with comments, and Firefox should run the Disqus script just as though you were using a lower level of Tracking Protection.

Success?

Helpful?

more options

For anyone using this approach, you may now need to add this to your list:

c.disquscdn.com

Helpful?

प्रश्न पूछें

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.