Nuna amsoshi da aka yiwa shaida: Nuna duk tambayoyi

how to fix "suggest-unexpected" incompatible database version error?

I'm using Ubuntu 24.04 and just reinstalled for unrelated reasons. I'm trying to copy my Firefox profile over from my backup to the new installation. I used the Ubuntu S… (daɗa karatu)

I'm using Ubuntu 24.04 and just reinstalled for unrelated reasons. I'm trying to copy my Firefox profile over from my backup to the new installation.

I used the Ubuntu Snap store to install Firefox and put my old profile in -- this is the one that I was using on my previous Ubuntu 24.04 installation just a couple days ago -- and everything seems fine, but I do see this error message:

[ERROR error_support::handling] suggest-unexpected: Error opening database: Incompatible database version: 18

It gets printed when I type things in the search bar, so it seems related to some sqlite database related to history and autocompletion.

Is there a way to fix this? I'm fine with just deleting it, so long as the other parts of the profile remain.

(This is a strange error, since after all I was using the exact same setup -- Firefox on Ubuntu 24.04, installed via snap -- just a couple days ago, and it was, as far as I know, up-to-date.)

Asked by Dan Drake 1 makon da ya gabata

Last reply by Dan Drake 6 kwanakin da su ka gabata