Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

How can Firefox be setting the TZ environment variable?

  • 3 Mbohovái
  • 2 oguereko ko apañuãi
  • 1 Hecha
  • Mbohovái ipaháva DAVe3283

more options

Time in websites is off compared to my local clock. If I run Date() in the console, I get "Tue Oct 24 2017 04:33:59 GMT+0000 (UTC)". This is incorrect, because my timezone is UTC-0700.

Using Process Explorer (or similar), I note the TZ environment variable is set to "UTC". This explains it! Right? No, because NO OTHER PROGRAM has that variable set. And it appears Firefox doesn't inherit that variable from anything. On powershell, running "(Get-Process firefox).StartInfo.EnvironmentVariables" shows that TZ is not set when Firefox is launched. So it acquired the variable after launch, which implies it set the variable itself.

How can Firefox be setting the TZ environment variable, and how do I prevent it? Ideally, I don't want to rebuild my profile.

Time in websites is off compared to my local clock. If I run Date() in the console, I get "Tue Oct 24 2017 04:33:59 GMT+0000 (UTC)". This is incorrect, because my timezone is UTC-0700. Using Process Explorer (or similar), I note the TZ environment variable is set to "UTC". This explains it! Right? No, because NO OTHER PROGRAM has that variable set. And it appears Firefox doesn't inherit that variable from anything. On powershell, running "(Get-Process firefox).StartInfo.EnvironmentVariables" shows that TZ is not set when Firefox is launched. So it acquired the variable after launch, which implies it set the variable itself. How can Firefox be setting the TZ environment variable, and how do I prevent it? Ideally, I don't want to rebuild my profile.

Ñemoĩporã poravopyre

You can also check this pref on the about:config page.

  • privacy.resistFingerprinting
Emoñe’ẽ ko mbohavái ejeregua reheve 👍 1

Opaite Mbohovái (3)

more options
more options

Ñemoĩporã poravopyre

You can also check this pref on the about:config page.

  • privacy.resistFingerprinting
more options

cor-el said

You can also check this pref on the about:config page.
  • privacy.resistFingerprinting

Hmm, I might have set this thinking back on it. I will check when I get home from work.

I also looked at the source code file you linked, but that doesn't appear to deal with the environment variable. I think you are on to something with the resistFingerprinting setting, thanks!