Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

HTML5 Playback causes choppy scrolling

  • 8 Mbohovái
  • 1 oguereko ko apañuái
  • 29 Hecha
  • Mbohovái ipaháva user686414

more options

HTML5 videos cause choppy scrolling - most notable when playing a YouTube video in a tab, and browsing in another one. If the video is paused there is no problem. Also, which is a bit weird, if I click on a YouTube video, and before it manages to fully load, switch to another tab, the scrolling is fine. If I switch back to the YouTube tab, it immediately gets choppy in all of Firefox. Similar problem with 9GAG gifs for example, so it's not just with YouTube.

All drivers are up to date. Windows 7 Professional N, hardware acceleration on or off makes no difference. Any ideas?

HTML5 videos cause choppy scrolling - most notable when playing a YouTube video in a tab, and browsing in another one. If the video is paused there is no problem. Also, which is a bit weird, if I click on a YouTube video, and before it manages to fully load, switch to another tab, the scrolling is fine. If I switch back to the YouTube tab, it immediately gets choppy in all of Firefox. Similar problem with 9GAG gifs for example, so it's not just with YouTube. All drivers are up to date. Windows 7 Professional N, hardware acceleration on or off makes no difference. Any ideas?

Opaite Mbohovái (8)

more options

hello alore, have you installed the "WindowsMedia Feature Pack für Windows 7 N" yet? http://www.microsoft.com/en-us/download/details.aspx?id=19289

more options

Hello, just installed it, no change.

more options

could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum?

more options

Also good to mention that if I switch to YouTube flash, the problem is gone, however Flash gives such a sh** performance, that I would rather tolerate a bit of choppy scroll than using the flash player :)

{

 "application": {
   "name": "Firefox",
   "version": "35.0.1",
   "userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0",
   "supportURL": "https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-GB/",
   "numTotalWindows": 1,
   "numRemoteWindows": 0
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "accessibility.typeaheadfind.flashBar": 0,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.capacity": 358400,
   "browser.cache.frecency_experiment": 4,
   "browser.places.smartBookmarksVersion": 7,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20150122214805",
   "browser.startup.homepage_override.mstone": "35.0.1",
   "browser.startup.homepage": "https://www.google.co.uk/",
   "browser.startup.homepage_override.buildID": "20150122214805",
   "browser.tabs.remote": true,
   "browser.tabs.remote.autostart": true,
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "35.0.1",
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "media.gmp-gmpopenh264.lastUpdate": 1419280476,
   "media.gmp-gmpopenh264.version": "1.1",
   "media.gmp-manager.lastCheck": 1422375690,
   "network.cookie.prefsMigrated": true,
   "places.database.lastMaintenance": 1422361802,
   "places.history.expiration.transient_current_max_pages": 104858,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "plugin.state.npnv3dv": 0,
   "plugin.state.npnv3dvstreaming": 0,
   "plugin.importedState": true,
   "print.printer_Microsoft_XPS_Document_Writer.print_in_color": true,
   "print.printer_Microsoft_XPS_Document_Writer.print_orientation": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_footerleft": "&PT",
   "print.printer_Microsoft_XPS_Document_Writer.print_scaling": "  1.00",
   "print.printer_Microsoft_XPS_Document_Writer.print_margin_top": "0.5",
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_width": "  8.50",
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_resolution_name": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_page_delay": 50,
   "print.printer_Microsoft_XPS_Document_Writer.print_edge_left": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_edge_top": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_edge_right": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_name": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_command": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_reversed": false,
   "print.printer_Microsoft_XPS_Document_Writer.print_resolution": 1515870810,
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_height": " 11.00",
   "print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom": "0.5",
   "print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_headercenter": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_bgimages": false,
   "print.printer_Microsoft_XPS_Document_Writer.print_headerleft": "&T",
   "print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts": false,
   "print.printer_Microsoft_XPS_Document_Writer.print_headerright": "&U",
   "print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit": true,
   "print.printer_Microsoft_XPS_Document_Writer.print_evenpages": true,
   "print.printer_Microsoft_XPS_Document_Writer.print_oddpages": true,
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_paper_data": 1,
   "print.printer_Microsoft_XPS_Document_Writer.print_duplex": 1515870810,
   "print.printer_Microsoft_XPS_Document_Writer.print_margin_left": "0.5",
   "print.printer_Microsoft_XPS_Document_Writer.print_margin_right": "0.5",
   "print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_plex_name": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_footerright": "&D",
   "print.printer_Microsoft_XPS_Document_Writer.print_colorspace": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_to_file": false,
   "print.printer_Microsoft_XPS_Document_Writer.print_footercenter": "",
   "print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left": 0,
   "print.printer_Microsoft_XPS_Document_Writer.print_bgcolor": false,
   "print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right": 0,
   "privacy.cpd.siteSettings": true,
   "privacy.sanitize.timeSpan": 0,
   "privacy.cpd.offlineApps": true,
   "privacy.sanitize.migrateFx3Prefs": true,
   "storage.vacuum.last.index": 1,
   "storage.vacuum.last.places.sqlite": 1421936523
 },
 "lockedPreferences": {},
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 11",
   "windowLayerManagerRemote": true,
   "adapterDescription": "NVIDIA GeForce GT 650M  ",
   "adapterVendorID": "0x10de",
   "adapterDeviceID": "0x0fd1",
   "adapterSubsysID": "21031043",
   "adapterRAM": "2048",
   "adapterDrivers": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
   "driverVersion": "9.18.13.4725",
   "driverDate": "1-9-2015",
   "adapterDescription2": "Intel(R) HD Graphics 4000",
   "adapterVendorID2": "0x8086",
   "adapterDeviceID2": "0x0166",
   "adapterSubsysID2": "0000000c",
   "adapterRAM2": "Unknown",
   "adapterDrivers2": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32",
   "driverVersion2": "10.18.10.4061",
   "driverDate2": "12-18-2014",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "6.2.9200.16492",
   "webglRenderer": "Google Inc. -- ANGLE (NVIDIA GeForce GT 650M   Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "direct2d",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.7",
     "version": "4.10.7"
   },
   "NSS": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.17.2",
     "version": "3.17.2"
   },
   "NSSSSL": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": [
   {
     "name": "Adblock Plus",
     "version": "2.6.7",
     "isActive": true,
     "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
   },
   {
     "name": "Classic Theme Restorer",
     "version": "1.2.9.1",
     "isActive": true,
     "id": "ClassicThemeRestorer@ArisT2Noia4dev"
   },
   {
     "name": "Flagfox",
     "version": "5.0.11",
     "isActive": true,
     "id": "{1018e4d6-728f-4b20-ad56-37578a4de76b}"
   },
   {
     "name": "Greasemonkey",
     "version": "2.3",
     "isActive": true,
     "id": "{e4a8a97b-f2ed-450b-b12d-ee082ba24781}"
   },
   {
     "name": "Location Bar Enhancer",
     "version": "5.2",
     "isActive": true,
     "id": "UIEnhancer@girishsharma"
   },
   {
     "name": "NextVid Stopper for YouTube",
     "version": "0.8",
     "isActive": true,
     "id": "jid1-8tHTvv1Wsu98MQ@jetpack"
   }
 ],
 "experiments": []

}

more options

when you happen the windows task manager (ctrl+shift+esc) while the slowness is going on is there a particular hight CPU usage in the processes tab for firefox.exe (or any other program there)?

one other thing to try: is the same behaviour happening when you launch firefox in safemode for testing purposes once?: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems if so i think the next step might be to file a bug report about that...

more options

There is no increase in CPU usage (with or without HTML5 playback). firefox.exe process stays between 1 and 6% max when scrolling.

Tried restarting in Safe Mode, the problem is still there.

more options

thank you. as a last test i'd recommend to try if this problem is reproducible with a fresh profile: Profile Manager - Create, remove or switch Firefox profiles

if this fails as well then i'm pretty much out of ideas unfortunately. in this case i'd encourage you to file a bug report about this issue on https://bugzilla.mozilla.org

more options

I deleted the profile and started fresh, however the problem is still present, so it's not an issue with the settings or addons.

Interestingly, I tried the latest Nightly build portable x64, and everything was fine there. I guess the developers are aware of the issue and will problably fix it in the next versions :)