Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Gmail look so bad in Firefox 18? It looks like bad anti-aliased fonts

  • 16 replies
  • 40 have this problem
  • 5 views
  • Last reply by JoeSalazar

more options

After upgrading to FF 18, my Gmail started to look blurry. I'm using Windows 7 and I have Cleartype on and I've tuned it well.

All other sites look alright. It's only FF 18 that started to look weird.

All Replies (16)

more options

Do you have smoothing turned on as well?

Have you reset Firefox? Refresh Firefox - reset add-ons and settings

more options

It was false. I set it to true and restarted. Still the same. It's only Gmail and Google Drive that looks weird.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

more options

Screenshots of my Gmail and another website attached for comparison.

Notice that Gmail text looks blurred - as if Cleartype is not working well?

Both were taken while viewing the sites using FF 18.

Just checked. hardware acceleration is on.

Modified by AshwinJay

more options

Does disabling hardware acceleration and closing and restarting Firefox has any effect?

more options

No diff after that.

more options

Try:

Does it help if you select another font to display the text?

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Modified by cor-el

more options

Thanks, but the tuner didn't seem to make any diff.

more options

Try to reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Nope didn't work but I really appreciate your determined efforts to help :)

more options

Something is definitely broken in FF 18. Fonts are blurry. I wonder why so few people complain about this. Seems like most people don't care. I can replicate this on any of my 6 Windows machines. For now the only solution is to revert back to FF 17. If it won't be fixed, I'll have to abandon my favorite browser and switch to Chrome, and I do not want this.

more options

Damned, I have spent the whole day thinking it was due to a hardware problem on my MacBook Pro ( because I replaced the logicboard yesterday), but it apparently wasn't !

I have an awfull aliasing on the google products ( gmail / youtube...) and some other websites but not all. It works well with video sites like dailymotion / vimeo...

What I found is: When I reflesh a youtube page without seeing the video windows, the fonts become clean, if I open a new video page or if I do the refresh at the bottom of the page where we can see the video, the fonts become ugly...

I tried to clean the cache / cleaning my font library but nothing solve the problem..

I tried the old Firefox 17 and the problem disapears...

My computer is an old MacBook Pro from 2007 (A1211 2,33Ghz with 256Mo GPU, 3Go ram) with SnowLeopard and Firefox 18.

I hope they will solve the problem in the next release...

See attached a test with Firefox / Safari / Chrome on mac...(It's easier to see the difference on the imagesharck hosted file bellow, but in reality than worst)

http://img59.imageshack.us/img59/7404/capturedecran20130129a1.jpg

Modified by Antoine

more options

Good news, I tried the Firefox 19 release on the Beta Channel and the problem is fixed !

more options

I have Firefox 19.0.2 installed and this problem exists on Google News which I use as a home page. I never noticed it until I installed this new version a few days ago. At first the fonts look good, but as I scroll down the page the fonts start blurring. Oddly, I found that if I select/highlight the text, the reverse color effect fixes the fonts and when I deselect the text if looks fine again.

Until I start scrolling through the page, and once again the text starts blurring. I once had a prescription for klonopin that caused a similar effect while working at my computer, but I am not tripping on anything when this text blurs. I have never seen this blurred text problem on anything but a google site.

In short, this problem is not fixed in v19.0.2 and in fact I never had the problem until I upgraded. I have used Firefox as my default browser for years but the last three or four versions have tried my patience with stupid design decisions and now this may make me leave it all together.

Anyone know any new fixes for this problem?

Modified by ricktay

more options

One other thought on this. My Canon printer died and I bought a new Epson and installed the Epson printer the same week I started noticing the blurred fonts in Firefox v19.0.2.

Is there any chance the Epson printer installed any type of fonts or font rendering software that may have caused this problem?

more options

I found this and it worked for me: 1. type about:config in address bar 2. search for "gfx.content.azure.enabled" and set it to false 3. restart your browser