Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Chinese characters are not displayed in the Firefox bookmarks

  • 2 replies
  • 3 have this problem
  • Last reply by apa535

more options

Chinese characters are not displayed in the Firefox bookmarks. The name looks like e.g. "??????? ????"

Chinese character of the site name is displayed ok in the head of the browser window and there is no problem reading chinese web content. I use Firefox Portable 11 /English from in Windows XP.

I googled and got some tips:

1) Set your browser to recognise Chinese language internet sites. Windows users: Under "Tools - Options" on your browser's menu-bar add Chinese to the languages list. - I did this.

2) Set your browser's "Character Set" or "Encoding" to UTF-8 (sometimes also called Universal Alphabet or Unicode). Encoding settings can be changed under the "View" option in your browser's menu-bar. - It was already set to UTF-8.

3) Windows users: If Chinese text still does not display correctly, East Asian language support may need to be enabled. - This has been done when I installed Windows.

I still don't get any Chinese fonts in the bookmark names. I can edit the bookmark name with chinese characters and then save the bookmark, it works fine. But why does not Firefox recognize the characters when saving bookmarks? Help is appreciated.

Modified by apa535

All Replies (2)

more options

The .com domain is not white listed in Firefox and should be displayed as puny code and also saved as such.

Did you make any changes to network.IDN.whitelist.* prefs to force domain to display as plain text?

Such domains may need to be coded via encodeURI().

Can you give a real example?

Modified by cor-el

more options

No I didn't change anything deep beneath the hood. My problem didn't apply to the URL, but to the name of the link or bookmark header or whatever you would like to call it. (When hitting Ctrl + D there is a Name field). I only got ???????? instead of chinese characters in the name. Also for e.g. ...but maybe all China is not in the whitelist either. ;-) But anyway, this was not the real problem for me.

Apparently I was wrong as after a reboot of the computer it worked. The solution seemed to be to add Chinese to the language list. I don't know why it was not enough to restart Firefox?

Now I only have problems to show chinese characters in the name field of my external link manager... But I guess it is not an issue for Mozilla.