Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Get the following when booting Firefox 4.0 with Snow Leopard 10.6.7: [JavaScript Application} can't creatre mcafee plug-in objects: type error: components.classes {cid} is undefined.

  • 4 replies
  • 11 have this problem
  • Last reply by wonder52

more options

On both MacBooks running latest Mac OS when starting Firefox. Did not have this problem with previous versions.

All Replies (4)

more options

That indicates that the extension is not compatible with Firefox 4. You can check with McAfee to see if they have an updated version for the Mac that works on Firefox 4.

more options

Thank you for the advice. However, I do not have McAfee installed in either of my computers. The statement occurs every time I open a file from the web (such as a bank statement) that usually opens in Adobe (have latest version). It also occurs when I first open Firefox. Very annoying. I will switch to Safari if this is not resolved.

more options

Ignore my first reply I just replied to the wrong post :)

As for your problem, that error indicates that you are using an add-on that is not compatible with Firefox 4. For details of how to troubleshoot this to find out what one is causing the problem see https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

more options

Thank you! Really! Thank you! I disabled Extensions and it solved the problem. I'll ad them one at a time to isolate the problem and get an update or scrap it. Thank yo again!