Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

cannot resize address bar in FF 29.0

  • 4 fhreagra
  • 16 leis an bhfadhb seo
  • 648 views
  • Freagra is déanaí ó cor-el

more options

Tried the FF 29 upgrade from FF 27.x, can't seem to figure out how to customize the toolbar now. Actually, what I am not liking is the address bar uses the full width of the screen. On FF 27, I used to open the customize toolbar box, then would add a bunch of SPACEs after the toolbar, essentially shrinking it to the left until it was to my liking. The new customize screen does not have this option and the only thing it seems I can do is rearrange the address and google search, nothing else seems of any use... very confusing.

All Replies (4)

more options

For this purpose have you tried the Classic Theme Restorer? https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/

Athraithe ag zoli62 ar

more options

You can use code in userChrome.css to set a maximum width for the location bar and for the search bar.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-container {max-width: 400px !important}
#search-container {max-width: 200px !important}


The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Thanks for the responses. Looks like FF 29.0.1 added the spaces option again. Classic Theme restorer has an option stating it can remove "Tab Toolbar background Fog (Windows Aeroglass)" and it does not seem to do so. Is there a way to manually remove this effect? Look at my attached picture to see what my gripe is-it cuts into the custom background art.

more options

You can try to ask advice in the Classic Theme Restorer forum thread.