Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Rather than go to the home page I have specified in the General tab of Options in the Tools menu, Firefox keeps going to a truncated version of this url.

  • 5 fhreagra
  • 3 leis an bhfadhb seo
  • 7 views
  • Freagra is déanaí ó cor-el

more options

I have used the following URL as my firefox home page for quite some time:

    https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+|+NIH.gov&btnG=Search

Several months ago, malware of some sort replaced this url with one of their own. I got rid of the malware and put back my original home page, but I'm continuing have a problem: Every time firefox goes to my home page, rather than using the whole url that I've specified, firefox truncates this url to just the first 87 characters, and goes to this truncated url instead:

    https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+

Not only is this not the url that I have specified in the General tab under Options in the Tools menu, I always get an error message in an additional tab whenever Firefox goes to this truncated version of my home page. Can anyone tell me what I need to do to get firefox to use the entire url I have specified as my home page in the General Tab under Options?


I do not know if this is relevant or not, but I noticed that prefs.js includes two other user prefs related to the home page in addition to the one that identifies the url I chose:

user_pref("browser.startup.homepage", "https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+|+NIH.gov&btnG=Search");

user_pref("browser.startup.homepage_override.buildID", "20130617145905");

user_pref("browser.startup.homepage_override.mstone", "22.0");

I have used the following URL as my firefox home page for quite some time: https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+|+NIH.gov&btnG=Search Several months ago, malware of some sort replaced this url with one of their own. I got rid of the malware and put back my original home page, but I'm continuing have a problem: Every time firefox goes to my home page, rather than using the whole url that I've specified, firefox truncates this url to just the first 87 characters, and goes to this truncated url instead: https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+ Not only is this not the url that I have specified in the General tab under Options in the Tools menu, I always get an error message in an additional tab whenever Firefox goes to this truncated version of my home page. Can anyone tell me what I need to do to get firefox to use the entire url I have specified as my home page in the General Tab under Options? I do not know if this is relevant or not, but I noticed that prefs.js includes two other user prefs related to the home page in addition to the one that identifies the url I chose: user_pref("browser.startup.homepage", "https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+|+NIH.gov&btnG=Search"); user_pref("browser.startup.homepage_override.buildID", "20130617145905"); user_pref("browser.startup.homepage_override.mstone", "22.0");

All Replies (5)

more options

I need to make a correction:

I haven't had internet access for almost six weeks, and it appears that I misremembered what happens when I click on the Home button, or when firefox is launched. What ought to happen, of course, is for the browser window in focus to have the url I have specified in the General tab under Options in the Tools menu as my home page:

    https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+|+NIH.gov&btnG=Search

What happens instead is that this browser window has a primary tab with a truncated URL:

    https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+CDC.gov+

and which has a second tab whose URL is largely made up of the remainder [ i.e., "|+NIH.gov&btnG=Search" ] of the home page url that I have specified:

     http://www.+nih.gov&btng=search/

Naturally, since the address of the second tab concerns a server which does not exist, the result is that the content of the second tab is not a web page but the following error message:

Firefox can't find the server at www.+nih.gov&btng=search.

Check the address for typing errors such as

   ww.example.com instead of
   www.example.com

If you are unable to load any pages, check your computer's network

   connection.

If your computer or network is protected by a firewall or proxy, make sure

   that Firefox is permitted to access the Web.
more options

The vertical bar is a special character in the home page setting: it separates multiple URLs so you can open multiple tabs as your home page. That's why your first address ends at the | and Firefox tries the next part as a different address.

I think you will need to use OR instead of | in your query (note that it needs to be in capital letters). If you want to limit the results to those domains, you could use this:

https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+(site:cdc.gov+OR+site:nih.gov)

more options

And if you trust Google's ability to deduce the correct dates for pages, the latest month of results:

https://www.google.com/search?num=100&safe=off&hl=en&complete=0&q=Rochester-NY+(site:cdc.gov+OR+site:nih.gov)&tbas=0&tbs=qdr:m

more options

Thanks very much--this solved the problem entirely. I should have thought of the possibility that the "pipe" had acquired a new function in firefox; I've been using this home page in Firefox and Explorer for so many years it never crossed my mind--especially since my home page had just been hijacked by malware. In any event, thank you!

more options

You need to escape the pipe character as %7c if you want to include it in the URL

Athraithe ag cor-el ar