Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox won't allow some sites to open lightboxes or login popups.

  • 3 fhreagra
  • 8 leis an bhfadhb seo
  • 235 views
  • Freagra is déanaí ó cor-el

more options

OS: Windows 8.1 (64 bit) x64 AMD E-300 Processor

Firefox 25.0.1

I just got a new laptop and have discovered this issue: When I try to click links on some sites to open a lightbox or popup (usually for login boxes or photo slideshows) nothing happens. Absolutely nothing, no error message, no loading screen, no "busy" or "working" animations, no redirect. I've tried the same pages in the latest versions of Internet Explorer and Chrome and they work correctly. These sites work on my old laptop with the same version of Firefox and Vista SP2 32 bit and my work computer with Windows 7 64 bit.

I've tried disabling Add-Ons one by one and as a group, didn't make a difference. I've cleared the cache and cookies. I've turned by firewall and antivirus/antispyware/antimalware programs on and off.

Sites with a known issue: "View larger images" on Zillow.com, Login on Moviepilot.com, Login on doubletakedeals.com. I can't remember any others at the moment.

Athraithe ag DarianaNight ar

Réiteach roghnaithe

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

You can delete the permissions.sqlite file to reset all permissions.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Read this answer in context 👍 0

All Replies (3)

more options

Firefox Options > Content. Check to see if the pop-up blocker is turned on. (It should be on, BTW) On the right side is a button called Exemptions. Click it. Now add any sites that you want to display their pop-ups. Do the same thing with Add-Block-Plus.

Athraithe ag FredMcD ar

more options

That was one of the first things I did. No effect. I even turned off the popup blocker completely, that didn't make a difference either.

more options

Réiteach Roghnaithe

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

You can delete the permissions.sqlite file to reset all permissions.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.