X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Saved username and passwords no longer works on Yahoo Mail

Postáilte

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin.

I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers.

This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin. I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers. This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Réiteach roghnaithe

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

Read this answer in context 1

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • NPWLPG

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

Tuilleadh Eolais

sherylsr 0 réiteach 15 freagra

Hey GOOD for you!! It DOES get to be a challenge so congrats!!

Hey GOOD for you!! It DOES get to be a challenge so congrats!!
Mari123 0 réiteach 3 freagra

Hi Jude23. Thanks for the details. I have tried your suggestion but nothing changes for me. My SSL box was already 'unchecked'. I have checked, saved, unchecked, saved etc restarted etc...but no change. Anyway, now planning to move my email accounts to another provider given Yahoo's inability to resolve this.

Hi Jude23. Thanks for the details. I have tried your suggestion but nothing changes for me. My SSL box was already 'unchecked'. I have checked, saved, unchecked, saved etc restarted etc...but no change. Anyway, now planning to move my email accounts to another provider given Yahoo's inability to resolve this.
jude23 0 réiteach 24 freagra

Hi Mari123, Sorry it didn't work for you. Notably, different solutions work for different folks. When sherylsr reported success with a Firefox reinstall and the IE(Q) fix, I thought "why didn't work for me?!" Point being, though, that this can't be so easy for Yahoo to resolve. But I empathize--I came very close to ditching my Yahoo account. Best of luck!

Hi Mari123, Sorry it didn't work for you. Notably, different solutions work for different folks. When sherylsr reported success with a Firefox reinstall and the IE(Q) fix, I thought "why didn't work for me?!" Point being, though, that this can't be so easy for Yahoo to resolve. But I empathize--I came very close to ditching my Yahoo account. Best of luck!
CharlieC914 0 réiteach 1 freagra

I tried selectively deleting cookies and passwords. I didn't feel I should have to delete everything for just Yahoo Mail when everything else worked.

Turns out it's that for me, it was just the Yahoo Mail bookmark. I tried going to the Yahoo homepage and noticed I was still logged in. I clicked on the mail link and I was in.

So I copied the NEW link and bookmarked it. Hopefully it will work for others too. Charlie

I tried selectively deleting cookies and passwords. I didn't feel I should have to delete everything for just Yahoo Mail when everything else worked. Turns out it's that for me, it was just the Yahoo Mail bookmark. I tried going to the Yahoo homepage and noticed I was still logged in. I clicked on the mail link and I was in. So I copied the NEW link and bookmarked it. Hopefully it will work for others too. Charlie
iconic944ss 0 réiteach 3 freagra

Never had this problem before but now I have after upgrading to V24. Yahoo is showing the correct Secure sign-in seal for my Yahoo account but on clicking on the Username field I DONT get the email account autofill in that I used to.

I have a partial workaround already.

Click into the password field THEN click back into the username field and THEN the account name/Email fills in (for me anyways) - passwords are likewise remembered and filled in next...

Thanks - Frank

Never had this problem before but now I have after upgrading to V24. Yahoo is showing the correct Secure sign-in seal for my Yahoo account but on clicking on the Username field I DONT get the email account autofill in that I used to. I have a partial workaround already. Click into the password field THEN click back into the username field and THEN the account name/Email fills in (for me anyways) - passwords are likewise remembered and filled in next... Thanks - Frank
Velvetpaws 0 réiteach 2 freagra

Hey that is wonderful! I did read every post here, all the way to yours, which is 4 or 5 pages! Now... if you could hep me by telling me where and how to get to the secure socket layer? After all this reading, my brain is tired, lol! thanks for pointing me in the one and only right direction! Velvetpaws

Hey that is wonderful! I did read every post here, all the way to yours, which is 4 or 5 pages! Now... if you could hep me by telling me where and how to get to the secure socket layer? After all this reading, my brain is tired, lol! thanks for pointing me in the one and only right direction! Velvetpaws
iconic944ss 0 réiteach 3 freagra

You got MUCH further than me Velvetpaws, I cant help you with SSL but this might:

https://support.mozilla.org/en-US/kb/enable-ssl-fix-cannot-connect-securely-error

You got MUCH further than me Velvetpaws, I cant help you with SSL but this might: https://support.mozilla.org/en-US/kb/enable-ssl-fix-cannot-connect-securely-error
SF BayWolf 0 réiteach 3 freagra

I too am having this problem. I have done all the steps in this conversation FF still reverts back to autocomplete OFF when I restart FF. Whats going on? It's obviously something in FF as I have never had this problem before. Yahoo is the only site doing this.

I too am having this problem. I have done all the steps in this conversation FF still reverts back to autocomplete OFF when I restart FF. Whats going on? It's obviously something in FF as I have never had this problem before. Yahoo is the only site doing this.
jscher2000
  • Top 10 Contributor
8793 réiteach 71930 freagra

Hi mtmac57, it's normal for the page to show autocomplete OFF. Unless something has changed, you only need to set that on in order to get Firefox to save (or prompt you to save) the password, not to get it to fill the password. If that is no longer working, someone may need to find a new trick.

Hi mtmac57, it's normal for the page to show autocomplete OFF. Unless something has changed, you only need to set that on in order to get Firefox to save (or prompt you to save) the password, not to get it to fill the password. If that is no longer working, someone may need to find a new trick.
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159013 freagra

Note that Firefox won't auto-fill the name and password if autocomplete="off" is present. You need to click in the name field to open the drop-down list (you may need to click outside that field to temporarily move the focus out of this element).

Note that Firefox won't auto-fill the name and password if autocomplete="off" is present. You need to click in the name field to open the drop-down list (you may need to click outside that field to temporarily move the focus out of this element).
Velvetpaws 0 réiteach 2 freagra

OK one last time... since it looks as if nobody at FF cares about this, and a few other annoying and relatively new items (such as opening TWO pages now, each time one clicks on e.g. "yahoo.com" which is set as my home page.)

Until the last update of FF, it was usual to just click the sign-on window on the yahoo home page (www.yahoo.com), and it would show all my three email names which I use. Now, it won't do that anymore. I have to type them in each time. Same scenario with the stored password. It is still stored, but it won't show up automatically anymore. This is NEW, and very annoying. Of course, one can change it by clicking in the sign-on window, pick "inspect element" and there change those "auto" lines to "on". It won't do much good, however, because it only functions that one time. Next time one opens a fresh yahoo.com window, it is back to no "auto-fill". If the folks at FF could kindly look into that and fix it, that would be awesome. If it is not due to some workings of the FF folks, then the only other source has to be Yahoo folks. Same suggestion: please, fix it! Thanks!

OK one last time... since it looks as if nobody at FF cares about this, and a few other annoying and relatively new items (such as opening TWO pages now, each time one clicks on e.g. "yahoo.com" which is set as my home page.) Until the last update of FF, it was usual to just click the sign-on window on the yahoo home page (www.yahoo.com), and it would show all my three email names which I use. Now, it won't do that anymore. I have to type them in each time. Same scenario with the stored password. It is still stored, but it won't show up automatically anymore. This is NEW, and very annoying. Of course, one can change it by clicking in the sign-on window, pick "inspect element" and there change those "auto" lines to "on". It won't do much good, however, because it only functions that one time. Next time one opens a fresh yahoo.com window, it is back to no "auto-fill". If the folks at FF could kindly look into that and fix it, that would be awesome. If it is not due to some workings of the FF folks, then the only other source has to be Yahoo folks. Same suggestion: please, fix it! Thanks!
cleverwabbit5 0 réiteach 16 freagra

I have been using autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data. I type it in, hit the link and the reload the page and even though I still have to type my id in it saved the password, I wanted the pull down menu to reappear but it disappeared months ago and haven't been able to restore it on yahoo sign in. Anyway after I upgraded to firefox 24 the work around doesn't work anymore. Now I have to type everything in all the time and the bookmarklet doesn't work. What is going on here it is really annoying, has anyone found a solution to this? Thanks

I have been using autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data. I type it in, hit the link and the reload the page and even though I still have to type my id in it saved the password, I wanted the pull down menu to reappear but it disappeared months ago and haven't been able to restore it on yahoo sign in. Anyway after I upgraded to firefox 24 the work around doesn't work anymore. Now I have to type everything in all the time and the bookmarklet doesn't work. What is going on here it is really annoying, has anyone found a solution to this? Thanks
oceanofdiamonds 0 réiteach 4 freagra

I have a problem that is a variation on this theme. Here's exactly what happens, Firefox 24.0, Windows XP SP3. To login to Yahoo, I type the first letter of a username I know is in there to be autocompleted. Nothing happens. I exit the field and RE-ENTER, type the next letter of the username and the autocomplete prompts me with it in a drop down. When I select it, it puts in the full username and password. Happens this way EVERY TIME. Wassup wit dat? :)

I have a problem that is a variation on this theme. Here's exactly what happens, Firefox 24.0, Windows XP SP3. To login to Yahoo, I type the first letter of a username I know is in there to be autocompleted. Nothing happens. I exit the field and RE-ENTER, type the next letter of the username and the autocomplete prompts me with it in a drop down. When I select it, it puts in the full username and password. Happens this way EVERY TIME. Wassup wit dat? :)
jscher2000
  • Top 10 Contributor
8793 réiteach 71930 freagra

Hi Velvetpaws, you wrote:

... opening TWO pages now, each time one clicks on e.g. yahoo.com which is set as my home page.

If this problem only occurs when you click the Home button or launch a new window, you may have gotten a second home tab in your options. You can check that following the steps in this article: How to set the home page.

Hi Velvetpaws, you wrote: <blockquote>... opening TWO pages now, each time one clicks on e.g. yahoo.com which is set as my home page.</blockquote> If this problem only occurs when you click the Home button or launch a new window, you may have gotten a second home tab in your options. You can check that following the steps in this article: [[How to set the home page]].
SF BayWolf 0 réiteach 3 freagra

Ok..with the help of another contributor, I believe I have figured this out. Especially for YMail users with multiple sign ons. Unfortunately this involved multiple steps, but works once done.

As described previously..bring up the Mail log-page. Access the javascript by Right clicking in the the "Yahoo! ID" box. Change the "auto-complete" to "on" in both locations...hitting the enter button after each change. Close the Javascript window via X in the upper right hand corner. Test your log-in.

Now sign out of Yahoo mail and close your browser. When your re-open your browser and bring up Y-mails log-in page, it may seem it will not display you previously save user name. Go outside the ID box and click on the page (no an advertisement..free space..usually just to the right of the box.) Then, go back to the ID box..click in it...then click it again. For me it brought up my saved id.

The downside part of this is, you have to do this procedure with each Yahoo ID individually. Once done, when you click into the ID box, using the click "outside the box" procedure, you should be good to go as all the ID's/passwords should have been save.

Ridiculous?.. I totally agree...but until the problem is located and rectified, this works.

Ok..with the help of another contributor, I believe I have figured this out. Especially for YMail users with multiple sign ons. Unfortunately this involved multiple steps, but works once done. As described previously..bring up the Mail log-page. Access the javascript by Right clicking in the the "Yahoo! ID" box. Change the "auto-complete" to "on" in both locations...hitting the enter button after each change. Close the Javascript window via X in the upper right hand corner. Test your log-in. Now sign out of Yahoo mail and close your browser. When your re-open your browser and bring up Y-mails log-in page, it may seem it will not display you previously save user name. Go outside the ID box and click on the page (no an advertisement..free space..usually just to the right of the box.) Then, go back to the ID box..click in it...then click it again. For me it brought up my saved id. The downside part of this is, you have to do this procedure with each Yahoo ID individually. Once done, when you click into the ID box, using the click "outside the box" procedure, you should be good to go as all the ID's/passwords should have been save. Ridiculous?.. I totally agree...but until the problem is located and rectified, this works.

Athraithe ag SF BayWolf ar

SF BayWolf 0 réiteach 3 freagra

works?

works?

Athraithe ag SF BayWolf ar

Kiu_RO 0 réiteach 3 freagra

I had also this problem. Try before login to check 'keep me signed in' and after that in ID list will appear your saved login ID's. I don't know if this make sense or is something logical behind, but checking this mark solved my problem. Mozilla version 24.

I had also this problem. Try before login to check 'keep me signed in' and after that in ID list will appear your saved login ID's. I don't know if this make sense or is something logical behind, but checking this mark solved my problem. Mozilla version 24.
oceanofdiamonds 0 réiteach 4 freagra

Thank you.

Checking the 'keep me signed in box' works, but so does UNCHECKING the box, if it happens to be checked. Somehow Firefox is demanding that I exit the username field by checking somewhere, anywhere outside the login field, then re-enter and provide the next character in the string.

Ugh.

Thank you. Checking the 'keep me signed in box' works, but so does UNCHECKING the box, if it happens to be checked. Somehow Firefox is demanding that I exit the username field by checking somewhere, anywhere outside the login field, then re-enter and provide the next character in the string. Ugh.
Saeid-T 0 réiteach 1 freagra

I had the same issue, but now SOLVED. The idea of changing the "autocomplete=off" to "autocomplete=on" was helpful for saving the ID and PW. But, then, I found it works just once then the problem happens again. Here is the simple solution: after you saved the ID and PW by changing the "autocomplete=off" to "autocomplete=on", every time you want to log in, just left click on password field first then left click on ID field. Your Yahoo ID will then appear and the saved PW comes next.

For changing the "autocomplete=off" to "autocomplete=on", as one the posts already says:

Right-click the username field and choose Inspect Element (Q). This will call up a pane (or optionally a separate window) where you can view and edit the HTML tag which creates the username field. There you can edit the autocomplete="off" to autocomplete="on" by double-clicking off and typing on and then pressing Enter. I have attached a screen shot.

Then when you log in, Firefox should offer to save your login.

Hope your issue is solved now.

I had the same issue, but now SOLVED. The idea of changing the "autocomplete=off" to "autocomplete=on" was helpful for saving the ID and PW. But, then, I found it works just once then the problem happens again. Here is the simple solution: after you saved the ID and PW by changing the "autocomplete=off" to "autocomplete=on", every time you want to log in, just left click on password field first then left click on ID field. Your Yahoo ID will then appear and the saved PW comes next. For changing the "autocomplete=off" to "autocomplete=on", as one the posts already says: Right-click the username field and choose Inspect Element (Q). This will call up a pane (or optionally a separate window) where you can view and edit the HTML tag which creates the username field. There you can edit the autocomplete="off" to autocomplete="on" by double-clicking off and typing on and then pressing Enter. I have attached a screen shot. Then when you log in, Firefox should offer to save your login. Hope your issue is solved now.
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159013 freagra

It is usually easier to use a bookmarklet to remove the autocomplete=off attribute(s).

It is usually easier to use a bookmarklet to remove the autocomplete=off attribute(s). *http://kb.mozillazine.org/User_name_and_password_not_remembered