X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Saved username and passwords no longer works on Yahoo Mail

Postáilte

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin.

I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers.

This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin. I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers. This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Réiteach roghnaithe

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

Read this answer in context 1

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • NPWLPG

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

Tuilleadh Eolais

oceanofdiamonds 0 réiteach 4 freagra

Thanks, Saeid-T.

Your 'solution' simplifies things slightly, and points to a better understanding of the problem. Note that this problem has nothing to do with autocomplete being off.

The further clue your method provides is that all that is required to 'cock' the autocomplete (you 'cock' the trigger of a revolver) is to click . . . anywhere on the sign in screen once BEFORE clicking in the username field. Then, enter the first letter of the username and - voila!

I don't speak Java, but I assume that, if I did, I would see some superfluous code in the autocomplete.

Thanks, Saeid-T. Your 'solution' simplifies things slightly, and points to a better understanding of the problem. Note that this problem has nothing to do with autocomplete being off. The further clue your method provides is that all that is required to 'cock' the autocomplete (you 'cock' the trigger of a revolver) is to click . . . anywhere on the sign in screen once BEFORE clicking in the username field. Then, enter the first letter of the username and - voila! I don't speak Java, but I assume that, if I did, I would see some superfluous code in the autocomplete.
_arcticwolf 0 réiteach 5 freagra

SOLVED FIX ANSWER TO YAHOO MAIL NOT REMEMBERING PASSWORDS

After reading this thread and no one fixing, but because you were all networking to find the answer I was able to find the answer. It turned out to be simpler than going to inspect q ect. That was very informative for me and lead me to do the following: I simply clicked "Tools" on the mozilla page, "Add Ons" , then in the search box of typed Autocomplete. about 6 add ons came up. Auto-complete 1.6 is the one I selected to install. Volla, problem solved. This add on keeps the auto complete feature on and will over ride yahoo mail settings. Finally I can now click in to yahoo mail like the good ole days. Hope this helps everyone and you all helped me find this answer.

SOLVED FIX ANSWER TO YAHOO MAIL NOT REMEMBERING PASSWORDS After reading this thread and no one fixing, but because you were all networking to find the answer I was able to find the answer. It turned out to be simpler than going to inspect q ect. That was very informative for me and lead me to do the following: I simply clicked "Tools" on the mozilla page, "Add Ons" , then in the search box of typed Autocomplete. about 6 add ons came up. Auto-complete 1.6 is the one I selected to install. Volla, problem solved. This add on keeps the auto complete feature on and will over ride yahoo mail settings. Finally I can now click in to yahoo mail like the good ole days. Hope this helps everyone and you all helped me find this answer.
jude23 0 réiteach 24 freagra

Arcticwolf, that sounds fantastic. I was able to solve the problem back in June or july by unchecking the SSL box (though I realize that didn't work for everyone). But think I'll try this add-on just for good measure(!)

Arcticwolf, that sounds fantastic. I was able to solve the problem back in June or july by unchecking the SSL box (though I realize that didn't work for everyone). But think I'll try this add-on just for good measure(!)
cleverwabbit5 0 réiteach 16 freagra

I tried that but it didn't work, I am on a mac using firefox 22.

I tried that but it didn't work, I am on a mac using firefox 22.
cleverwabbit5 0 réiteach 16 freagra

where is the ssl?

where is the ssl?
cleverwabbit5 0 réiteach 16 freagra

sorry firefox 24

sorry firefox 24
jscher2000
  • Top 10 Contributor
8797 réiteach 71955 freagra

Hi cleverwabbit5, you wrote:

where is the ssl?

I think the poster meant that she turned off SSL security in her Yahoo mail options. You might try that if you're on a wired connection, but I don't recommend it on a wireless connection because it opens you up to session hijacking by anyone in the vicinity of the hotspot (e.g., Firesheep attack).

Edit: corrected incorrect gender references. Sorry Jude!

Hi cleverwabbit5, you wrote: <blockquote>where is the ssl?</blockquote> I think the poster meant that she turned off SSL security in her Yahoo mail options. You might try that if you're on a wired connection, but I don't recommend it on a wireless connection because it opens you up to session hijacking by anyone in the vicinity of the hotspot (e.g., Firesheep attack). ''Edit: corrected incorrect gender references. Sorry Jude!''

Athraithe ag jscher2000 ar

cleverwabbit5 0 réiteach 16 freagra

Thanks for the warning, I won't do it then, just trying to figure it out with all of the yahoo changes driving me crazy

Thanks for the warning, I won't do it then, just trying to figure it out with all of the yahoo changes driving me crazy
jude23 0 réiteach 24 freagra

Yes, "she" (me!) turned off "her" SSL security. I did it on wifi, which I use at home, and have accepted the risks. Basically, preferable to having to reenter my password every 5 min!! Maybe if I spent more time working in public areas I'd reconsider.

Yes, "she" (me!) turned off "her" SSL security. I did it on wifi, which I use at home, and have accepted the risks. Basically, preferable to having to reenter my password every 5 min!! Maybe if I spent more time working in public areas I'd reconsider.
Deafrocks 0 réiteach 1 freagra

First Complete Yahoo ID and Password. Then Click Right Mouse on Yahoo ID "Inspect Element (Q)" Then See At below autocomplete Double Click "off" change type on both autocomplete. Then click Sign in yahoo it will appear pop up to save password. Then try login again double click on password then double click on yahoo. If not then refresh it then do that again double click. Every time you make new username and do same thing to click off to on both autocomplete. Do not use "autocorrect". Good Luck.

'Make sure Privacy Firefox will remember History' just in temporary


Click below Picture you will see it.

First Complete Yahoo ID and Password. Then Click Right Mouse on Yahoo ID "Inspect Element (Q)" Then See At below autocomplete Double Click "off" change type on both autocomplete. Then click Sign in yahoo it will appear pop up to save password. Then try login again double click on password then double click on yahoo. If not then refresh it then do that again double click. Every time you make new username and do same thing to click off to on both autocomplete. Do not use "autocorrect". Good Luck. ''''''Make sure Privacy Firefox will remember History'''''' '''just in temporary''' ''' Click below Picture you will see it.'''

Athraithe ag Deafrocks ar

988413 0 réiteach 2 freagra

I have the same no Username/Password problem with Yahoo Mail and have found that if I open another small application over the Firefox page then click in the Yahoo sign in box the Usernames will appear and I can sign in as usual. This works on my two Windows 7 64 bit machines with both Firefox and Cyberfox. It also happens in OSX Mavericks in Firefox. They are all synced through Firefox Sync but I don't think that makes a difference.

I have the same no Username/Password problem with Yahoo Mail and have found that if I open another small application over the Firefox page then click in the Yahoo sign in box the Usernames will appear and I can sign in as usual. This works on my two Windows 7 64 bit machines with both Firefox and Cyberfox. It also happens in OSX Mavericks in Firefox. They are all synced through Firefox Sync but I don't think that makes a difference.
988413 0 réiteach 2 freagra

Just tried Auto-complete 1.6 and it made no difference.

Just tried Auto-complete 1.6 and it made no difference.
CaseyBlue 0 réiteach 1 freagra

At the risk of repeating this solution, I will post it here. I found it on another thread of Mozilla Support Forum.

Simply click once in the empty Password line, then double click in the Yahoo ID line. Works every time for me.

At the risk of repeating this solution, I will post it here. I found it on another thread of Mozilla Support Forum. Simply click once in the empty Password line, then double click in the Yahoo ID line. Works every time for me.
oceanofdiamonds 0 réiteach 4 freagra

Thanks for your answer. What this comes down to, I believe, is that when the page loads the cursor is inserted in the User ID field. You must 1) exit the field the 2) re-enter the field in order to get the autofill's attention. It doesn't matter TO WHERE you exit the field. Just exit, then re-enter.

Mr. Gorbachev, fix this code!

Thanks for your answer. What this comes down to, I believe, is that when the page loads the cursor is inserted in the User ID field. You must 1) exit the field the 2) re-enter the field in order to get the autofill's attention. It doesn't matter TO WHERE you exit the field. Just exit, then re-enter. Mr. Gorbachev, fix this code!
scraperfect 0 réiteach 7 freagra

I do find autocomplete = off and I change it to ON and hit enter...but I don't see a save button. When I go back to the website and load the password page, it's set back to autocomplete= off.

OH! This isn't for yahoo. It's just another website I use frequently and wish the password would autofill. I to am MAC and Safari works just fine for this site and autofills the password perfectly.

I do find autocomplete = off and I change it to ON and hit enter...but I don't see a save button. When I go back to the website and load the password page, it's set back to autocomplete= off. OH! This isn't for yahoo. It's just another website I use frequently and wish the password would autofill. I to am MAC and Safari works just fine for this site and autofills the password perfectly.

Athraithe ag scraperfect ar

cor-el
  • Top 10 Contributor
  • Moderator
17583 réiteach 159079 freagra

You would have to use an extension or a Greasemonkey script to remove the autocomplete=off, but I don't know if that will make Firefox fill both fields once the name and passwords are stored.

Note that Firefox won't auto-fill a saved name automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.


You would have to use an extension or a Greasemonkey script to remove the autocomplete=off, but I don't know if that will make Firefox fill both fields once the name and passwords are stored. Note that Firefox won't auto-fill a saved name automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list. ---- *Remember Passwords: https://addons.mozilla.org/firefox/addon/remember-passwords/
ogrethemage 0 réiteach 1 freagra

I am having the same issue but it is with everything since updating from FF 20 to FF 25. The only site I was able to get it to save the password for was Mozilla.org (here). I think subsequent versions of FF after v.20 have changed the way they deal with new scripting of webpages where login and password are concerned. I have had to do a combination of things, I had to start FF in safe mode, then right-click in the password field and select view elements and change the autocomplete="off" switch in order to even get the save password dialog box to show up but it only did so momentarily and I still couldn't save passwords so I have had to download and install an add-on to allow me to create/edit saved passwords from within the saved passwords dialog box.

I am having the same issue but it is with everything since updating from FF 20 to FF 25. The only site I was able to get it to save the password for was Mozilla.org (here). I think subsequent versions of FF after v.20 have changed the way they deal with new scripting of webpages where login and password are concerned. I have had to do a combination of things, I had to start FF in safe mode, then right-click in the password field and select view elements and change the autocomplete="off" switch in order to even get the save password dialog box to show up but it only did so momentarily and I still couldn't save passwords so I have had to download and install an add-on to allow me to create/edit saved passwords from within the saved passwords dialog box.