Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

I updated to 20.0 and now my web client I use to monitor my home security (My-Q see) no longer works. What do I need to do.

  • 42 freagra
  • 16 leis an bhfadhb seo
  • Freagra is déanaí ó Ali Baba

more options

My remote monitoring for my security ( My-Q see) worked fine until I updated to 20.0. Now Firefox pops up asking me to install web plug in kit. when I do, it still does not work even after restart.

Réiteach roghnaithe


Install GreaseMonkey:

Then install the userscript on this page:
Use the Install button in the upper-right corner of that page.

Then you may need to edit line #50 of that script

var j=""; 

to the Q-See Plugin version number that you have installed.

GreaseMonkey user manual is here -

Read this answer in context 👍 2

All Replies (20)

more options

Which plug-in is it trying to install? From what I can quickly find, it looks like My-Q see uses ActiveX, and the company's manuals are IE-only (or Firefox with IE Tab add-on).

Another thread about this software and Firefox (links to company's manual):

IE Tab add-on, if they're still using ActiveX for your security system model:

more options

I tried all the options listed above and still does not work in firefox. I can view all my cameras in IE and chrome with no problems.

more options

I have the same problem = using Firefox to view my Q-See system worked completely fine prior to upgrading to V20.0... I have fiddled around a little bit with some about:config settings, but no luck.

One of the about:config settings I tweaked was "plugins.click_to_play" = I set this to true. After doing so, when I reloaded the URL which should work, I see that Firefox does know about the "DVR Client". I think the plugin is starting, but somehow is now not giving the ability to log into my DVR.

BTW, the "DVR Client" my Firefox shows is installed is

more options

My wife is having this problem while my laptop was just fine. But after I closed FF completely and re-opened on my laptop I saw a very brief "firefox is checking compatibility of plugins" box. After that the webclient plugin isn't working on my laptop either. My version is - directly downloaded from the DVR itself, I'm not sure where to get updates if they even update the plugin.

more options

There is still no solution for this problem. I've tried all suggestions and it keeps showing the same message. It would work just fine if I install Firefox 19.0 back on. I personally believe that Firefox 20.0 has problem with npwebclient.dll.

more options

I have the same problem with Firefox 20.0 and 20.0.1 . I have tried changing various Firefox settings with no luck.

In Firefox version 19.x I was able to access the Q-See application with its native plug-in which is downloaded from the Q-See DVR, it didn't require any additional plug-in's.

I am providing some additional technical information that may be helpful to a Firefox expert.

Q-See DVR model qt-426

Firefox url to access q-see dvr http://q-see-ip-address/WebClient.html

Q-see Plug-in information: Plugin name DVR Cleint; Web Camera; File npwebclient.dll; Mime Type application/x-dvrwebclient (npwebclient)

Q-See Plugin installer setup.cmd file text listing:

REM ×¢²áacitvex¿Ø¼þ

regsvr32 /S npwebclient.dll

REM Ìí¼Ófirefox plugin ×¢²á±í reg delete "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /va /f > nul

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /v "Path" /t reg_sz /d "C:\windows\system32\WebClient\npwebclient.dll" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /v "Version" /t reg_sz /d "" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /v "ProductName" /t reg_sz /d "EDVR Web Client" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /v "Description" /t reg_sz /d "EDVR Web Client Plugin" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient" /v "Vendor" /t reg_sz /d "" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient\MimeTypes" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@EDVR/WebClient\MimeTypes\application/x-dvrwebclient" /f

REM Ìí¼Ó¿ØÖÆÃæ°åɾ³ý³ÌÐò

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\WebClient" /v "DisplayName" /t reg_sz /d "WebClient" /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\WebClient" /v "UninstallString" /t reg_sz /d "c:\windows\system32\WebClient\uninstall.cmd" /f

REM ÐÞ¸Äfirefox²å¼þ³¬Ê±Ê±¼ä300Ãë

REM chdir "C:\"

REM for /f "delims=" %%i in ('dir /a-d /s/b prefs.js') do echo

user_pref("dom.ipc.plugins.timeoutSecs", 300); >> %%~fi

REM chdir "C:\windows\system32\WebClient"

REM ɾ³ý×ÔÉí

more options

Okay! This is good! Thank you tarnationsauce2, leang, and mg581 for adding your postings, and dkraum for starting the thread! Hopefully by "pooling our ignorance" we can help to solve this issue!

I really do sense that the "DVR Client" is starting up "behind the scenes", but that the login prompt is somehow being blocked from displaying. Why do I think this?

Previously, when life was good under FF v19, when I would use the web access pathway to my QT548 I always noticed upon closing the tab I had open in Firefox which was displaying my QT548, that Firefox would "pause" for a few seconds before I could "use" other tabs/web pages currently open. NOW, with FF v20, even though I get the dreaded "please click icon to load and install WebkitPlugin:" prompt, when I close the tab ONCE AGAIN I experience the "pause" I've always experienced before.

I suspect there was some sort of "security" change, from FF v19 to v20, that is simply blocking the "full" startup of the plugin AND/OR is simply blocking the display of the login prompt...

BTW - I have seen some perhaps older "solutions" for accessing a Q-See DVR by utilizing the add-on "IE Tab". I never had to use the "IE Tab" add-on to access my QT548, nor do I want to now... As much as a love Firefox add-ons and use Firefox because of them, I don't want to install another one!

more options

I think the problem may be how the new v20.x processes the html code and scripts from the Q-See DVR. It seems have a problem in being able to either detect the Plug-in properly or is unable to properly parse the code.

For any Firefox developers who may not own a Q-See DVR, but can help debug this problem here is a public Q-see demo URL.

Basic URL, does detection of web browser type or device and re-directs depending on what it detects:

Firefox and other web browsers specific URL:

IE web browser URL:

I ran the Firefox v20 "Error Console" under the Tools->Web Developer->Error Console" and it is displaying some Warnings, but I need to run the Error Console on a v19 Firefox and see if there are different warning messages.

more options

I am also having this problem. Like cheesemonkeyboy1, I also don't want to have to use another browser's addons to be able to use this.

I am also not clever enough to be able to sort this out, so any help will be great. Thanks for getting this going.

more options

I also have the same problem and I think I narrowed down the problem to the main.js script where it checks a constructor to see if it's an Object or HTMLEmbedElement and continue on if it's either or. In previous versions, WebClient.constructor==HTMLEmbedElement returned true but now it doesn't therefore it doesn't think the plugin is loaded (which it actually is).

Here is the actual line of code if it helps:

if((f&&(k!=""||WebClient.constructor==Object))|| !f&&(WebClient.constructor==Object||WebClient.constructor==HTMLEmbedElement))

var f = true if it's on a macOS (for x86 firefox users it should be false)

var k = Mac's plugin version (this should also be blank/null)

and as an fyi:

WebClient = [object HTMLEmbedElement]

WebClient.constructor = [object Function]

I am not a web page/html developer so I can't tell you if that check for Object or HTMLEmbedElement is proper or not but it worked before, the plugin is recognized and loaded by firefox and if you bypass that check it loads up just fine.

more options

Hi P.G., I looked at the demo page and I think you are correct about the problem. It seems the EMBED tag doesn't respond to the constructor method the way it did before. I can't think of a browser-based workaround for this. How did you bypass the check -- do you have a local version of the page when you actually use the service?

more options

I would like to try this. Thanks for the feedback.

How do I access the main.js file? Is this on the actual DVR or a local file?

more options

I haven't found a browser work around either.

What I did to debug it was I used the Web Developer tools that come with Firefox, saw what files were pulled from my DVR and then manually pulled them over and put them in a proper folder structure as it would be on the dvr/server itself.

Then I went through the main.js and manually re-formatted the file to make it readable and much easier to debug (original is all on one line making debugging painful).

Ran the local copy through Firefox with the dev tools enabled and got to that check, checked the values and both conditions returned false. I then modified the local copy to ignore the constructor check and got into the log in screen.

It doesn't connect to the dvr past the log in screen because the rest of the local copy has to be modified to point to the dvr vise your local machine.

To pull the files I used WGET for windows. Sorry don't have link at the moment...I'm at work...

more options

For everyone that still can not get Fire Fox to work, the Chrome browser works fine with the Q-See program,

more options

I can't log in using the IE tab method that used to be the only to connect before Q-See updated to the new plugin. I might have to use *ghasp* actual IE. I haven't even started that program in years.

more options

I have been having some quirks with it when running under IE10, like when trying to search events and the camera list/checkbox keeps groing on it's own. But what I did do is I used grease monkey to "re-do" the OnLoadPage function with the proper fixes and got it to work (so far).

more options

Hi P.G., that's brilliant. Did you post the script on or anywhere else for sharing?

more options

I just uploaded it to Named:

Q-See DVR Plugin v1.1.1.25/Firefox 20 Fix.

Hope it works for you... if not, it may need some tweaking for your version of the plugin, if it differs any.

more options

Once again, mine didn't work after installing the script that P.G. handed out.

more options

I was not successful using Chrome either. But I did capture this from Chrome's developer tools. Notice the exception near the top of the script on the call to 'offsetHeight' that I braced in <<--->>. The script seems to die and never load because I don't make it to the login form that is supposed to display.

function GotoWebKitPage() {
<<---Uncaught TypeError: Cannot read property 'offsetHeight' of null--->>

    document.getElementById("div_ocx").style.width = "1px";
    document.title = html_title;
    if (g_bupdate) {
        g_bupdate = false
    } else {
    var c = document.all ? document.getElementsByTagName("html")[0].offsetHeight : window.innerHeight;
    var b = document.getElementById("table_load").offsetHeight;
    var a = ((c - b) / 2) - 160;
    document.getElementById("table_load").style.marginTop = a + "px";
    document.getElementById("div_load_webkit").style.display = ""
function sleep(a) {
function LoadWebKit() {
    var c = CreateLoadWebKitXml();
    var d = WebClient.ExcuteCmd(c);
    var b;
    for (var a = 0; a < 5000; a++) {
        b = setTimeout(sleep, 1000)
    if (b != 0) {
function CreateLoadWebKitXml() {
    var a = "<request>\r\n";
    a += '<command name="' + STR_REQUEST_LOAD_WEBKIT + '">\r\n';
    a += "</command>\r\n";
    a += "</request>\r\n";
    return a

Athraithe ag cor-el ar

  1. 1
  2. 2
  3. 3