Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Copy/paste in a Word document loses its format (bullet points, coloured tex, etc) when Firefox is open. When I close Firefox it is fine again. I am not talking about copying and pasting text between MS Word and Firefox. It is within MS Word itself.

  • 13 freagra
  • 15 leis an bhfadhb seo
  • 5778 views
  • Freagra is déanaí ó jscher2000

more options

Firefox 11.0 MS Word 2003 Basic Edition SP3

Athraithe ag breum12 ar

Réiteach roghnaithe

Can be caused by the Skype Click to Call extension.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 👍 4

All Replies (13)

more options

Réiteach Roghnaithe

Can be caused by the Skype Click to Call extension.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Athraithe ag cor-el ar

more options

Disabling the the Skype Click to Call extension fixed the problem. Many thanks !!!!!!

more options

You're welcome

more options

thanks a lot. I was totally hopeless because I am writing a book and all in a sudden the footnotes disappeared when I did a copy/paste. You can understand the agony I went through. I looked for a day on the internet for solutions and did not find any that worked.

But I am totally flabbergasted with the solution. How the heck is it possible that skype interferes with MSWORD??????? And how did you discover this??

more options

I noticed that copy/paste sometimes worked and sometimes not. And then the process of elimination began. It finally turned out that Firefox was the culprit. Why it interferes with MS-Word is still a question to me as well.

more options

Although i disabled it in Firefox, the trouble started again. Then I discovered that the Skype click to call addin for Chrome causes the same problem.

Hence, it isn't Firefox that is the culprit but Skype.

A big problem is that nowhere on the Skype site there is a page to post major bugs.

Anyway, thanks again

Athraithe ag thamcore ar

more options

Thank you!! I was going crazy trying to figure out why my cut and paste or even paste special was messed up! I changed options, tools, templates, etc. until I found this answer. I had recently started using Skype again, but do agree it is Firefox. I closed down my browser and then was able to cut and paste with formatting as before.

more options

For my opinion the problem with Skype interfering copy/paste on MSWORD can be solved in maybe three ways. Iam not a programmer.

first way is: set the skype-options in that way that skype is not launched

         on windows-startup or exit/end Skype before using MSWord.

second way: use 'open Office' or 'libre Office' instead of MS Office

third way: force 'SKYPE' to fix that bug

regards Paule___

Athraithe ag Paule___ ar

more options

Skype may be part of the issue, but it is by no means the whole story. I have the same problem - running Firefox 14.0.1 on Win7 Pro - and Skype is NOT installed nor has ever been.

This is most assuredly caused by Firefox: shutting down Firefox corrects the problem. All the usual "Troubleshooting" mechanisms - safe mode, disabling add-ons, etc. - fail to fix the problem.

This is an entirely reproducible problem. Here are the steps: 1) Launch Firefox. 2) Launch Word (2007). 3) Open a document with formatting (say, bullets, color highlighting, etc.) 4) Copy some formatted text. 5) Open a new Word document 6) Paste the contents of the copy buffer (clipboard) into the new document.

All formatting is lost.

Bonus steps for the diagnostics wonks: 7) Select the contents of the new document and delete (i.e. delete key). 8) Go back to the first document; re-select and re-copy the same text. 9) Go to the new document and paste it again.

Bada boom, bada bing: the paste works correctly this time. Incidentally, I've tried the same experiment from other apps (like copying from Visual Studio's code editor to Word or Outlook); same outcomes.

Control Test: 1) Shut down Firefox

Repeat steps 2-6. Word behaves normally (i.e. the copy/paste operation retains the formatting the first time.)

If IE (v8.0) is used as the browser instead, the problem does not occur.

Some years ago I abandoned IE in favor of Firefox. It appears that it may be time to reverse that decision.

more options

Hi spmallett3, that's very peculiar.

If instead of using Paste, you drop down the Paste button on the ribbon and choose Paste Special, does the dialog show the other customary Word formats (e.g., RTF)? Do those work or are they also corrupted?

Note: I've never seen this behavior in Word 2003, Word 2007, or Word 2010. However, I do not currently have access to Word 2007 to test with.

Athraithe ag jscher2000 ar

more options

Hi spmallett3, could you try three other scenarios?

(1) Double-copy the first time, i.e., Ctrl+c Ctrl+c, and then paste. Any difference?

(2) Start up Firefox in a new profile (i.e., with a clean settings folder).

Fully exit Firefox, then from the Start menu search or run box:

firefox.exe -p

Click Create Profile, assign a name like Fx14, and accept the defaults. Then check copying/pasting in Word. Any difference?

(3) Manually disable all plugins in the new profile using:

orange Firefox button > Add-ons > Plugins

I don't know whether you need to exit and restart Firefox in order for this to fully take effect, I suppose you could try both. Any difference?

To return to your regular profile, fully exit Firefox and go back to the Profile Manager dialog, highlight your regular profile, and click Start Firefox.

I appreciate your efforts to help track this down.


Finally, in case some malware/spyware is running only when Firefox is active (to disguise its web traffic), you may want to run some supplemental scans. These two tools are highly regarded:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

more options

Hello JScher2000

Keeping in mind that I make my living in SQA (ergo this, for me, is working for free), I ran dozens of test scenarios. The net result is that once again it's proven that no good deed goes unpunished. (See the end of this note.)

To answer your questions: The "Paste Special..." dropdown shows only "Unformatted Text" and "Unformatted Unicode Text" as its only options. For all I know, this is the 'normal' behavior - I don't use that particular feature and this machine (new in May) was set up by members of the IT group. However, as it happens, I also got a new Win7 machine for home use in June that's running the Office 2010 suite and the behavior is the same.

Double copy followed by paste doesn't make a difference. (I'd actually tried that in the earlier runs.)

I then ran with a new profile. At first there was no difference. Then I disabled all the plug-ins and initially, that seemed to fix the problem. Further testing showed this not to be the case.

The short version of dozens of runs was that the behavior was somewhat unpredictable. Certain test cases - the one I outlined earlier - seem to behave consistently. But other times the results were unpredictable: sometimes the formatting was retained in the paste, sometimes not.

On a hunch, I re-enabled the plug-ins, exited Firefox, restarted the Profile Manager, nuked the test profile, and launched with the default profile. I made several dozen more runs with the same results that I had under the test profile.

With, now, one added item. (Remember I mentioned punishment?) Now when I launch Firefox, it opens three *three instances*, one with the previously opened tabs/pages, two with just the home page. I tried this half a dozen times with the same result.

After writing that last paragraph, I seem to have stumbled on a "fix" (if I may take liberties with that term). After launch, I closed the home-page only instances leaving open only the instance with the several tabs/pages I'd been browsing when I exited. Then I launched Firefox again from the start menu; it opened to the home page. I closed both instances and now the Firefox launch is behaving correctly - one instance, previous tabs/pages.

So all's well that ends well (sorry - this sort of software issue brings out my sarcastic side). In the end, the only sure-fire fix is to not run Firefox. I guess it's time to find the page that describes how to import the hundreds of work-related bookmarks I have in FF into IE.

more options

Normally when you copy text in Word, you get several formats on the clipboard. "Something" is trashing all the alternate formats. Firefox does not natively do that, and you've ruled out add-ons, so I'm not sure we will solve the mystery.

As a final test: can you launch Word with add-ons, macros, and custom settings disabled to rule out anything on the Office side?


winword.exe /a

It's very easy to move bookmarks from Firefox to IE. Export an HTML file from Firefox (Export Firefox bookmarks to an HTML file to back up or transfer bookmarks) and import it into IE.