Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to stop Firefox upgrading to a new version that keeps crashing.

  • 27 freagra
  • 28 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó gemma.laming

more options

I have had enough of Firefox crashing. I do not mind having a slightly slower browser, I do mind it crashing.

I would like to know a SIMPLE way to stop automatic updates. I am actually using a Dutch version of Firefox, which in their attempt to make things easier for us has a different layout :-(

I am now extremely unhappy with Firefox. Since the upgrade before last it has done nothing but crash. If it is not possible this time to switch out the automatic updates - so that I can update to the previous version that (hopefully) no longer crashes, then I shall simply move to Chrome. Sorry.

All Replies (20)

more options

-> Update Firefox to the latest version 10.0.1

Check and tell if its working.

Athraithe ag Hasan ar

more options

"Check and tell if its working."

Thanks 007, but could you tell me something I could do, please?

I need a simple answer that I can implement. I have this problem every time Firefox updates, and I am getting fed up with it. Sorry.

more options

Hi,

Try starting Firefox in Diagnose Firefox issues using Troubleshoot Mode and type about:crashes in the Address Bar then copy and paste the entire page in a new reply here.

more options

Hi MJB

thanks for that, it took only a few minutes - - - and it worked (!!) I will add that I only send a crash report on a few occasions, around one time in three. This is the list you wanted:

Rapport-ID  Verzenddatum

bp-4c606421-5e33-48a4-9e9b-f4d15212021414-02-1215:26
14dff207-5573-9dcc-27707971-45c8306114-02-1215:04
1266dd54-b1b8-b808-505f91fa-1a02d46c14-02-1215:02
3d82fa89-4dd2-04bd-61767b9d-69422d7614-02-1200:00
bp-c5563434-7d79-42a1-96a1-c5645212021313-02-1210:14

As you can see, it is something I am getting used to ...

Athraithe ag cor-el ar

more options

Perform the suggestions mentioned in the following article:

Check and tell if its working.

more options

Actually, if it works fine in "safe mode" as it is at the moment, I will be happy.

I am not sure if any of the things mentioned in your recommendation actually apply to me - I have only one plug-in and it is disabled (but not removed).

My problems started when I upgraded to Firefox 10 - which is why I would like to go back to Firefox 9 (or any version that simply works without crashing - like "safe mode"!).

more options

If its working fine in -> Diagnose Firefox issues using Troubleshoot Mode, then perform the suggestions mentioned in the following article:

Check and tell if its working.

more options

Thanks, I will see if it crashes tomorrow, and if it doesn't, then it stays as it is!!

I can delete any plugins I have - they aren't used anyway (the one that is left ... )

All I need to know now is how to stop Firefox making automatic updates. I can't find it in the advanced section of the Voorkeuren (options?) because it is set out differently from the English version, which is a real nuisance!

more options

Try to disable hardware acceleration.

  • Edit > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

more options

@Cor El

can you tell me what "hardware acceleration" is, and why it might make my system crash?

I have enough problems with updates - of any kind - to want to update anything any more! In all honesty, Ubuntu 6 or 8 would be more than sufficient for my needs in terms of speed and capability - with the obvious exception of internet nasties.

more options

Did you try to disable that setting?

Hardware acceleration means that Firefox access the graphics display directly to improve performance and bypasses operating system call that provide more compatibility.
If Firefox doesn't work well with the graphics display driver then all kinds of problems can occur.

See also http://hacks.mozilla.org/2010/09/hardware-acceleration/

more options

Good morning Cor-El

okay: my hardware acceleration was already switched off (or at least there was a tick/check in the box beside it).

I will have to research the driver-updates for my graphics whateveritis.

In the mean time, is there any way to stop Firefox automatically updating? I noticed in my burrowings in the Preferences box that there is no way to do it there, which seems odd to me. How can I do this? If I was able to remain "behind the curve" by one version of Firefox, I would have a reasonable Firefox because my problems always start with a fresh update.

It is like when I updated to Ubuntu 10 - which I was pursuaded to do so that my computer "would work better" and so on. I can frankly state with all the problems it caused me, I wish I had stayed with Ubuntu 9. I will not be upgrading to Ubuntu 11, 12 or 13 any time soon! (Unless it is imperative to do so).

BTW I have just re-started Firefox for whatever update they needed this time.

more options

Starting with the release of Firefox 10, the previous versions of Firefox (4.0.x, 5.0.x, 6.0.x, 7.0.x, 8.0.x, 9.0.x) are no longer maintained with Security and Stability updates. Firefox 3.6 is the last previous Firefox version that is still being maintained.

Firefox versions 4.0.x, 5.0.x, 6.0.x, 7.0.x, 8.0.x, 9.0.x contain Security Vulnerabilities that are known and could be exploited by some websites to gain unauthorized access to information or to disrupt critical processing. Only the Latest version 10.0.1 and an Older version 3.6.25 of Firefox are secure against these known vulnerabilities.

If you opt-out of Updating to the latest Firefox version, you will not receive Critical Security Updates that may keep you Safe Online.

-> 10 Reasons to Upgrade to the Latest Firefox Version

Athraithe ag Hasan ar

more options

Thanks, that was the reason I was told that I should upgrade - could you tell me how to install Firefox 3.6 I need a sensible stable browsing platform. With the finesses that Firefox 10 give me (crashes) I can do without it.

I would also like to know how to disable automatic upgrades to Firefox "n" so that I don't have to downgrade again!!

more options

As a backup, you can use Mozilla Firefox Portable Edition

Mac versions of Firefox Portable can be obtained here:

Athraithe ag Hasan ar

more options

Thankyou 007

First point: "Firefox 3.6 will only be maintained with security and stability updates for a short period of time." - how long? A month, a year? it is rather lacking in the specifics I expect of tecchies!

Second point: once Firefox 3,6 is no longer servicable, I am back to square one. I will have newly installed Firefoxes that continue to crash.

My two questions (again, for clarification).

(1) IF I DO NOT MOVE TO FIREFOX 3,6 THEN I NEED TO DOWNGRADE TO THE LAST (STABLE) VERSION OF FIREFOX THAT IS AVAILABLE

(2) I WILL NEED TO STOP FIREFOX FROM UPDATING AUTOMATICALLY SO THAT I CAN RETAIN A BROWSER THAT DOES NOT CRASH

So far I have not had much in the way of repsonses to these questions. If the last firefox (9) is no longer "safe" then what am I to do? Firefox 10 is not working for me. Firefox 3,6 is available "for a limited [but undisclosed] time".

In short, is Chrome the answer?

Athraithe ag gemma.laming ar

more options

You said, okay: my hardware acceleration was already switched off (or at least there was a tick/check in the box beside it).

Open Firefox 10 in Diagnose Firefox issues using Troubleshoot Mode, go to the Options window - Advanced panel (General tab) and look again. If the "Use hardware acceleration when available" box has a check mark that means it's turned on, which is the default setting. You have to clear the box to turn it off.

P.S. In case it helps, here is the crash report for the first Crash ID on the list you posted:

https://crash-stats.mozilla.com/report/index/4c606421-5e33-48a4-9e9b-f4d152120214
Firefox 10.0.1 Crash Report [@ libdbus-1.so.3.4.0@0x1077 ]

Athraithe ag AliceWyman ar

more options

Thanks, Alice. That point was not made clear to me.

However, in safe mode Firefox has not crashed today. I am hoping it won't.

Is there any problem with leaving Firefox in safe mode?

Can you give some suggestions as to my two questions above, please? It seems that as soon as these things are mentioned, the answers stop. Is it just me?

more options

If Firefox doesn't crash in Diagnose Firefox issues using Troubleshoot Mode, it could because hardware acceleration is temporarily disabled while you run Firefox in that mode. Besides disabling hardware acceleration, Firefox Safe Mode also disables added extensions and the default theme and default localstore settings (window size and toolbar settings and controls) are used. Also disabled are the Just-in-time (JIT) JavaScript compiler and any changes made via userContent.css and userChrome.css. Ref: http://kb.mozillazine.org/Safe_Mode

If you don't mind not using Firefox extensions or themes, not saving window settings or toolbar customizations across sessions, etc. I suppose you can continue to run Firefox that way but why not simply disable hardware acceleration and restart Firefox, to see if that resolves the problem?

Athraithe ag AliceWyman ar

more options

Thanks Alice, I understood half of that ... but the second paragraph was clear enough :-)

I will give it a go tomorrow and see what happens - whatever else, in safe mode it has not crashed today - and to be honest I have not noticed any difference to how it browses. Whatever hardware acceleration does (or does not do) it seems to make little difference to me, so it seems to be the thing to go. But not now, thanks. I will let you know how it goes.

Can I ask what a JIT Javascript does? I have a vague understanding of javascript (and html - but rudimentary).

  1. 1
  2. 2