Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

it is possible to look back in history for more than 7 days ?

  • 5 fhreagra
  • 4 leis an bhfadhb seo
  • 792 views
  • Freagra is déanaí ó Xircal

more options

Is it possible t0 look back in the history for more than 7 days? 7 days is the default...

Thanks in advance for your comment.

Jan

Réiteach roghnaithe

Try this.

  • In the location bar, type about:config and click OK.
  • Copy/Paste the following into the filter at the top: browser.history_expire_days to isolate that setting.
  • Presumably, it's going to say "7" because that's all you can see. So right click it and choose Modify from the menu, delete the figure which is in there and replace it with 180
  • Then go to File | Exit, restart Firefox and do a bit of surfing to build up some history.

Check it again tomorrow to see if anything has changed.

Read this answer in context 👍 2

All Replies (5)

more options

The default is actually 180 days, but you may have configured it to only remember 7 days. The setting in that version can be found in Tools | Options | Privacy

Incidentally, you'd be well advised to update to v3.6.16 via Help | Check For Updates. There was a security breach at an SSL Provider recently and a number of fraudulent certificates fell into the wrong hands. Those can be used to impersonate any site including online banking and older versions of all browsers will not display a warning. Version 3.6.16 blacklists those certificates.

more options

I did everything you recommended, but the limit is still set to 7 days. I can choose between Today, Yesterday and last 7 days. Are there any other possible solutions?

Thanks in advance.

more options

Réiteach Roghnaithe

Try this.

  • In the location bar, type about:config and click OK.
  • Copy/Paste the following into the filter at the top: browser.history_expire_days to isolate that setting.
  • Presumably, it's going to say "7" because that's all you can see. So right click it and choose Modify from the menu, delete the figure which is in there and replace it with 180
  • Then go to File | Exit, restart Firefox and do a bit of surfing to build up some history.

Check it again tomorrow to see if anything has changed.

more options

I took your advice and it worked! thanks for the effort. Sincerely,

janB.

more options

You're welcome.

Could you click the "Solved" button to take your post out of the loop please?

Thanks.