Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

trackpad 2 finger zoom does not work, is there a fix or do I go back to Safari?

  • 10 bhfreagra
  • 87 leis an bhfadhb seo
  • 314 views
  • Freagra is déanaí ó briandsk

more options

I have a 1.5 year old Macbook Pro. After I changed to FF 4 I cannot zoom the page with two fingers. It will zoom in the view tab at the top of the page or using Command/+

All Replies (10)

more options

Some gestures have been removed in Firefox 4.

You can restore the zoom feature by changing the values of the related prefs on the about:config page.

browser.gesture.pinch.in -> cmd_fullZoomReduce
browser.gesture.pinch.in.shift -> cmd_fullZoomReset
browser.gesture.pinch.out -> cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift -> cmd_fullZoomReset
browser.gesture.pinch.latched -> false

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Athraithe ag cor-el ar

more options

If my problem can be fixed this way why doesn't Mozilla do this fix for all. I am reluctant to do the fix because it may not work, or may cause problems with my other browsers which do work properly now.

more options

It happened as the consequence of this bug:

  • Bug 613909 – Disable pinch gestures by default & revert three finger vertical swipe gestures
more options

Changes like that made inside of Firefox aren't going to affect other programs, only Firefox.

more options

I followed the suggestion above. Changed the value of 'full zoom reduce' and 'enlarge' with latched at 'false' . It worked. I didn't change the other since I don't think I need it.

@cor-el, thanks for the help.

more options

I opened Firefox and typed the about:config, and a Google search came up, not the about config page. Is this action for a Mac or PC?

more options

OK, I found the about:config page without putting i the "" part, got the warning and changed the first four lines, but on the fifth one the "latched" one, I was only able to change it from true to false, it was shown as a boolean item not a string so the -> is not on the line. It did not fix my trackpad control.

more options

Next try changing only the 'full zoom reduce' and 'enlarge' with latched at 'false' like qnhan said, but still did not work. I then changed back to the default to go back to the orginal setting. I gues I give up until Mozilla fixes it. Thank all for for your effort.

more options

Thanks cor-el! I had the same problem, and this fixed the bug for me!

more options

Trackpad problem still exists with FF 5. The about:config instructions do not solve the problem on my MacBook Pro. Yes, I'm using Nosquint and Theme changer to try and deal with it. I want my original functionality back. How do I do this? Is Mozilla even remotely interested in fixing this issue?