Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to not manually delete download files?

  • 5 fhreagra
  • 1 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó gudehh

more options

I am honestly in chock with Firefox's terrible decision of not providing any option for the user to delete downloaded files.

It is honestly amazing that they came up with such a terrible decision. My downloads folder is a complete mess now and there seems to be no way to fix this.

I don't understand why not just provide an option for the user to only open files. People should be able to choose their settings.

I refereed to this previous post and the solution there didn't work: https://support.mozilla.org/en-US/questions/1370409. By setting browser.download.improvements_to_download_panel to false.

Is there actually no way to only open files now?

I am honestly in chock with Firefox's terrible decision of not providing any option for the user to delete downloaded files. It is honestly amazing that they came up with such a terrible decision. My downloads folder is a complete mess now and there seems to be no way to fix this. I don't understand why not just provide an option for the user to only open files. People should be able to choose their settings. I refereed to this previous post and the solution there didn't work: https://support.mozilla.org/en-US/questions/1370409. By setting browser.download.improvements_to_download_panel to false. Is there actually no way to only open files now?

Réiteach roghnaithe

Note that Firefox always needs to download a file to be able to show you this file in a tab.

You can set browser.download.start_downloads_in_tmp_dir = true to revert to the previous behavior to use the OS temp folder.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

(fixed pref name - thanks for noticing)

Read this answer in context 👍 1

All Replies (5)

more options

Réiteach Roghnaithe

Note that Firefox always needs to download a file to be able to show you this file in a tab.

You can set browser.download.start_downloads_in_tmp_dir = true to revert to the previous behavior to use the OS temp folder.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

(fixed pref name - thanks for noticing)

Athraithe ag cor-el ar

more options

This didn't solve the issue. It is browser.download (without s). I tried setting to true and to false, both cases the files go to downloads when selecting open.

more options

Thanks for noticing this issue with the extra 's' on browser.download.start_downloads_in_tmp_dir. Looking on Bugzilla there appears to have been some confusion with documenting this new pref.

Tom Schuster Comment 135 • 4 months ago

I think there is some kind of mistake here. StaticPrefList.yaml calls this pref browser.download.start_downloads_in_tmp_dir, but Policies.jsm uses browser.download*s*.start_downloads_in_tmp_dir. The release page also has the s.
more options

You could try setting this preference in about:config to false. browser.download.useDownloadDir

From searchfox. org: bool True - Save files directly to the folder configured via the browser.download.folderList preference. False - Always ask the user where to save a file and default to browser.download.lastDir [not a preference] when displaying a folder picker dialog

more options

Well, I realized the indicated option in this forum is different from the one I posted at first. They both are:

  • browser.download.improvements_to_download_panel = false
  • browser.download.start_downloads_in_tmp_dir = true

The first one has no effect. The second one actually send downloaded files (when selected to only open) to tmp folder, although I can't actually open them, I can only open PDFs if I selected to open with firefox. This is a workaround which quite works for me, since I download a lot of PDFs regularly, but not best solution at all.

I didn't understand what Terry pointed out.

I am extremely disappointed with firefox, it is unbelievable people actually though this change was a good idea. They are making their software worst.